Jump to content
Калькуляторы

SUP-7203BXL и microflow police

Доброго времени суток!

Имеется вышеназванный девайс, который имеет следующий конфиг:

ip access-list extended TARIF-1M
permit ip any host xx.xx.7.254
ip access-list extended CLIENTS
permit ip any any

class-map match-all CLIENTS
 match access-group name CLIENTS
class-map match-all 1M
 match access-group name TARIF-1M

policy-map OUTSIDE
 class 1M
    police flow mask dest-only 1024000 128000 conform-action transmit exceed-action drop
policy-map 1M
 class CLIENTS
    police flow mask src-only 1024000 128000 conform-action transmit exceed-action drop

interface Vlan800
description UPLINK
ip address yy.yy.58.62 255.255.255.252
ip access-group in in
ip access-group out out
no ip redirects
no ip proxy-arp
load-interval 30
service-policy input OUTSIDE

interface Vlan10
description TEST-CLIENT
ip address xx.xx.7.253 255.255.255.252
service-policy input 1M

Стоит задача прополисить клиента на один мегабит, однако тестовая закачка на торренте показывает что ограничение не отарабатывает вообще, никто не подскажет что делаю не так?

Заранее спасибо.

Share this post


Link to post
Share on other sites

microflow policy на торренты? шутите?

почитайте про них еще раз.

если абонент воткнет 1000 соединений p2p с разными хостами, на каждое из них будет накладываться ограничение в 1мбит/с, а суммарно у вас ограничений нет ;)

Share this post


Link to post
Share on other sites

а можно тогда услышать пример про применение микрофлоу в жизни?

Share this post


Link to post
Share on other sites

Щас посмотрел на список пиров на тестовой машине, много пиров у кого скорость выше чем 1 мегабит.... есть десятки мегабит пиры....

Share this post


Link to post
Share on other sites

в свое время практиковали m/f policy между сегментами крупных сетей на внутресетевом обмене, в итоге никто не засорял сеть тяжеловесным трафиком, за который никто не платит.

Share this post


Link to post
Share on other sites

Понял спасибо, и вот ещё что, а вот у меня таки получилось ограничить торренты вышеприведённым конфигом, путём навешивания сервис полисили на физический интерфейс.... правда пока тока даунлоад....

Edited by catalist

Share this post


Link to post
Share on other sites

darkagent, у него же flow mask dest-only и src-only, т.е. flow будет идентифицироваться только по src или dst ip, а не по паре src-dst, разве не так?

 

catalyst, во-первых вам в прошлой теме говорили кажется, что наедитесь говна на халяву с желанием полисить 2000 клиентов на sup720 в общем, и при использовании microflow policer в частности. Вы понимаете, что из 4х тысяч вланов вы сможте использовать только 64? Во-вторых, проверьте стоит или "mls qos vlan-based" на физических интерфейсах, конфиг вроде у вас верный.

Edited by agr

Share this post


Link to post
Share on other sites

Про предыдущую тему я помню, но у меня стоит задача протестить вот и тестю....

Вы понимаете, что из 4х тысяч вланов вы сможте использовать только 64?

Нет не понимаю, можно подробней?

Во-вторых, проверьте стоит или "mls qos vlan-based" на физических интерфейсах, конфиг вроде у вас верный.

Да стоит.

что наедитесь говна на халяву с желанием полисить 2000 клиентов на sup720 в общем, и при использовании microflow policer в частности

А что мне делать остаётся, 3845 которая есть дохнет под нагрузкой, следующий претендент на роль браса десятитонник ESR я создал тему про него подойдёт ли он мне, но никто ничё внятного не сказал.....

Edited by catalist

Share this post


Link to post
Share on other sites

а зачем сразу ESR? у вас какой траф в инет суммарный in out?

Share this post


Link to post
Share on other sites

насчет 64 VLAN мне кажется вы перегнули палку) 64 тп.

Share this post


Link to post
Share on other sites

 

А что мне делать остаётся, 3845 которая есть дохнет под нагрузкой, следующий претендент на роль браса десятитонник ESR я создал тему про него подойдёт ли он мне, но никто ничё внятного не сказал.....

 

ESR специально создавался для предоставления сервисов, т.е. специализированная железка для (в том числе) и BRAS. И Вам сказали, чтоб вы САМИ прочитали на сайте. Но ESR сейчас или уже почти сейчас EOS. Для BRAS/BNG cisco позиционирует другие железки, в том числе и ASR1000. ASR1001/ASR1002 вам хватит для предоставления сервисов по IPoE. Читайте про ISG на сайте

Edited by Konstantin Klimchev

Share this post


Link to post
Share on other sites

а зачем сразу ESR? у вас какой траф в инет суммарный in out?

Суммарный пока коло полу гигабита, но очень сильно растёт.

 

насчет 64 VLAN мне кажется вы перегнули палку) 64 тп.

Не 64 а 32 так как полисить надо в разные стороны. Есть ещё правда момент в том что если у клиента более одного адреса или на него смаршрутизирована сеть то придётся походу юзать общий полисимап, но таких к счастью не много.

 

 

А что мне делать остаётся, 3845 которая есть дохнет под нагрузкой, следующий претендент на роль браса десятитонник ESR я создал тему про него подойдёт ли он мне, но никто ничё внятного не сказал.....

 

ESR специально создавался для предоставления сервисов, т.е. специализированная железка для (в том числе) и BRAS. И Вам сказали, чтоб вы САМИ прочитали на сайте. Но ESR сейчас или уже почти сейчас EOS. Для BRAS/BNG cisco позиционирует другие железки, в том числе и ASR1000. ASR1001/ASR1002 вам хватит для предоставления сервисов по IPoE. Читайте про ISG на сайте

Везде пишут что АСР очень сырой, да и по деньгам получается дороже, то что ЕСР ЕОС меня не пугает...

Share this post


Link to post
Share on other sites

каталист .. знаете что .. не е@ите себе мозги с сапом - чую времени вы там угробили немало ))

купите ASR1002 плюс доку по isg с упором на TAL

и все будет просто понятно и доступно

или редбэк вроде здесь тоже описывали

ESR вам явно не нужен

 

ASR был сырой под брас года два назад - сейчас это нормальное решение

косяки у них только с натом

Edited by alks

Share this post


Link to post
Share on other sites

Вы понимаете, что из 4х тысяч вланов вы сможте использовать только 64?

Нет не понимаю, можно подробней?

Я в той теме писал, что занятый полисер - это не полисер в общем конфиге, а полисер привязанный к интерфейсу. Вы можете прописать в глобальном конфиге всего один полисер, но повесить его больше чем на 64 интерфейса не получится. Количество уже занятых полисеров можно посмотреть командой:

RT#sh platform hardware capacity qos
QoS Policer Resources
 Aggregate policers: Module                      Total         Used     %Used
                     6                            1024          298       29%
 Microflow policer configurations: Module        Total         Used     %Used
                                   6                64            1        1%

на рутере на котором выполнена данная команда у меня заведено 43 policy-map'а, а занято как видно 298. У меня aggregate, но для microflow будет то же самое.

 

 

 

Во-вторых, проверьте стоит или "mls qos vlan-based" на физических интерфейсах, конфиг вроде у вас верный.

Да стоит.

хм, странно, посмотрите что говорит команда

sh policy-map interface vlXXX

матчится ли трафик.

 

А что мне делать остаётся, 3845 которая есть дохнет под нагрузкой, следующий претендент на роль браса десятитонник ESR я создал тему про него подойдёт ли он мне, но никто ничё внятного не сказал.....

Держать 2000 юриков на одном рутере и на нем же принимать full-view от нескольких аплинков вообще нехорошая идея. Лучше наверно отделить BRAS'ы от бордера. На вскидку не скажу из относительно бюджетных решений, что может поддерживать 2К вланов с полным полисингом, несколько full-view и пропускать трафик выше гигабита. Посмотрите в сторону juniper, j6350(himem) поддерживает 1К вланов и гиг трафика пропустит без труда, или MX80 - он вроде подходит под все ваши критерии, но выйдет подороже.

Share this post


Link to post
Share on other sites

На роль бордера при десятитоннике виделся как раза суп 720... А десятитонник тупо как брас...

Share this post


Link to post
Share on other sites

ericsson se100 спасет отца русской демократии и как брас и как бордер (эти 2 сущности можно/нужно будет разнести по 2-м контекстам).

при условии, что трафика немного - до 3Г с аплинка.

Share this post


Link to post
Share on other sites

Полисит отлично и торренты в том числе тоже. Пузомерки показывают правильные цифры. Полиси стоят на физических интерфейсах. Фактически внутри этой десятки около 30 штук 24 сетей. Вот простой конфиг которым проверял качество резки траффика, сейчас усложнено, сделано несколько тарифных планов.

 

access-list 199 permit ip 10.10.0.0 0.0.255.255 any

access-list 2199 permit ip any 10.10.0.0 0.0.255.255

 

class-map match-any all-10-in

match access-group 2199

 

class-map match-any all-10-out

match access-group 199

 

policy-map ubrl-all-in

class all-10-in

police flow mask dest-only 1024000 128000 conform-action transmit exceed-action drop

 

policy-map ubrl-all-out

class all-10-out

police flow mask src-only 1024000 128000 conform-action transmit exceed-action drop

 

interface GigabitEthernet7/1

service-policy input ubrl-all-in

 

interface GigabitEthernet8/1

service-policy input ubrl-all-out

 

P.S. Мнение коллег о том, что для бордера и браса лучше иметь отдельные железки категорически поддерживаю.

Edited by eek

Share this post


Link to post
Share on other sites

ДА спасибо, всё уже настроили путём пробо и ошибок. Если кому станет интересно могу выложить конфиг.

Правда у нас висит не на физике, а на SVI.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this