Jump to content
Калькуляторы

Хитрый шейпер для MikroTik

Имеется сеть с доступом в интернет через MikroTik RouterOS 5.12.

Все пользователи сети получают полный канал, который приходит на шлюз.

Все пользователи работают на NAT и имеют статические IP адреса.

Имеется один юзер, которому нужно выделить большую полосу.

То есть, допустим канал 2 мегабита. В начале месяца подключаем 4 мегабита специально для этого(нового) юзера.

И как зашейпить всех старых юзеров на 2 мегабита(чтобы было всё по старому), а новому выделить стабильно 2 мегабита(которые были подключены именно для него)?

IP ему будет так же назначен статический вида 10.1.1.0/24.

 

Можно, конечно вгонять все IP в queue и уже там уникально для каждого прописывать....

Но нужно найти способ оптимальнее. Желательно, который бы входил в рамки лицензии 1 уровня RouterOS

Share this post


Link to post
Share on other sites

классифицировать всех абонентов на 2 лагеря.

1. Ваш супер-юзер

2. все остальные.

 

Разделять трафик справедливо по классам. 2+2

Share this post


Link to post
Share on other sites

DobroFenix

У нага такой вроде нет инфы.

Я собсно на MT обратил внимание исключительно по причине стабильности и шейпера.

Это воще классическая задача для шейпера в офисах - кусок отрезать, остальное поделить поровну. ;-)

В сетке полно инфы - лучше всего я читал про это на DDxClub.

Варианты деления поровну - по сессия или по юзверям.

Ну и обязательно - настройка классов траффика (высший - пинг, низший - торрент, остальное - промежуточная помойка, + 10-20% резерва линии для того чтобы это работало).

Share this post


Link to post
Share on other sites

Как бы все представляют как это сделать) но микротик не эксплуатируют))

Share this post


Link to post
Share on other sites

Как бы все представляют как это сделать) но микротик не эксплуатируют))

;-)

автор DobroFenix - эксплуатирует.

Я бы уже 2 месяца эксплуатировал, да меня магазин Нага кинул. Деньги вернули (40 дней пробыли в Екатеринбурге), я не сомневался, но вот с наличием и сопровождением - такого не ожидал. меня сопровождало 3 менеджера и они через неделю пропадали бесследно.

Щас в Wifi-магазине заказал.

Share this post


Link to post
Share on other sites

Достаточно 2-х правил в Simple Queues.

 

Первое правило где указан ваш клиент, собственно его адрес указываете и его ограничение по скорости 2мбит.

Второе правило ничего не указываете кроме ограничения скорости 2мбит, на вкладке ADVANCED в пункте Parent указываете первое правило.

 

В этом случае будет работать либо первое ограничение, либо второе.

Share this post


Link to post
Share on other sites

Меня смущает либо.

 

Нужно, чтобы все юзеры сети сидели за 2 мегабитами, а новый юзер сидел за другими 2 мегабитами.

Share this post


Link to post
Share on other sites

wiki.mikrotik.com

Все там расписано и даже работает.

Share this post


Link to post
Share on other sites

А что ты так не сделал?

/queue simple

add interface=ether2-local-master max-limit=2M/2M name=superuser target-addresses=10.1.1.2/32

add interface=ether2-local-master max-limit=2M/2M name=alluser target-addresses=10.1.1.0/24

 

главное что бы правило с суперюзером было первым.

Edited by rmika

Share this post


Link to post
Share on other sites

Хороший вариант...

Осталось обзавестись лицензией...

Share this post


Link to post
Share on other sites

не обратил внимание про 1 уровень лицензии... нафиг тогда микротик нужен?

Share this post


Link to post
Share on other sites

Другого нет.

Денег нет.

Некоммерческая организация.

Кто даст -- с меня скан благодарственной грамоты в цвете.

Share this post


Link to post
Share on other sites

Второе правило ничего не указываете кроме ограничения скорости 2мбит, на вкладке ADVANCED в пункте Parent указываете первое правило.

Меня смущает либо.

 

Я знал , что "бох" следит за нами... ;-)

 

А меня не смущает слово "либо", там ключевое слово Парент.

Сначала отрезаем кусок, а затем дочек делим поровну.

Ом! Харе Кришна! Алелуйя! Славься Боже! Алла ойк'бар!

Share this post


Link to post
Share on other sites

Меня смущает либо.

 

Нужно, чтобы все юзеры сети сидели за 2 мегабитами, а новый юзер сидел за другими 2 мегабитами.

 

Там имеется в виду что каждое правило работает только для своего трафика, если не попадает в первое - попадет во второе. Следовательно все клиенты получат положенные мегабиты. Но если вы хотите свой канал делить интеллектуально, ведь у вас 4мбит, тогда надо делать правила в дереве. В этом случае при не активности каких то клиентов все могут получить по 4мбит.

 

Есть ломанные версии 3-й ветки, там можете сколько угодно правил в дереве сделать.

Share this post


Link to post
Share on other sites

Лучше использовать честный 1 уровень, чем ломаную.

 

То, как она ломаная, не привлекается по нарушению законодательства.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this