Jump to content
Калькуляторы

Потери в EoMPLS-сети

При использовании технологии EoMPLS между L3-коммутаторами WS-C6504-E и ME-3600X-24FS-M , наблюдаются потери пакетов в размере 10-15% при попытке достучатся по протоколу pppoe(пробовали и static IP) от рабочей станци до бордера.

На 6504 в сторону бордера настроен сабинтерфейс, а на 3600 xconnect забирает траффик с влан-интерфейса.

При этом MPLS-траффик в global table и vrf'е(L3VPN) ходит без потерь, те проблема именно в AToM'ом траффике.

Топология сети и конфиги представлены ниже.

Просьба помочь, если кто-нибудь сталкивался с подобной проблемой (Юзернейм user_green.pngnitroyar посвящен в вопрос и готов дополнить/ответить на ваши вопросы)

2011te.png

Конфиги:

Cat 6504

interface TenGigabitEthernet1/4
mtu 8000
ip address 10.76.0.106 255.255.255.252
logging event link-status
mpls mtu 1550
mpls label protocol ldp
mpls ip

interface GigabitEthernet1/3.1111
encapsulation dot1Q 1111
xconnect 10.76.0.1 111 pw-class pppoe

pseudowire-class pppoe
encapsulation mpls

sh mpls l2transport vc 111 det
Local interface: Gi1/3.1111 up, line protocol up, Eth VLAN 1111 up
 Interworking type is Ethernet
 Destination address: 10.76.0.1, VC ID: 111, VC status: up
   Output interface: Te1/4, imposed label stack {17}
   Preferred path: not configured  
   Default path: active
   Next hop: 10.76.0.105
 Load Balance: none
 Flow Label: Disabled
 Create time: 05:13:22, last status change time: 05:13:21
 Signaling protocol: LDP, peer 10.76.0.1:0 up
   Targeted Hello: 10.76.0.2(LDP Id) -> 10.76.0.1, LDP is UP
   Status TLV support (local/remote)   : enabled/not supported
     LDP route watch                   : enabled
     Label/status state machine        : established, LruRru
     Last local dataplane   status rcvd: No fault
     Last local SSS circuit status rcvd: No fault
     Last local SSS circuit status sent: No fault
     Last local  LDP TLV    status sent: No fault
     Last remote LDP TLV    status rcvd: Not sent
     Last remote LDP ADJ    status rcvd: No fault
   MPLS VC labels: local 22, remote 17 
   Group ID: local 0, remote 0
   MTU: local 1550, remote 1550
   Remote interface description: 
 Sequencing: receive disabled, send disabled
 Control Word: Off (configured: autosense)
 VC statistics:
   transit packet totals: receive 18896, send 22250
   transit byte totals:   receive 11066229, send 17872490
   transit packet drops:  receive 0, send 0

ME3600

interface TenGigabitEthernet0/2
port-type nni
no switchport
mtu 8000
ip address 10.76.0.105 255.255.255.252
mpls mtu 1550
mpls label protocol ldp
mpls ip

interface Vlan1111
mtu 1550
no ip address
 xconnect 10.76.0.2 111 pw-class pppoe
end

pseudowire-class pppoe
encapsulation mpls

Local interface: Vl1111 up, line protocol up, Eth VLAN 1111 up
 Interworking type is Ethernet
 Destination address: 10.76.0.2, VC ID: 111, VC status: up
   Output interface: Te0/2, imposed label stack {22}
   Preferred path: not configured  
   Default path: active
   Next hop: 10.76.0.106
 Create time: 05:17:56, last status change time: 05:16:31
 Signaling protocol: LDP, peer 10.76.0.2:0 up
   Targeted Hello: 10.76.0.1(LDP Id) -> 10.76.0.2
   Status TLV support (local/remote)   : enabled/not supported
     Label/status state machine        : established, LruRru
     Last local dataplane   status rcvd: no fault
     Last local SSS circuit status rcvd: no fault
     Last local SSS circuit status sent: no fault
     Last local  LDP TLV    status sent: no fault
     Last remote LDP TLV    status rcvd: not sent
   MPLS VC labels: local 17, remote 22 
   Group ID: local 0, remote 0
   MTU: local 1550, remote 1550
   Remote interface description: CN_10.76.0.2_Te1/3.1111 to BRAS
 Sequencing: receive disabled, send disabled
 VC statistics:
   packet totals: receive 22648, send 20967
   byte totals:   receive 18187297, send 12609294
   packet drops:  receive 0, send 0

Тест

ping X.X.X.X rep 100

Type escape sequence to abort.
!!!!!.!!!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!
!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!
Success rate is 84 percent (84/100), round-trip min/avg/max = 1/1/31 ms


ping X.X.X.X rep 100 si 1500

Type escape sequence to abort.
!!.!!.!!.!!.!!.!!.!!.!!.!!.!!!!!!.!!!.!!.!!.!!.!!.!!.!!.!!.!!.!!.!!.!!
.!!.!!.!!.!!.!!.!!.!!.!!.!!.!!
Success rate is 69 percent (69/100), round-trip min/avg/max = 1/3/33 ms

Edited by pticavorobey

Share this post


Link to post
Share on other sites

Дак у вас с сначала работало а потом начались потери ? Или вы настроили и появились потери ? Если второе то MTU поглядите. Если первое то даже и не знаю так с ходу.

Share this post


Link to post
Share on other sites

Дак у вас с сначала работало а потом начались потери ? Или вы настроили и появились потери ? Если второе то MTU поглядите. Если первое то даже и не знаю так с ходу.

 

Потери появились сразу, c mtu всё уже перепробовали, да и потери возникают даже при пинге самыми маленькими пакетами.

 

ping 95.xx.xx.xx rep 100 si 40

Type escape sequence to abort.
Sending 100, 40-byte ICMP Echos to 95.xx.xx.xx, timeout is 2 seconds:
!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!!!!.!!!!!.!!!!!.!!!
!!.!!!!!.!!!!!.!!!!!.!!!!!.!!!

Edited by nitroyar

Share this post


Link to post
Share on other sites

Случаенно заметил. Именно так выглядит работа ограничителя скорости. У вас полисер где то. Видите пинг через одинаковые промежутки пропадает это работа полисера. 100%

Edited by yegorgk

Share this post


Link to post
Share on other sites

Случаенно заметил. Именно так выглядит работа ограничителя скорости. У вас полисер где то. Видите пинг через одинаковые промежутки пропадает это работа полисера. 100%

Никаких полисеров нигде не висит.

Share this post


Link to post
Share on other sites

Просто очень похоже. Вот не может пинг так сам пропадать через одинаковые промежутки это вам не только я скажу вам. Это видно что срабатывает именно rate limit вот только почему и где вот это вопрос или просто со скоростью что то. А больше к сожалению не приходит ничего на ум. Может кто нить зайдет в тему еще подскажет.

Share this post


Link to post
Share on other sites

изменили топологию, вместо 6504, поставили ещё одну ME3600 и между двумя подняли xconnect на vlan интерфейсах, всё работает отлично, а с 65ой по прежнему хреново....

Edited by nitroyar

Share this post


Link to post
Share on other sites

Что-то вы накрутили на 6504. слишком ровно теряются пакеты. смотрите конфиг полностью.

Share this post


Link to post
Share on other sites

тупо воткнул бы обычный рутер wrt54g с поддержкой вланов в самый вверх и посмотреть есть потери или нет. если нет - копаем 6504 если есть копаем ниже

 

)))))) чтото я погнал mikrotik 450g рутер в помощь.. на тест самое то

 

а вообще show configuration будет правильнее чем огрызки

Edited by vladimirslk

Share this post


Link to post
Share on other sites

тупо воткнул бы обычный рутер wrt54g с поддержкой вланов в самый вверх и посмотреть есть потери или нет. если нет - копаем 6504 если есть копаем ниже

 

)))))) чтото я погнал mikrotik 450g рутер в помощь.. на тест самое то

 

зачем он нужен? есть конкретная проблема с конкретным оборудованием, и проблема эта именно на участке псевдопровода.

Edited by nitroyar

Share this post


Link to post
Share on other sites

Проблему решили, оказался баг в IOS s72033-advipservicesk9_wan-mz.122-33.SXI4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this