Jump to content
Калькуляторы

ASR1002, EIGRP over Etherchannel ASR не отдает маршруты

Доброго дня!

 

Сегодня переносил линк между каталистом 3750 и ASR1002 с гигабита на etherchannel. Изначально все работало.

 

На ASR:

1) перенес конфиг с gig0/0/0 на port-channel 1

2) в router eigrp 1 добавил no passive-interface port-channel 1

3) в interface gig0/0/0 добавил channel-group 1

 

На 3750:

1) в интерфейс gig1/0/12 прописал channel-group 2 mode on

2) перенес конфиг gig0/0/0 в interface port-channel 2

 

(на 3750 etherchannel 1 уже занят)

 

Все апнулось. Пинги между interface vlan 1000 на каталисте и port-channel 1 на ASR ходят.

EIGRP поднялся. Все супер.... Но :) каталист не видит маршрутов от ASR'а. А ASR видит маршруты с каталиста.

Причем если на interface port-channel 1 на ASR сделать: ip summary eigrp 1 .... то указанная сеть появится на каталисте.

 

Переношу все обратно на физические интерфейсы - работает.

Собрал эту же схему на столе из 2811 и 3750 - все работает.

 

На ASR'е ios: asr1000rp1-adventerprise.03.01.00.S.150-1.S.bin

 

Гуглил - с такой проблемой сталкивался только один человек, но решения нет.... Помогите, плз, если есть успешный опыт eigrp поверх port-channel'а на ASR'ах.

Share this post


Link to post
Share on other sites

вообще рекомендую использовать не channel-group 2 mode on, а channel-group 2 mode active, тем самым сделав lacp активное соединение, что будет надежнее. eigrp не использую - ничего не посоветую...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this