Jump to content
Калькуляторы

Pim-SM Dlink 3627 и Cisco 6500 и ism vlan

Схема такая

 

в Dlink 3627 включены стример который вещает multicast

по PIM-SM все маршрутизируется на CISCO 6500

 

кошке подключены клиентские железки доступа DES 3200-28 с ISM vlan

 

кто к ним подключен у тех высыпает IPTV

кто подключен к 3627 у тех все ок

и кто подключен к другому 3627 который подключен к 3627(со стримером) тоже все ок

 

вот настройки кошки

 

ip multicast-routing

 

interface GigabitEthernet2/1

description lan

ip address 10.0.19.2 255.255.255.0

ip pim sparse-mode

ip ospf network broadcast

 

стык между 3627 и кошкой

 

interface Vlan23

ip address 10.244.244.1 255.255.255.0

ip pim sparse-mode

ip multicast ttl-threshold 7

 

23 влан он Ism влан на свичах длинк

 

ip pim autorp listener

ip pim rp-address 91.211.45.97 IPTV override

 

ip access-list standard IPTV

permit 224.11.0.0 0.0.0.3

permit 239.0.0.0 0.255.255.255

Share this post


Link to post
Share on other sites

qos нужен + не мого ли ip multicast ttl-threshold 7?

Share this post


Link to post
Share on other sites

Не понял из поста что именнон не работает? Что значит "высыпает"?

Edited by triam

Share this post


Link to post
Share on other sites

ip multicast ttl-threshold 7

 

уже просто не знал куда копать

 

Не понял из поста что именнон не работает? Что значит "высыпает"?

картинка сыпится

Share this post


Link to post
Share on other sites

зачем qos там порт не нагружен вообще

все равно сыпет и картинку и звук

Share this post


Link to post
Share on other sites

По симптомам похоже, что des3200 флудит мультикастом во все порты. Подключите 2ух клиентов к разным портам 3200, приджойните разные группы и посмотрите ваершарком приходит ли незапрашиваемый трафик. Если приходит, то разбирайтесь с igmp/mvr

Share this post


Link to post
Share on other sites

как то странно

когда было подключен сегмент в 3627

такого не наблюдалось, только с переездом на кошку

Share this post


Link to post
Share on other sites

порты на сегмент

вот такие настройки

 

interface GigabitEthernet2/12

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 8,23,999

switchport mode trunk

!

interface GigabitEthernet2/13

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,23,996

switchport mode trunk

Share this post


Link to post
Share on other sites

Нужно кончно смотреть снифером что происходит. Попробуйте включит на D-link'ах strick-mode в QoS.

Так же надо заджойнится на мультикастном влане в группу и посмотреть мультикаст маршруты.

conf t

int vlan 23

ip igmp join-group 1.2.3.4

end

sh ip mroute 1.2.3.4

Share this post


Link to post
Share on other sites

схему усложнил

 

dlnk 3627 - cisco 6500 - dlink 3627 - des 3200-28

 

сыпится раз в 2 секунды

 

dlnk 3627 - cisco 6500 - des 3200-28

 

сыпится раз в 3 секунды

 

dlnk 3627 - dlink 3627 - des 3200-28

 

все отлично

 

dlnk 3627 - des 3200-28

 

все отлично

 

с маршрутов все ок

Share this post


Link to post
Share on other sites

не поделитесь конфигами длинков 3627 и 3200-28?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this