Перейти к содержимому
Калькуляторы

dhcp с option82 на Huawei MA5200G Как поднять?

Здравствуйте, уважаемые! Подскажите пожалуйста по такой теме.

Как поднять dhcp с option82 на Huawei MA5200G? Измучался совсем, мануалы не читабельны, в инете не нашел, тех поддержка хуавея помогать отказалась :(

[NSIV_BRAS]dis ver

Huawei Versatile Routing Platform Software

VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

Copyright © 2000-2008 Huawei Technologies Co., Ltd

Quidway MA5200G-4 uptime is 0 week, 4 days, 0 hour, 18 minutes

Patch: V300R003SPH063

 

SMUG 5(Slave) : uptime is 0 week, 4 days, 0 hour, 18 minutes

1024M bytes SDRAM

128M bytes Flash Memory

512K bytes NVRAM

974M bytes CF card

Pcb Version : H523SMUG REV B

Logic Version : 001

BootROM Version : 200-200

Bas Version : 5200-33106363

Software Version : VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

BarCode : 030GFX1094000079

 

Заранее спасибо!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, уважаемые! Подскажите пожалуйста по такой теме.

Как поднять dhcp с option82 на Huawei MA5200G? Измучался совсем, мануалы не читабельны, в инете не нашел, тех поддержка хуавея помогать отказалась :(

[NSIV_BRAS]dis ver

Huawei Versatile Routing Platform Software

VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

Copyright © 2000-2008 Huawei Technologies Co., Ltd

Quidway MA5200G-4 uptime is 0 week, 4 days, 0 hour, 18 minutes

Patch: V300R003SPH063

 

SMUG 5(Slave) : uptime is 0 week, 4 days, 0 hour, 18 minutes

1024M bytes SDRAM

128M bytes Flash Memory

512K bytes NVRAM

974M bytes CF card

Pcb Version : H523SMUG REV B

Logic Version : 001

BootROM Version : 200-200

Bas Version : 5200-33106363

Software Version : VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

BarCode : 030GFX1094000079

 

Заранее спасибо!

Вы бы прислали конфиг, что наваяли - можно было бы указать на недочеты. Ну и поточнее рассказать о схеме сети.

Давать вам конфиг с рабочей железки пусть даже с купюрами не хочется.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

С таким конфигом не заработало. Связать ip pool и dhcp-server

непонятно как. Надо ли вообще привязывать к интерфейсу dhcp server? Пока пытался поднять просто dhcp сервер, без опции 82. Спасибо!

Вот конфа:

 

sysname NSIV_BRAS

#

memory warning 50 holding 45 limit 40 safety 55

#

traffic policy _remote-defined-policy

#

diffserv domain default

#

interface Aux0/0/1

async mode flow

#

interface GigabitEthernet0/0/0

ip address 192.168.5.144 255.255.255.0

speed auto

duplex auto

#

interface GigabitEthernet1/0/0

eth-trunk 1

#

interface GigabitEthernet1/0/1

#

interface GigabitEthernet1/1/0

#

interface GigabitEthernet1/1/1

#

interface GigabitEthernet2/0/0

#

interface GigabitEthernet2/0/1

#

interface GigabitEthernet2/1/0

#

interface GigabitEthernet2/1/1

#

interface GigabitEthernet3/0/0

#

interface GigabitEthernet3/0/1

#

interface GigabitEthernet3/1/0

#

interface GigabitEthernet3/1/1

#

interface NULL0

#

dhcp-server group users

dhcp-server 192.168.10.1

#

ip pool users local

gateway 192.168.11.1 255.255.255.0

section 0 192.168.11.2 192.168.11.252

dns-server 192.168.11.253

#

qos-profile default

#

dot1x-template 1

#

aaa

authentication-scheme local

authentication-mode local

authorization-scheme local

domain default0

domain default1

domain default_admin

authentication-scheme local

authorization-scheme local

#

local-aaa-server

user admin password cipher \#-D9V\>>)aQ=^Q`MAF4<1!! level 3

user arodionov password cipher C;D)\R0/I8aQ=^Q`MAF4<1!! level 3

#

l2tp-group default-lac

start l2tp

#

l2tp-group default-lns

#

interface Eth-Trunk0

#

interface Eth-Trunk1

#

interface Eth-Trunk1.1

vlan-type dot1q 1

description Control

ip address 10.90.90.1 255.255.255.0

#

interface Eth-Trunk1.100

vlan-type dot1q 100

description test

ip address 192.168.10.1 255.255.255.0

dhcp-server group users

#

ip route-static 192.168.5.0 255.255.255.0 GigabitEthernet0/0/0 192.168.5.1

#

stelnet server enable

ssh user arodionov

ssh user admin

ssh user arodionov authentication-type password

ssh user admin authentication-type password

ssh user arodionov service-type all

ssh user admin service-type all

#

user-interface maximum-vty 15

user-interface con 0

user-interface aux 0

user-interface vty 0 4

authentication-mode aaa

user privilege level 3

user-interface vty 5 14

authentication-mode aaa

user privilege level 3

protocol inbound ssh

#

ancp

neighbor-profile default-neighbor

#

return

[NSIV_BRAS]

Изменено пользователем ivcrash

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

ip pool надо указывать в настройках aaa, но это на ME60

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1. Нет BAS интерфейса

2. Для связки IP pool и DHCP сервер скажите

 

[Quidway] ip pool isp2_pool remote
[Quidway-ip-pool-isp2_pool] gateway 30.30.30.1 255.255.255.0
[Quidway-ip-pool-isp2_pool] dhcp-server group group1
[Quidway-ip-pool-isp2_pool] quit

 

3. Совершенно справедливое замечание от Jazzy$

 

Вполне читабельный мануал: http://support.huawei.com/support/pages/kbcenter/view/product.do?actionFlag=searchManualTableOfContents&web_doc_id=SE0000455855&doc_type=ProductManual

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

1. Нет BAS интерфейса

2. Для связки IP pool и DHCP сервер скажите

 

[Quidway] ip pool isp2_pool remote
[Quidway-ip-pool-isp2_pool] gateway 30.30.30.1 255.255.255.0
[Quidway-ip-pool-isp2_pool] dhcp-server group group1
[Quidway-ip-pool-isp2_pool] quit

 

3. Совершенно справедливое замечание от Jazzy$

 

Вполне читабельный мануал: http://support.huawei.com/support/pages/kbcenter/view/product.do?actionFlag=searchManualTableOfContents&web_doc_id=SE0000455855&doc_type=ProductManual

Спасибо Вам огромное! Действительно читабельный)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Здравствуйте, господа, прошу помощи снова. Пытаюсь поднять dhcp с использованием опции 82, через авторизацию на радиусе. Радиус настроен принимать любые запросы. С данным конфигом не заработало, ip адрес по дхцп через коммутатор доступа получить не могу. Посмотрите, пожалуйста, возможно где-то ошибся. Также нельзя исключать неправильную настройку коммутатора доступа от Dlink DES-3200-28, на нем настраивал dhcp relay option82.

Буду признателен за любую помощь.

 

Результаты диагностики на хуавее:

display authentication-scheme

-------------------------------------------------------------------

Authentication-scheme-name Authentication-method

-------------------------------------------------------------------

default0 None

default1 RADIUS

local Local

home RADIUS

-------------------------------------------------------------------

 

Total of authen scheme: 4

display accounting-scheme

-------------------------------------------------------------------

Accounting-scheme-name Accounting-method

-------------------------------------------------------------------

default0 None

default1 RADIUS

home RADIUS

-------------------------------------------------------------------

Total of accounting-scheme: 3

display radius-server configuration

RADIUS no response packet count : 10

RADIUS auto recover time(Min) : 3

RADIUS specified no response packet interval(Sec) : 5

---------------------------------------------------------

Server-group-name : rad1

Authentication-server: IP:192.168.5.223 Port:1812 Weight[0] [uP]

Vpn: -

Accounting-server : IP:192.168.5.223 Port:1813 Weight[0] [uP]

Vpn: -

Protocol-version : radius

Shared-secret-key : gfMH56V7ghfj6mb

Retransmission : 3

Timeout-interval(s) : 5

Acct-Stop-Packet Resend : NO

Acct-Stop-Packet Resend-Times : 0

---------------------------------------------------------

Total 1,1 printed

 

Радиус пишет:

00:00:00.000015 IP 192.168.5.101.1812 > 192.168.5.223.1812: RADIUS, Access Request (1), id: 0x02 length: 274

00:00:00.000023 IP 192.168.5.223.1812 > 192.168.5.101.1812: RADIUS, Access Accept (2), id: 0x02 length: 20

Mon Oct 31 16:53:36 2011 : Auth: Login OK: [10.90.90.90-4@home1/vlan] (from client 192.168.5.101 port 51384320 cli 1c:75:08:05:8f:dc)

Mon Oct 31 16:55:08 2011 : Auth: Login OK: [10.90.90.90-4@home1/vlan] (from client 192.168.5.101 port 51384320 cli 1c:75:08:05:8f:dc)

Mon Oct 31 16:56:09 2011 : Auth: Login OK: [10.90.90.90-4@home1/vlan] (from client 192.168.5.101 port 51384320 cli 1c:75:08:05:8f:dc)

 

Вот сопсна конфиг BRAS:

 

memory warning 50 holding 45 limit 40 safety 55

#

user-group home1

#

radius-server group rad1

radius-server authentication 192.168.5.223 1812 weight 0

radius-server accounting 192.168.5.223 1813 weight 0

radius-server shared-key gfMH56V7ghfj6mb

radius-server source interface GigabitEthernet3/1/0

#

radius-server authorization 192.168.5.223 shared-key gfMH56V7ghfj6mb server-grou p rad1

#

traffic policy _remote-defined-policy

#

diffserv domain default

#

interface Aux0/0/1

async mode flow

#

interface GigabitEthernet0/0/0

ip address 192.168.7.175 255.255.255.0

speed auto

duplex auto

#

interface GigabitEthernet1/0/0

#

interface GigabitEthernet1/0/1

#

interface GigabitEthernet1/1/0

#

interface GigabitEthernet1/1/1

#

interface GigabitEthernet2/0/0

#

interface GigabitEthernet2/0/1

#

interface GigabitEthernet2/1/0

#

interface GigabitEthernet2/1/1

#

interface GigabitEthernet3/0/0

#

interface GigabitEthernet3/0/1

#

interface GigabitEthernet3/1/0

ip address 192.168.5.101 255.255.255.0

#

interface GigabitEthernet3/1/1

ip address 10.90.90.1 255.255.255.0

bas

access-type layer3-subscriber default-domain pre-authentication home1

client-option82

#

interface NULL0

#

ip pool users local

gateway 192.168.168.1 255.255.255.0

section 0 192.168.168.2 192.168.168.253

dns-server 192.168.168.254

#

qos-profile default

#

dot1x-template 1

#

aaa

default-user-name include gateway-address . - option82 sub-option 1 offset 1 parse-mode binary 1

authentication-scheme local

authentication-mode local

authentication-scheme home

accounting-scheme home

domain default0

domain default1

domain default_admin

authentication-scheme local

domain home1

authentication-scheme home

accounting-scheme home

radius-server group rad1

user-group home1

ip-pool users

domain device

authentication-scheme default0

accounting-scheme default0

#

local-aaa-server

user root password cipher FV]1a9:aIXGQ=^Q`MAF4<1!! level 3

#

l2tp-group default-lac

start l2tp

#

l2tp-group default-lns

#

interface Eth-Trunk1

#

stelnet server enable

ssh user root

ssh user root authentication-type password

ssh user root service-type all

#

layer3-subscriber 10.90.90.90 10.90.90.90 domain-name device

#

user-interface maximum-vty 15

user-interface con 0

user-interface aux 0

user-interface vty 0 14

authentication-mode aaa

user privilege level 3

protocol inbound ssh

#

ancp

neighbor-profile default-neighbor

#

return

Изменено пользователем Andy_999

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

причем видно, что коммутатор зарегистрировался в домене device, а вот в домене home1 пусто :(

dis dom

-------------------------------------------------------------------------

DomainName State Access-limit Online type

-------------------------------------------------------------------------

default0 Active 65536 0 Normal

default1 Active 65536 0 Normal

default_admin Active 65536 0 Normal

home1 Active 65536 0 Normal

device Active 65536 1 Normal

-------------------------------------------------------------------------

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

сделайте вывод команды display version и display patch-information

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
dis ver

Huawei Versatile Routing Platform Software

VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

Copyright © 2000-2008 Huawei Technologies Co., Ltd

Quidway MA5200G-4 uptime is 0 week, 0 day, 22 hours, 23 minutes

Patch: V300R003SPH063

 

SMUG 5(Slave) : uptime is 0 week, 0 day, 22 hours, 22 minutes

1024M bytes SDRAM

128M bytes Flash Memory

512K bytes NVRAM

974M bytes CF card

Pcb Version : H523SMUG REV B

Logic Version : 001

BootROM Version : 200-200

Bas Version : 5200-33106363

Software Version : VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

BarCode : 030GFX1094000079

 

Switch Fabric:

Logic Version : 009

Software Version : LDRIVER

 

Clock:

StartupTime 2011/10/31 18:07:28

Pcb Version : H521CLK REV B

Epld Version : 016

Software version : 021

 

SMUG 6(Master) : uptime is 0 week, 0 day, 22 hours, 22 minutes

1024M bytes SDRAM

128M bytes Flash Memory

512K bytes NVRAM

974M bytes CF card

Pcb Version : H523SMUG REV B

Logic Version : 001

BootROM Version : 200-200

Bas Version : 5200-33106363

Software Version : VRP ® software, Version 5.30 (MA5200G V300R003C01B063)

BarCode : 030GFX1094000078

 

Switch Fabric:

Logic Version : 009

Software Version : LDRIVER

 

Clock:

StartupTime 2011/10/31 18:06:54

Pcb Version : H521CLK REV B

Epld Version : 016

Software version : 021

 

SFUT 1 : uptime is 0 week, 0 day, 22 hours, 18 minutes, normal boot

Host Processor :

512M bytes SDRAM

16M bytes Flash Memory

Network Processor :

292M bytes SDRAM

5M bytes SRAM

NP Version : 3.1

CP PCB Version : H521CPCE VER.D

CP Logic Version : 400

Pcb Version : H522SFUT REV B

Logic Version : 003

BootROM Version : 006-016

Fsu Version : 5200-33106301

Efu Version : 5200-33106301

BarCode : 030BPM1093000045

TCMA's version information:

Pcb Version : H522TCMA REV C

Logic Version : 2006-10-12

Tcam1 Version : 1.6

Tcam2 Version : 1.6

PIC0's version information:

Pcb Version : H521O2GDF REV A

Single FPGA Version : 7

PIC1's version information:

Pcb Version : H521O2GDF REV A

Single FPGA Version : 7

 

SFUT 2 : uptime is 0 week, 0 day, 22 hours, 18 minutes, normal boot

Host Processor :

512M bytes SDRAM

16M bytes Flash Memory

Network Processor :

292M bytes SDRAM

5M bytes SRAM

NP Version : 3.1

CP PCB Version : H521CPCE VER.D

CP Logic Version : 400

Pcb Version : H522SFUT REV B

Logic Version : 003

BootROM Version : 006-016

Fsu Version : 5200-33106301

Efu Version : 5200-33106301

BarCode : 030BPM1093000039

TCMA's version information:

Pcb Version : H522TCMA REV C

Logic Version : 2006-10-12

Tcam1 Version : 1.6

Tcam2 Version : 1.6

PIC0's version information:

Pcb Version : H521O2GDF REV A

Single FPGA Version : 7

PIC1's version information:

Pcb Version : H521O2GDF REV A

Single FPGA Version : 7

 

SFUT 3 : uptime is 0 week, 0 day, 22 hours, 18 minutes, normal boot

Host Processor :

512M bytes SDRAM

16M bytes Flash Memory

Network Processor :

292M bytes SDRAM

5M bytes SRAM

NP Version : 3.1

CP PCB Version : H521CPCE VER.D

CP Logic Version : 400

Pcb Version : H522SFUT REV B

Logic Version : 003

BootROM Version : 006-016

Fsu Version : 5200-33106301

Efu Version : 5200-33106301

BarCode : 030BPM1093000042

TCMA's version information:

Pcb Version : H522TCMA REV C

Logic Version : 2006-10-12

Tcam1 Version : 1.6

Tcam2 Version : 1.6

PIC0's version information:

Pcb Version : H521O2GDF REV A

Single FPGA Version : 7

PIC1's version information:

Pcb Version : H521O2GDF REV A

Single FPGA Version : 7

 

display patch-information all

----------The patch information of master board----------

patch version : MA5200V300R003C01B063

common patch number : 1

current patch number : 1

running patch number : 1

active patch number : 0

patch area length : 0x100000

patch area start address: 0x100000

patch filename : cfcard:/dm_3363_smug.pat

 

----------The patch information of slave board----------

patch version : MA5200V300R003C01B063

common patch number : 1

current patch number : 1

running patch number : 1

active patch number : 0

patch area length : 0x100000

patch area start address: 0x100000

patch filename : cfcard:/dm_3363_smug.pat

 

----------The patch information of slot 1----------

patch version :

common patch number : 0

current patch number : 0

running patch number : 0

active patch number : 0

patch area length : 0x100000

patch area start address: 0x100000

patch filename :

 

----------The patch information of slot 2----------

patch version :

common patch number : 0

current patch number : 0

running patch number : 0

active patch number : 0

patch area length : 0x100000

patch area start address: 0x100000

patch filename :

 

----------The patch information of slot 3----------

patch version :

common patch number : 0

current patch number : 0

running patch number : 0

active patch number : 0

patch area length : 0x100000

patch area start address: 0x100000

patch filename :

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

была похожая проблема решилась патчем. Патч смогу дать только завтра.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
была похожая проблема решилась патчем. Патч смогу дать только завтра.

спасибо, буду ждать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот обещанный патч. Выложил на файл обменник так как сюда не дает выложить. Пользуйтесь надеюсь поможет устранить проблему.

Letitbit

depositfiles

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Вот обещанный патч. Выложил на файл обменник так как сюда не дает выложить. Пользуйтесь надеюсь поможет устранить проблему.

спасибо! по результатам отпишусь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите в него для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас