Jump to content
Калькуляторы

wpa_supplicant проблемы с подключением к циске с wpa2

Приветствую,

Есть телефон с Андроидом (прошивка Cyanogenmod 7 rc1.5), на работе стоит циска семисотой серии, раньше на ней использовался WEP, теперь, из соображений здравого смысла поставили WPA2.

После этого, телефон вообше перестал видеть эту точку доступа, несмотря на то, что кругом куча других точек с WPA2, он их прекраснго видит и коннектится без проблем.

Для вайфая в моем телефоне используется демон wpa_supplicant, может кому приходилось иметь с ним дело, может он чего неподдерживает?

На циске настройки такие:

aaa authentication login vpn_auth local
aaa authorization network vpn_auth local

...

ip dhcp excluded-address x.x.x.x
!
ip dhcp pool wifi_pool
network x.x.x.x 255.255.255.0
default-router x.x.x.x
dns-server x.x.x.x
domain-name hq.domain.ru
lease 2

...


dot11 ssid xxxx
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 xxxxxxxx

...

crypto map vpn_map client authentication list vpn_auth
crypto map vpn_map isakmp authorization list vpn_auth
crypto map vpn_map client configuration address respond
crypto map vpn_map 10 ipsec-isakmp dynamic dynmap

...

interface Dot11Radio0
description WiFi Network
ip address x.x.x.x 255.255.255.0
ip access-group wifi_in in
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
encryption mode ciphers aes-ccm
!
ssid xxxx
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
fair-queue 64 256 256
crypto map vpn_map

...

ip access-list extended wifi_in
deny tcp any any eq smtp log
permit ip any any

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this