Jump to content
Калькуляторы

C3560 + DES3526 LACP

Помогите поднять LACP между Cisco Catalyst 3560 и D-Link DES-3526.

 

На D-Link'е настроил LACP Agregation на 23 и 24 порт (23 порт основной). На C3560 выполняю следующее (для 5 и 6 порта):

 

switch>enable

switch#config terminal

switch(config)#interface range fastethernet 0/5-6

switch(config-if-range)#channel-protocol lacp

switch(config-if-range)#channel-group 10 mode active

 

После чего даю команду:

show lacp internal

 

C3560#show lacp internal

Flags: S - Device is requesting Slow LACPDUs

F - Device is requesting Fast LACPDUs

A - Device is in Active mode P - Device is in Passive mode

 

Channel group 10

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Fa0/5 SA indep 32768 0xA 0x0 0x105 0x45

Fa0/6 SA susp 32768 0xA 0x0 0x106 0x45

C3560#

 

Подскажите в чем может быть проблема?

P.S. Между двумя Д-Линками все работает, я очевидно накосячил в настройках циски.

Share this post


Link to post
Share on other sites

Покажите вывод команд show link_aggregation и sh etherchannel load-balance.

Настройки портов на кошке и делинке не различаются часом? Всякие там разрешенные вланы, лупбэки, арп-контрол, stp и подобные вещи...

Edited by passer

Share this post


Link to post
Share on other sites

конфигурация интерфейсов fa0/5, fa0/6 и port-channel10 идентична?

и channel-protocol lacp на fastethernet накиньте.

 

неоднократно собирал на разных железках этих двух вендоров по инструкции http://dlink.ru/ru/faq/62/250.html

и никаких проблем не наблюдается (бывали на древних длинковских прошивках косяки, но вроде все починили)

Share this post


Link to post
Share on other sites

passer, show link_aggregation не выводит пишет неправильное имя команды, на sh etherchannel load-balance выдает:

C3560#sh etherchannel load-balance

EtherChannel Load-Balancing Configuration:

src-mac

 

EtherChannel Load-Balancing Addresses Used Per-Protocol:

Non-IP: Source MAC address

IPv4: Source MAC address

IPv6: Source MAC address

 

darkagent сделал все так как в методичке по ссылке, только порты прописал свои, Fa0/5 поднялся, но на Fa0/6 статус suspend

Share this post


Link to post
Share on other sites

sh run int fa0/5

sh run int fa0/6

сравнивать...

 

Вот что получилось:

C3560#sh run int fa0/5

Building configuration...

 

Current configuration : 181 bytes

!

interface FastEthernet0/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 600

switchport mode trunk

channel-protocol lacp

channel-group 1 mode active

end

 

C3560#sh run int fa0/6

Building configuration...

 

Current configuration : 85 bytes

!

interface FastEthernet0/6

channel-protocol lacp

channel-group 1 mode active

end

 

Но мне одно не понятно, откуда на 5 порту взялся 600-й VLAN, когда у меня на длинке все виланы 172-е.

Этот старый конфиг можно как-то убрать, не трогая остальных настроек, так как кошка рабочая и соединяет несколько сетей.

Share this post


Link to post
Share on other sites

darkagent, вы просто профи!!! Спасибо, все поднялось!

Еще подскажите какую-нибудь литературу для нуба по коммутаторам кошко.

Share this post


Link to post
Share on other sites

Спасибо!

 

UPD:

 

Все работает, только скорость не стала 200Мбит/с, все также осталась на уровне 100Мбит/с, все остальные соединения - гигабитные.

Edited by Daedalus

Share this post


Link to post
Share on other sites

В чем может быть проблема?

 

Как вы это проверяете? По графикам?

Дело может быть в балансировке распределения пакетов в объединенном канале.

 

# port-channel load-balance ?
 dst-ip       Dst IP Addr
 dst-mac      Dst Mac Addr
 src-dst-ip   Src XOR Dst IP Addr
 src-dst-mac  Src XOR Dst Mac Addr
 src-ip       Src IP Addr
 src-mac      Src Mac Addr

 

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.2_25_see/configuration/guide/swethchl.html#wp1020401

Edited by vurd

Share this post


Link to post
Share on other sites

Как вы это проверяете? По графикам?

 

Тестили программкой iperf с таким конфигом:

iperf.exe -c ns2.********.biz -u -P 1 -i 1 -p 5001 -f m -b 300M -t 30 -T 1

pause

 

Дело может быть в балансировке распределения пакетов в объединенном канале.

 

Сейчас стоит src-mac, это я понял что для одного МАС адреса используется только 100Мбит/с, если соединить другую машину, то на ней скорость тоже будет 100 Мбит/с, а если поставить dst-mac, то разграничение по МАС не будет включено и для машины с гигабитной картой будет скорость 200Мбит/с??? По ссылке ходил, но мало что понял - с английским не дружу.

 

UPD:

 

или же для того чтобы получить на машине с гигабитным портом скорость 200 Мбит/с надо отключить вообще load-balance ???

Edited by Daedalus

Share this post


Link to post
Share on other sites

в один поток не выйдет получить 200мбит.

Это при таком конфиге или вообще на данном оборудовании?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this