Jump to content
Калькуляторы

RB450G-проброс портов не получаеться пробросить порт

Есть rb-450G не получается на нём настроить проброс порта. Интерфейс WAN- ip:91.212.x.x, интерфейс Lan – ip:10.0.0.3, к интерфейсу Lan подключен Nanobridge M2 – ip:192.168.7.27. На порту Lan(rb-450G) прописан еще один ip:192.168.7.70. Существует проблема: не пробрасывается порт с Nanobridge M2 на интерфейс WAN. При этом проброшенный порт на ip:10.0.0.207(для radmin), работает нормально. Ip:192.168.7.70(Nanobridge M2) с rb-450G пингуеться, в ARP таблице запись существует. Пытался менять адресацию на Nanobridge M2(ip c диапазона 10.0.0.0) -безрезультатно.Подскажите пожалуйста, может, что-то не так делаю, или есть какой то нюанс.

Share this post


Link to post
Share on other sites

пришли что выдает:

/ip fir nat export

/ip addr export

Share this post


Link to post
Share on other sites

пришли что выдает:

/ip fir nat export

/ip addr export

add action=masquerade chain=srcnat comment="Added by webbox" disabled=no out-interface=ether1-gateway src-address-list=internet

add action=dst-nat chain=dstnat comment="" disabled=no dst-address=91.212.x.x dst-port=4899 protocol=tcp to-addresses=10.0.0.207 to-ports=4899

add action=dst-nat chain=dstnat comment="" disabled=yes dst-address=91.212.x.x dst-port=80 protocol=tcp to-addresses=10.0.0.3 to-ports=80

add action=dst-nat chain=dstnat comment="" disabled=no dst-address=91.212.x.x dst-port=8555 protocol=tcp to-addresses=192.168.7.27 to-ports=80

 

/ip address

add address=10.0.0.3/8 broadcast=10.255.255.255 comment="default configuration" disabled=no interface=ether2-local network=10.0.0.0

add address=91.212.X.X/29 broadcast=91.212.X.X comment="" disabled=no interface=ether1-gateway network=91.212.X.X

add address=192.168.7.70/24 broadcast=192.168.7.254 comment="" disabled=no interface=ether2-local network=192.168.7.0

Share this post


Link to post
Share on other sites

/ip servi export

Может у тебя на 80 порту уже вебсервер микротика крутится? попробуй

/ip fir nat set 2 dst-port=81

Share this post


Link to post
Share on other sites

/ip servi export

Может у тебя на 80 порту уже вебсервер микротика крутится? попробуй

/ip fir nat set 2 dst-port=81

Так я же порт 80 отправляю на 192.168.7.27, а 81 порт мне не нужен, так как веб сервер на 192.168.7.27 работает на 80-том.

 

/ip service

set telnet address=0.0.0.0/0 disabled=no port=23

set ftp address=0.0.0.0/0 disabled=no port=21

set www address=0.0.0.0/0 disabled=no port=80

set ssh address=0.0.0.0/0 disabled=no port=22

set www-ssl address=0.0.0.0/0 certificate=none disabled=yes port=443

set api address=0.0.0.0/0 disabled=yes port=8728

set winbox address=0.0.0.0/0 disabled=no port=8291

Edited by ur4ulf

Share this post


Link to post
Share on other sites

на то он и проброс, ты зайдешь на 81 а микротик тебя пробросит на 80, у тебя в микротике крутится веб-сервер на 80 порту "set www address=0.0.0.0/0 disabled=no port=80"

Share this post


Link to post
Share on other sites

на наносе проверь чтоб шлюзом для него был 192.168.7.70

Share this post


Link to post
Share on other sites

на то он и проброс, ты зайдешь на 81 а микротик тебя пробросит на 80, у тебя в микротике крутится веб-сервер на 80 порту "set www address=0.0.0.0/0 disabled=no port=80"

А в чем разница если я пробрасиваю не на 81-й а на 8555? add action=dst-nat chain=dstnat comment="" disabled=no dst-address=91.212.x.x dst-port=8555 protocol=tcp to-addresses=192.168.7.27 to-ports=80

 

на наносе проверь чтоб шлюзом для него был 192.168.7.70

Этого не пробывал, сейчас как раз и нету туда доступа, сегодня доберусь со стороны Lan и попробую, по результатам обязательно отпишусь.

Share this post


Link to post
Share on other sites

Сори не увидел что ты там пробрасывал, тебе не хватает маскарада для интерфейса ether2-local

Share this post


Link to post
Share on other sites

на наносе проверь чтоб шлюзом для него был 192.168.7.70

Все таки да! В этом причина. Большая благодарность Вам Alexspils за помощь!

Edited by ur4ulf

Share this post


Link to post
Share on other sites

Для таких случаев лучше поднимать VPN сервер с ARP-proxy, тогда не зависимо от настроек других устройств, в том числе указания шлюзов, можно заходить на любые устройства локальной сети.

Share this post


Link to post
Share on other sites

Для таких случаев лучше поднимать VPN сервер с ARP-proxy, тогда не зависимо от настроек других устройств, в том числе указания шлюзов, можно заходить на любые устройства локальной сети.

Спасибо за совет, обязательно учту. VPN сервер с ARP-proxy тяжело поставить на 450-g? Не нашел в настройках. На обратной стороне должен стоять обычный vpn клиент?

Share this post


Link to post
Share on other sites

Там все настройки сводятся к тому, что в свойствах адаптера или бриджа, где ваша локалка ходит, ставите в пункте ARP - Proxy ARP. Далее создаете VPN сервер (или любой другой туннельный), где в secrets создаете клиента с адресом сервера к примеру 10.0.0.2, адресом клиента 10.0.0.3. Сам микротик допустим имеет адрес 10.0.0.1. Теперь можно внутри локалки раздавать адреса 10.0.0.10-254 к примеру и работать=)

 

Теперь можно подключится к микротику и получить адрес локалки, и иметь полный доступ в нее по этим адресам. Если вдруг настройки наноса слетели в дефолтные, вам нужно будет всего добавить в микротик адрес 192.168.1.1 и подправить адрес в secrets, и сможете легко все перенастроить=)

 

А еще там можно PPP клиента в бридж добавить и работать с любыми адресами, только нужно будет их вручную в свойствах соединения в винде прописывать.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this