Jump to content
Калькуляторы

Cisco 3560 QOS и очереди

доброго времени суток!

поможите по вот какому вопросу

имеется циска 3560, mls qos включён. Наблюдается странное свойство исходящего трафика на одном интерфейсе.. точнее на портченеле из двух, исходящий трафик всегда меньше на четверть от физически вероятного.

крутил разные параметры очередей,

такие

srr-queue bandwidth share 1 30 60 10

srr-queue bandwidth shape 25 0 0 0

 

ставил дефолтные

srr-queue bandwidth share 1 25 25 25

srr-queue bandwidth shape 25 0 0 0

 

и даже такие

switchport access vlan 62

switchport mode access

srr-queue bandwidth share 5 5 5 5

srr-queue bandwidth shape 0 0 0 0

no cdp enable

channel-protocol pagp

channel-group 3 mode auto

 

разницы нет

вообщем всегда канал работает лишь на 75%..не важно в портченеле 1 интерфейс или два.. но стоит только отключить mls qos как беда проходит и трафик нормально загружает канал на 90% и чуть

выше..

 

примечательно что рядом есть другой ченел собраный иначе и у него такой проблемы нет.

 

interface GigabitEthernet0/28

no switchport

no ip address

srr-queue bandwidth share 1 60 30 10

srr-queue bandwidth shape 20 0 0 0

no cdp enable

channel-group 4 mode on

 

как так??? :(

Share this post


Link to post
Share on other sites

Попробую угадать.

Если отсчитывая порты по порядку, поделить их на группы по 8 (то есть первые восемь портов - первая группа, следующие 8 - вторая, итд), то не получается ли, что правильно работающий портчаннел собран из портов одной группы, а проблемный - из портов разных групп?

Share this post


Link to post
Share on other sites

Проще было спросить - порты портченела висят на однои asic или на разных?

Share this post


Link to post
Share on other sites

Проще было спросить - порты портченела висят на однои asic или на разных?

А вдруг пациент не знает про PortASIC? :)

Share this post


Link to post
Share on other sites

Вот я не знал что есть проблема с qos если порты на разный asic

Share this post


Link to post
Share on other sites

Вообщем в минуты пиковых нагрузок решил я и проверить версию с асиками :)

 

 

C3560R#sh platform pm if-numbers

раньше порты сидели так:

interface gid gpn lpn port slot unit slun port-type lpn-idb gpn-idb

----------------------------------------------------------------------

Gi0/10 10 10 10 3/0 1 10 10 local Yes Yes

Gi0/15 15 15 15 2/0 1 15 15 local Yes Yes

похоже асики разные

 

посадил их так

interface gid gpn lpn port slot unit slun port-type lpn-idb gpn-idb

----------------------------------------------------------------------

Gi0/15 15 15 15 2/0 1 15 15 local Yes Yes

Gi0/16 16 16 16 2/1 1 16 16 local Yes Yes

асик одинаковый

 

для справки безпроблемные порты вот..

Gi0/27 27 27 27 4/1 1 27 27 local Yes Yes

Gi0/28 28 28 28 4/0 1 28 28 local Yes Yes

асик также одинаковый

 

И проблема не исчезла :(

также 25% канала нет, если вырубить один интерфейс как я и говорил выше выше загрузка гигабитного порта выше 750 мегабит не вылезает тоесть также 25% нет.

вот такие дела :( какие есть ещё тонкости?

Edited by skinner

Share this post


Link to post
Share on other sites

вообщем локально проблему вылечили.

если кому-то интересен мой опыт то вылечилось тем что я плохой портченел пересадил в тот же асик где жил хороший

 

sh platform pm if-numbers

Gi0/25 25 25 25 4/3 1 25 25 local Yes Yes

Gi0/26 26 26 26 4/2 1 26 26 local Yes Yes

Gi0/27 27 27 27 4/1 1 27 27 local Yes Yes

Gi0/28 28 28 28 4/0 1 28 28 local Yes Yes

 

какой то этот 4-й асик волшебный видимо ) подключён к сфп портам во первых, а во вторых

 

по следующей команде чем-то отличается от остальных :)

show platform port-asic version

 

Port-Asic Version Info:

========================

ASIC-0: Version:9 DeviceType:0x2F4

ASIC-1: Version:9 DeviceType:0x2F4

ASIC-2: Version:9 DeviceType:0x2F4

ASIC-3: Version:9 DeviceType:0x2F4

ASIC-4: Version:12 DeviceType:0x2C1

ASIC-5: Version:9 DeviceType:0x2F4

ASIC-6: Version:9 DeviceType:0x2F4

 

раньше до этого не обращал внимания, но посмотрел на другие портченелы на этой же железке где по 4 и более линков собрано, выглядит так что похоже всё что на медных портах 3560 выше чем 75% загрузки при включёном косе не фурычит 0_о...

 

в целом дело закрыто но.. интересно может у кого-то есть другой опыт?

Edited by skinner

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this