Jump to content
Калькуляторы

D-link агрегация для двух бриджевых РРЛ

Здравствуйте, ув. гуру!

Имеем схему:

Dlink 3028 (1 и 2 порты) <-----> 2 независимых радио канала (bridge) <----> (1 и 2 порты)Dlink 3028

 

Если я на обоих свичах Dlink 3028 на 1 и 2 портах включу LACP 802.3ab, то получится-ли у меня суммировать каналы за счет 2-х радиоканалов?

На каком уровне происходит агрегация?

Спасибо!

Edited by morf

Share this post


Link to post
Share on other sites

Понял, спасибо!

И такой вопрос, в случае агрегации портов на коммутаторах, смогу-ли я видеть в агрегированном канале свои РРЛ ?

Share this post


Link to post
Share on other sites

Здравствуйте, ув. гуру!

Имеем схему:

Dlink 3028 (1 и 2 порты) <-----> 2 независимых радио канала (bridge) <----> (1 и 2 порты)Dlink 3028

 

Если я на обоих свичах Dlink 3028 на 1 и 2 портах включу LACP 802.3ab, то получится-ли у меня суммировать каналы за счет 2-х радиоканалов?

На каком уровне происходит агрегация?

Спасибо!

 

 

Назовите модель что за РРЛ у вас используется

Share this post


Link to post
Share on other sites

mikrotik rb800

Тарелка 0,9 м с облучателем mimo2х2 + протокол nstream2.

В результате чего скорость достигается до 200 мбит на 1-м линке.

 

Интерфейсы бриджуются - соот-но все прозрачно.

Share this post


Link to post
Share on other sites

И какая суммарная скорость в итоге?

200 мбит/с это udp или tcp, микротиковским тестом?

Share this post


Link to post
Share on other sites

200 мбит udp - это максимальное значение. В реальности около 170-180 udp и около 80 tcp.

Суммарная скорость при агрегации радиолинков через LACP 802.3ab - это вопрос теории, который я скоро буду осуществлять.

Так же остается открытым вопрос о доступности этих микротиков после агрегации на портах dlink'ов.

Share this post


Link to post
Share on other sites

Линк сколько километров? помоему rb800 деньги на ветер

Share this post


Link to post
Share on other sites

21 км и 5, у меня большой опыт построения линков на различных роутербордах. Могу смело заверить, что рб800 стоит своих денег.

И так - все это флуд. Меня таки интересует вопрос насчет доступности точек в случае агрегации их на портах.

Share this post


Link to post
Share on other sites

Такая агрегация будет работать только тогда, когда скорости и задержка через оба радиоканала одинаковые и нет потерь. На практике такое получается редко, в итоге потратите время зря и не получите нормальных результатов. Запустите лучше кольцо на OSPF, оно работает на 3-м уровне и на задержки и разницу в скоростях ему побоку. Только понадобятся еще 2 микротика с обоих сторон, к которым будут подключены 2 радиолинка и "выходной" кабель.

Share this post


Link to post
Share on other sites

Здравствуйте, ув. гуру!

Имеем схему:

Dlink 3028 (1 и 2 порты) <-----> 2 независимых радио канала (bridge) <----> (1 и 2 порты)Dlink 3028

 

Если я на обоих свичах Dlink 3028 на 1 и 2 портах включу LACP 802.3ab, то получится-ли у меня суммировать каналы за счет 2-х радиоканалов?

На каком уровне происходит агрегация?

Спасибо!

 

Очень не рекомендую Вам делать так, как Вы захотели. Во-первых Вы все же не включите толком LACP при таком подходе, т.к. MAC будут разными в этих линках. Следовательно, кто последний будет воткнут/поднят, тот и отвалится. Потом агрегация LACP - это псевдо агрегация, то есть она работает только тогда, когда есть "насыщенная" MAC сеть с обоих сторон или хотя бы Вы должны понимать, как она работает. Я же Вам предлагаю поднять так, как, например делаю я. Поднимается канал по отдельному VLAN с каждой стороны для соединения бриджей и делается round-robin проброс прямо на одном из микротиков с каждой стороны. В этом случае будет действительно агрегация по типу "пакет туда, пакет сюда" :). Одно "но" при такой схеме, будут теряться пакеты, увеличиваться пинг, если один из радио-прострелов будет глючить. round-robin не определяет, упал ли канал и уж тем более его качество. Тут уж сорри. То есть если один канал разрушить, будет 50% loss.

Share this post


Link to post
Share on other sites

Спасибо за Ваши ответы!

Исходя из двух последних постов, нужны будут по 1-у микротику с каждой стороны. Единственное методы реализации разные:

в-первом случае: подымаются шлюзы с ospf-роутингом.

во-втором: mikrotik bonding balance-rr

Все верно?

Share this post


Link to post
Share on other sites

Спасибо за Ваши ответы!

Исходя из двух последних постов, нужны будут по 1-у микротику с каждой стороны. Единственное методы реализации разные:

в-первом случае: подымаются шлюзы с ospf-роутингом.

во-втором: mikrotik bonding balance-rr

Все верно?

 

Все верно, только я никогда не применял OSPF в таких случаях, ибо нужно сделать прозрачный Ethernet канал. А роутинг он и round-robin бывает, безо взяких OSPF. ;))))

Share this post


Link to post
Share on other sites

Почитал мануал по bonding'у на микротике. Можно включить arp-monitor или MII мониторинг, и в случае падения одного из каналов он будет посылать пакеты через рабочий, а не получать 50% потери.

Прямо тут об это пишут с примерами: http://wiki.mikrotik.com/wiki/Manual:Interface/Bonding#ARP_Monitoring

Edited by morf

Share this post


Link to post
Share on other sites

Почитал мануал по bonding'у на микротике. Можно включить arp-monitor или MII мониторинг, и в случае падения одного из каналов он будет посылать пакеты через рабочий, а не получать 50% потери.

Прямо тут об это пишут с примерами: http://wiki.mikrotik.com/wiki/Manual:Interface/Bonding#ARP_Monitoring

 

По-моему не работало или приводило к нежелательным последствиям, по крайней мере для меня. Поэтому отказался. ;)

Share this post


Link to post
Share on other sites

Бондинг не будет работать, пробовал=)

 

Вот как надо:

 

ospf.png

 

На каждом из линков делается своя подсеть - 192.168.0.х и 192.168.1.х., 192.168.3.х, 192.168.4.х и 192.168.5.х. Хотя сделать это можно и из трех подсетей, суть в том что соседние роутеры не должны ничего знать о адресах на соседних. Все микротики запускаются в режим роутера, запускается OSPF и настраивается маршрутизация так, чтобы по одному каналу шло в одну сторону, по другому в другую. А дальше на выходах крайних микротиков делаете уже то, что надо, или забираете трафик по L3, или создаете EoIP туннель, если нужен L2. В итоге не имеем никаких потерь и проблем.

 

Такую схему можно отработать на столе, используя 3шт. RB750. Когда я настраивал - все очень легко и быстро заработало. Но на данный момент такие схемы не применяю, т.к. отпала надобности.

Share this post


Link to post
Share on other sites

Бондинг не будет работать, пробовал=)

 

Вот как надо:

 

post-60991-098290400 1312473782_thumb.png

 

На каждом из линков делается своя подсеть - 192.168.0.х и 192.168.1.х., 192.168.3.х, 192.168.4.х и 192.168.5.х. Хотя сделать это можно и из трех подсетей, суть в том что соседние роутеры не должны ничего знать о адресах на соседних. Все микротики запускаются в режим роутера, запускается OSPF и настраивается маршрутизация так, чтобы по одному каналу шло в одну сторону, по другому в другую. А дальше на выходах крайних микротиков делаете уже то, что надо, или забираете трафик по L3, или создаете EoIP туннель, если нужен L2. В итоге не имеем никаких потерь и проблем.

 

Такую схему можно отработать на столе, используя 3шт. RB750. Когда я настраивал - все очень легко и быстро заработало. Но на данный момент такие схемы не применяю, т.к. отпала надобности.

 

Т.е. получается tx по одном каналу rx по другому. А на крайних микротиках (если нужен L2) создаю eoip и загоняю их в bonding для суммирования канала?

По-моему я не так понял.

Почему бы в данной схеме исключить ospf и сделать исключительно bonding mode=balance-rr.

Что думаете, профессор ?

Share this post


Link to post
Share on other sites

Все правильно поняли. Если нужен L2 загоняете в EoIP туннель, но он съест 20% производительности канала. Бондинг тут лишнее. Возьмите на столе различные схемы понастраивайте.

 

Но мы в сети используем PPPoE для подключения клиентов, поэтому если нужно больше скорости - делаем 2 независимых канала до PPPoE терминатора и они сами автоматически балансируются.

 

Если бы у вас были настоящие РРЛ, которые гарантируют доставку пакетов, можно было бы городить балансировку по L2, но в случае микротиков такой фокус не пройдет.

Share this post


Link to post
Share on other sites

Все правильно поняли. Если нужен L2 загоняете в EoIP туннель, но он съест 20% производительности канала. Бондинг тут лишнее. Возьмите на столе различные схемы понастраивайте.

 

Но мы в сети используем PPPoE для подключения клиентов, поэтому если нужно больше скорости - делаем 2 независимых канала до PPPoE терминатора и они сами автоматически балансируются.

 

Если бы у вас были настоящие РРЛ, которые гарантируют доставку пакетов, можно было бы городить балансировку по L2, но в случае микротиков такой фокус не пройдет.

Т.е. фактически Вы предлагаете не балансировать канал, а разделить на входящий и исходящий трафик по разным каналам ?

Share this post


Link to post
Share on other sites

Т.е. фактически Вы предлагаете не балансировать канал, а разделить на входящий и исходящий трафик по разным каналам ?

 

Да, получится что-то вроде nstreme-dual или FDD в релейках. Если один канал выйдет из строя, весь трафик пойдет через оставшийся.

Share this post


Link to post
Share on other sites

Т.е. фактически Вы предлагаете не балансировать канал, а разделить на входящий и исходящий трафик по разным каналам ?

 

Да, получится что-то вроде nstreme-dual или FDD в релейках. Если один канал выйдет из строя, весь трафик пойдет через оставшийся.

По-моему в nstream2 с гарантированной доставкой пакета стало лучше, единственное, если канал не качественный то обработка ошибочных/не доставленных фреймов кладется на процессор, но при этом канал держится стабильно. Есть у меня такой не качественный линк - на нем и загрузка процессора больше, но работает без потерь.

Может я и не прав.

Дело в том, что для меня не выгодно разделать трафик по каналам. Соотношение 1:3 или 4.

Edited by morf

Share this post


Link to post
Share on other sites

Все правильно поняли. Если нужен L2 загоняете в EoIP туннель, но он съест 20% производительности канала. Бондинг тут лишнее. Возьмите на столе различные схемы понастраивайте.

 

Но мы в сети используем PPPoE для подключения клиентов, поэтому если нужно больше скорости - делаем 2 независимых канала до PPPoE терминатора и они сами автоматически балансируются.

 

Если бы у вас были настоящие РРЛ, которые гарантируют доставку пакетов, можно было бы городить балансировку по L2, но в случае микротиков такой фокус не пройдет.

 

Ужас. Вы людям навязываете OSPF там где не нужно, но еще и пугаете про 20% потерю производительности на EoIP туннелях. ;)))

Давайте обратимся к документации разработчиков http://www.mikrotik.com/testdocs/ros/3.0/vpn/eoip.php и найдем корень зла: "mtu (integer; default: 1500) - Maximum Transmission Unit. The default value provides maximal compatibility, although it may lead to decreasing performance on wireless links due to fragmentation. If you can increase MTU on all links inbetween, you may be able to regain optimal performance"

Собственно говоря, тут говорится, что накладывая EoIP на такую непонятную структуру как 802.11abgn в конкретных условиях, при конкретных уровнях сигнала и возможных ухудшениях и улучшениях следует "поиграться" с MTU, конечно, если это кому то нужно и требуется. К слову говоря, EoIP на 802.3 будет работать БЕЗ деградации в скорости.

 

Заявление "Бондинг не будет работать, пробовал=)" весьма смелое, надо будет перепроверить, работают ли мои радиолинки или cacti из пальца высасывает показания. ;) То, что было описано мной в качестве примера, это один из вариантов бондинга, которые я использую. Еще у меня есть одна гордость, построенная мной ранее - это когда концы Mikrotik на периферии приземлялись не сразу на свитч, а тянулись в виде EoIP туннелей и бондились = балансировались/резервировались на одном мощном PC Mikrotik в центре сети (стойке). ;) Вот это я понимаю, агрегат.

Edited by tartila

Share this post


Link to post
Share on other sites

tartila, Saab95 спасибо за поддержку темы.

Вы про такую схему? Единственное в этой схеме не предусмотрен eoip, не понимаю зачем он. Если канал с микротика идет в свитч, то можно ведь vlan прокинуть.

И кстати, я был бы Вам благодарен, если Вы предоставили хар-ки Вашего агрегированного канала :)

post-64099-077609100 1312526722_thumb.png

Edited by morf

Share this post


Link to post
Share on other sites

Подниму тему. В данный момент интересует настройка двух радио-бриджей в паре для повышения производительности резервного канала (прозрачного разумеется), на руках есть два бриджа (в данный момент не важно каких) и два микротика rb1100, до данного момента микротики никогда не настраивал, вот что сейчас есть:

 

На микротиках отключаем все интерфейсы, кроме первых 3-х, т.е. ether1-3.

Каждому интерфейсу назначаем ip адрес, в моём случае это на первом микротике:

eth1 192.168.20.1/24

eth2 192.168.5.1/24

eth3 192.168.10.1/24

 

На втором микротике.

eth1 192.168.20.2/24

eth2 192.168.5.2/24

eth3 192.168.10.2/24

 

Ether1 – на обоих микротиках будем использовать как порт для подключения сегмента сети.

Ether2 и Ether3 – соответственно для работы радио-линков.

 

Для теста, порты микротиков были соединены патчкордами 2-2, 3-3 соответственно, к первым портам микротиков были подключены 2-а ноута с подсетью 192.168.200.0

 

Далее был поднят EoIP туннель на первом микротике:

/interface eoip add remote-address=192.168.10.2 local-address=192.168.10.1 tunnel-id=0 name=eoip-tunnel1 disabled=no

 

EoIP туннель на втором микротике:

/interface eoip add remote-address=192.168.5.1 local-address=192.168.5.2 tunnel-id=0 name=eoip-tunnel1 disabled=no

 

На втором микротике. Объединяем EoIP туннель бриджем с интерфейсом Ether1 на каждом микротике.

/interface bridge add

/interface bridge port add bridge=bridge1 interface=ether1

/interface bridge port add bridge=bridge1 interface= eoip-tunnel1

 

Далее начинаются вопросы, нужно ли в данной схеме OSFP?

На обоих микротиках выполняем:

/routing ospf network

add network=192.168.5.0/24 area=backbone

add network=192.168.10.0/24 area=backbone

 

На микротике 1 выполняем:

/routing ospf interface add interface=ether2 cost=100

 

На микротике 2 выполняем:

/routing ospf interface add interface=ether3 cost=100

 

Прошу прокомментировать, сильно не бить, ценные советы были бы просто замечательны) Ну и вообще как лучше реализовать?

Edited by BeHalf

Share this post


Link to post
Share on other sites

Вот это сообщение прочитайте, там и схема есть как делать=) - http://forum.nag.ru/forum/index.php?showtopic=68359&view=findpost&p=631267

 

Заявление "Бондинг не будет работать, пробовал=)" весьма смелое, надо будет перепроверить, работают ли мои радиолинки или cacti из пальца высасывает показания. ;) То, что было описано мной в качестве примера, это один из вариантов бондинга, которые я использую. Еще у меня есть одна гордость, построенная мной ранее - это когда концы Mikrotik на периферии приземлялись не сразу на свитч, а тянулись в виде EoIP туннелей и бондились = балансировались/резервировались на одном мощном PC Mikrotik в центре сети (стойке). ;) Вот это я понимаю, агрегат.

 

Так тут зависит какие требования к каналу. Колебания задержки, количество потерянных пакетов. Многие используют каналы с плохим качеством но большой скоростью, и это их вполне устраивает. А если нужен хороший магистральный канал, тогда приходится идти на разного рода ухищрения.

 

Хотя странно смотреть на людей=) они покупают RB800 чтобы сделать на нем линк - выкидывают кучу денег на то, что не нужно=) Ведь 4 штуки RB800 стоят 40 тыс. рублей + карточки. Еще немного добавить и можно сделать канал на ваймаксе с максимальной скоростью 30 мегабит и гарантированной доставкой пакетов с задержкой 7мс.

 

А если городить еще и сервера для бондинга, которые стоят так же денег=) Лучше сразу операторское оборудование использовать.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this