Jump to content
Калькуляторы

Прием от провайдера мультикаста по PIM и настройка PIM в своей сети :D длинк циско циско циско циско.... :)

Есть интересная задача (а может и не очень)

 

значит нам один провайдер отдает мультикаст по PIM-SM дальше надо в своей сети организовать маршрутизацию мультикаста

 

Значит получается цепочка типо (по порядку от источника мультикаста)

0. Источник мультикаста

1. Оборудования провайдера мультикаста (вроде там какой то длинк стоит)

2. наша циско 3750g №1

3. наша циска 3750g №2

4. наша циска..... №n

 

линк с провйдером получается между 1-2 железкой.

 

у нас на 3750g №1 настроено:

 

ip igmp snooping
!
ip multicast-routing distributed
!
interface Vlan50
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
!
interface Vlan150
ip address 172.2.2.1 255.255.255.252
ip pim sparse-mode
!
ip route 172.1.1.0 255.255.255.0 172.2.2.2
!
ip pim rp-address 172.1.1.1 IPTV override
!
ip access-list standard IPTV
permit 239.224.20.0 0.0.0.255

Vlan150 - это влан с интерфейсом в сторону провайдера с мультикастом

Vlan50 - мультикаст VLAN для наших абонентов

172.1.1.1 точка рандеву мультикаст групп которые мы берем у провайдера (если не ошибаюсь 172.2.2.2 и 172.1.1.1 это 2 интерфейса на одной и той же железки)

у абонентов подключенных к этой железке с мультикастом все впорядке

 

теперь вопрос как сделать чтобы мультикаст маршрутизировался на 3750g №2

 

Пробовал добавить в интерфейсах локальной маршрутизации

3750g №1

interface Vlan100
ip address 10.20.0.1 255.255.255.128
ip ospf network broadcast
ip ospf 2 area 0
ip pim sparse-mode

 

3750g №2

interface Vlan100
ip address 10.20.0.2 255.255.255.128
ip ospf network broadcast
ip ospf 2 area 0
ip pim sparse-mode

interface Vlan50
ip address 10.1.1.2 255.255.255.0
ip pim sparse-mode

неработает, что делать с точкой рандеву.

у провайдера предоставляющего мультикаст нету маршрутов на наши подсети и естественно с 3750g №2 адрес 172.1.1.1 не пингуется (и добавить нет возможности)

 

подскажите как быть (раскинуть везде по магистралям vlan 50 и включить igmp snooping не совсем правильно, хотя сейчас так и работает)

Edited by mukca

Share this post


Link to post
Share on other sites

я бы попросил провайдера не давать мне по PIM, зачем такой да ещё лишняя для вас точка проблем. Пусть он вам просто сыпет поток каналов а вы уже сами решите что с ним делать и не будет у вас проблем.

Share this post


Link to post
Share on other sites

на №2 RP так же должна быть задана статично

 

ip pim rp-address 172.1.1.1 IPTV override

 

и до неё должен быть маршрут в таблице маршутизации(статикой или по протоколу маршрутизации)

связности между вашими сетями и RP при этом не обязательно быть, только маршрут

 

в сторону абонентов надо говорить

ip pim passive

Share this post


Link to post
Share on other sites
и до неё должен быть маршрут в таблице маршутизации(статикой или по протоколу маршрутизации)

связности между вашими сетями и RP при этом не обязательно быть, только маршрут

да но у провайдера дающего мультикаст нет маршрута на нашу сеть 10.0.0.0/8 (как понимаю у провайдера тоже используются сеть 10.0.0.0/8 )

Share this post


Link to post
Share on other sites

это не важно, могут быть даже совпадающие сети.

сигнализация вся проходит внутри PIM(source-ip у IP пакетов меняются hop-by-hop, и заменяются адресом интерфейса смотрящего в сторону RP), а не unicast/multicast сообщениями от IP ваших хостов.

в случае успешной сигнализации, обратный поток мультикаста маршрутизируется по цепочке к точке запроса(l3 свич к которому подключен коммутатор доступа), где он в соответствии с IGMP таблицей выкидывает multicast в нужный интерфейс.

Share this post


Link to post
Share on other sites

Городить один pim домен между разными as не очень кошерно. Попробуйте нагнуть провайдера мультика настроить msdp+mbgp. Сразу отпдут все проблемы с маршрутами до сорсов. RP и BSR лучше указывать кандидатами. Если не хочется прозрачно гнать мультик через цепочку каталистов со снупингом, можно настроть анонсы RP с первого каталиста. А на конце уже pim passive в сторону хомячков.

Share this post


Link to post
Share on other sites

3gvanek

а где вы разные AS увидили?? там вообще негде неиспользуется BGP. Просто небольшой локальный пиринг :D

 

Если не хочется прозрачно гнать мультик через цепочку каталистов со снупингом, можно настроть анонсы RP с первого каталиста. А на конце уже pim passive в сторону хомячков.

дайте пример

 

ingress

пробовал на №2 указать

ip pim rp-address 172.1.1.1 IPTV override

ip route 172.1.1.0 255.255.255.0 10.20.0.1

 

не работает

поэтому тут сразу и спросил :)

Share this post


Link to post
Share on other sites

3gvanek

а где вы разные AS увидили?? там вообще негде неиспользуется BGP. Просто небольшой локальный пиринг :D

 

Ну, если Вы говорите, что получаете мультикаст от другого провайдера, то очевидно что у вас разные AS. То, что нет BGP - как раз и плохо. Дело в том, что идеологически гораздо правильней использовать Inter-domain multicast routing в случае обмена мультикастом между разными автономными системами. Этим собственно и являются msdp+mbgp как протоколы обнаружения источников мультикаста и маршрутизации в довесок к pim-sm. Хотя бы потому что такую схему легче дебажить и обслуживать.

 

Вот представьте, что вы сейчас получили 100 ТВ-каналов от провайдера, написали статику на сорсы мультикаста и все вроде хорошо работает. Потом хитрые продажники решили этот мультикаст продавать разным домосетям в вашем городе. Вы с ними точно так же пиритесь, pim-sm, статика через вас до сорсов. А потом провайдер меняет адреса сорсов, или еще лучше - часть каналов берет где то еще, тоже с помощью pim. И что, всем заново статику переписывать? Зачем она нужна, если mbgp все роуты сам сложит в rpf таблицу? Зачем забивать основную таблицу маршрутизации или vrf'ы статикой на серые сети сорсов, если, например, эта серая адресация пересекается с вашей или ваших пиров?

 

Тема маршрутизации мультика очень жаже обширная, поэтому вот вам в качестве примера http://www.cisco.com/en/US/tech/tk828/technologies_tech_note09186a0080094821.shtml

По ключевым словам из этого гайда найдете много полезного на том же cisco.com

Share this post


Link to post
Share on other sites

показывайте тогда

show ip igmp snooping vlan 50

show run | inc pim

show run | inc multicast

а лучше весь конфиг.

 

3gvanek

некоторые не могут, или принципиально не хотят

допустим в Москве это home-ix

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this