Jump to content
Калькуляторы

Микротик и с чем его едят Описание, примеры, вопросы, трудности, с которыми придется столкнуться

питание 220 тянули к свичу? или тупо от того же БП что питает микротик взяли?

свич питается от своего БП, 220 было близко...

Share this post


Link to post
Share on other sites

Подскажите, пожалуйста, в чем может быть проблема:

 

Была переадресация DNS-запросов на семейный DNS Яндекса

1.add action=netmap chain=dstnat disabled=no dst-port=53 protocol=udp to-addresses=77.88.8.7

 

всё прекрасно работало, пока не включил прокси

2.add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp src-address-list=users to-ports=3128

 

теперь возникает впечатление, что правило 1 не отрабатывает, по крайней мере DNS Яндекса ничего не отсекает, хотя

счетчики этого правила щелкают...

Share this post


Link to post
Share on other sites

Подскажите, пожалуйста, в чем может быть проблема:

 

Была переадресация DNS-запросов на семейный DNS Яндекса

1.add action=netmap chain=dstnat disabled=no dst-port=53 protocol=udp to-addresses=77.88.8.7

 

всё прекрасно работало, пока не включил прокси

2.add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp src-address-list=users to-ports=3128

 

теперь возникает впечатление, что правило 1 не отрабатывает, по крайней мере DNS Яндекса ничего не отсекает, хотя

счетчики этого правила щелкают...

Пропишите этот DNS в самом микротике без правила редиректа.

Share this post


Link to post
Share on other sites

Всем Доброго времени суток!

Вопрос от совсем дилетанта (курил мануалы, читаю форум), пытаюсь на базе RB951 сделать репитер, настраивал по статье от Lanmart.

В итоге железка раздает инет по кабелю, но при попытке подключиться к вафле, в wireless - registration в момент подключения

вижу мак подключаемого устройства, но дальше "сеть не отвечает" и тишина. Пните плиз в нужном направлении, заранее благодарен.

 

export compact

 

# jan/01/2002 01:45:11 by RouterOS 6.30.2

# software id = 0C7K-Z7I1

#

/interface bridge

add mtu=1500 name=bridge1

/interface wireless

set [ find default-name=wlan1 ] band=2ghz-b/g/n basic-rates-b="" default-authentication=no disabled=no guard-interval=long \

hw-protection-mode=rts-cts hw-retries=15 l2mtu=1600 mode=ap-bridge radio-name=Slave rate-set=configured ssid=\

BLA_BLA_BLA supported-rates-b="" tx-power-mode=all-rates-fixed wds-default-bridge=bridge1 wds-mode=dynamic \

wireless-protocol=802.11

/interface wireless security-profiles

set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" group-ciphers=tkip,aes-ccm unicast-ciphers=\

tkip,aes-ccm wpa-pre-shared-key=31012005 wpa2-pre-shared-key=31012005

/tool user-manager customer

set admin access=own-routers,own-users,own-profiles,own-limits,config-payment-gw

/interface bridge port

add bridge=bridge1 interface=wlan1

add bridge=bridge1 interface=ether1

add bridge=bridge1 interface=ether2

add bridge=bridge1 interface=ether3

add bridge=bridge1 interface=ether4

add bridge=bridge1 interface=ether5

/interface wireless access-list

add signal-range=-80..120 vlan-mode=no-tag

/interface wireless connect-list

add interface=wlan1 security-profile=default

/ip address

add address=192.168.1.2/24 interface=bridge1 network=192.168.1.0

/system lcd

set contrast=0 enabled=no port=parallel type=24x4

/system lcd page

set time disabled=yes display-time=5s

set resources disabled=yes display-time=5s

set uptime disabled=yes display-time=5s

set packets disabled=yes display-time=5s

set bits disabled=yes display-time=5s

set version disabled=yes display-time=5s

set identity disabled=yes display-time=5s

set bridge1 disabled=yes display-time=5s

set wlan1 disabled=yes display-time=5s

set ether1 disabled=yes display-time=5s

set ether2 disabled=yes display-time=5s

set ether3 disabled=yes display-time=5s

set ether4 disabled=yes display-time=5s

set ether5 disabled=yes display-time=5s

set wds4 disabled=yes display-time=5s

/system leds

set 5 interface=wlan1

/tool romon port

add

/tool user-manager database

set db-path=user-manager

Share this post


Link to post
Share on other sites

Подскажите, пожалуйста, в чем может быть проблема:

 

Была переадресация DNS-запросов на семейный DNS Яндекса

1.add action=netmap chain=dstnat disabled=no dst-port=53 protocol=udp to-addresses=77.88.8.7

 

всё прекрасно работало, пока не включил прокси

2.add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp src-address-list=users to-ports=3128

 

теперь возникает впечатление, что правило 1 не отрабатывает, по крайней мере DNS Яндекса ничего не отсекает, хотя

счетчики этого правила щелкают...

Пропишите этот DNS в самом микротике без правила редиректа.

Спасибо. Иначе никак? Просто хотелось бы знать из-за чего такое происходит, чтобы глубже разбираться в вопросе.

Скажем, возникнет необходимость части пользователей ходить через DNS Яндекса, а части через установленные по умолчанию.

Share this post


Link to post
Share on other sites

Настройте одно устройство как нужно, далее разверните окно винбокса на весь экран, нажмите кнопку New Terminal и разверните его так же на весь экран, напишите там export compact и нажмите Enter. Будет выведен весь конфиг в текстовом виде. Соответственно выделяете его и копируете. Если он большой и прокрутился, нажимаете правой кнопкой мышки в фон окна и выбираете Copy All. Далее полученный текст вставляете в блокнот, удаляете лишнее, вставляете пароль на доступ, т.к. в конфиге его не будет и заливаете на новые устройства, предварительно скинув начальные настройки.

 

Не забудьте вставить в конец изменение параметров буферизации, что бы уменьшить вероятность потерь данных в радио канале при высокой нагрузке.

 

/queue type

set 1 pfifo-limit=1000

set 2 kind=pfifo pfifo-limit=1000

 

Эта команда устанавливает пароль на устройство.

 

/user set 0 password=mikrotik-password

 

 

А данный параметр где необходимо настраивать? На базе или на клиентах ?

Share this post


Link to post
Share on other sites

Я настроил на базе и на клиентах.

Share this post


Link to post
Share on other sites

Скажем, возникнет необходимость части пользователей ходить через DNS Яндекса, а части через установленные по умолчанию.

У меня эта же задача решается точно таким же правилом, только в адресс листе нужно внести тех кому ходить через DNS яндекса и ни каких проски не надо.

Share this post


Link to post
Share on other sites

Скажем, возникнет необходимость части пользователей ходить через DNS Яндекса, а части через установленные по умолчанию.

У меня эта же задача решается точно таким же правилом, только в адресс листе нужно внести тех кому ходить через DNS яндекса и ни каких проски не надо.

У меня прокси включен для совсем других целей. Фишка в том, что когда включаю прокси, перестаёт работать переадресация DNS :(

Share this post


Link to post
Share on other sites

Можно ли конфиги (бекап) заливать в микротик без изменения маков и почему конфиг выключает вай фай и не восстанавливает режим работы из бекапа

...

Не забудьте вставить в конец изменение параметров буферизации, что бы уменьшить вероятность потерь данных в радио канале при высокой нагрузке.

 

/queue type

set 1 pfifo-limit=1000

set 2 kind=pfifo pfifo-limit=1000

...

А давайте обсудим, какие все же типы очередей оптимально использовать для наиболее эффективной, рациональной работы с радиомостами, воткнутыми в медные Ethernet-порты Микротиков?

 

Я, например, так делаю на RB750UP, который рулит/питает несколько секторов:

/queue interface

set ether1-gateway queue=wireless-default

set ether2-master-local queue=wireless-default

set ether3-slave-local queue=wireless-default

set ether4-slave-local queue=wireless-default

set ether5-slave-local queue=wireless-default

Соседняя страничка в Winbox сообщает, что wireless-default фактически является sfq-очередью, что мне импонирует по задаче ("и никто из клиентов не уйдет обиженным").

 

Однако вопрос эффективности по загрузке очередями CPU этого не самого мощного устройства в линейке, а также качеству разруливания пакетов перед радиосегментом остается открытым.

Share this post


Link to post
Share on other sites

Если у вас радиомост, то с одной стороны идут данные из сетевого порта, потом попадают в беспроводку, где скорость может быть ниже. Если у вас большой буфер, то пришедший поток данных легко в него помещается и потихоньку передается. Приложения абонентов понимают, что скорости не хватает, ведь задержка увеличивается, и сбавляют скорости. В итоге все работает отлично. Когда стоят другие режимы, часто наблюдаются дропы, приложения не понимают в чем дело и запрашивают данные повторно, в итоге канал загружен, а скорость маленькая.

Share this post


Link to post
Share on other sites

Если у вас радиомост, то с одной стороны идут данные из сетевого порта, потом попадают в беспроводку, где скорость может быть ниже. Если у вас большой буфер, то пришедший поток данных легко в него помещается и потихоньку передается. Приложения абонентов понимают, что скорости не хватает, ведь задержка увеличивается, и сбавляют скорости. В итоге все работает отлично. Когда стоят другие режимы, часто наблюдаются дропы, приложения не понимают в чем дело и запрашивают данные повторно, в итоге канал загружен, а скорость маленькая.

 

Получается ставим на стыках LAN - WLAN т.е. на базе и на клиентских антеннах?

/queue type

set 1 pfifo-limit=1000

set 2 kind=pfifo pfifo-limit=1000

 

Share this post


Link to post
Share on other sites

Да, только по сетевому порту нужно небольшое уточнение в зависимости от модели оборудования, часто используется другой тип буфера и указанные вами данные не применяются. Проверьте данные вручную после ввода команды.

Share this post


Link to post
Share on other sites

Да, только по сетевому порту нужно небольшое уточнение в зависимости от модели оборудования, часто используется другой тип буфера и указанные вами данные не применяются.

Оборудование SXT SA и SXT Lite5.

Захожу в Interface Queue Type и вижу что по умолчанию only-hardware-queue.

 

Тогда получается меняем на 7 = set 7 kind=pfifo pfifo-limit=1000, это имели ввиду ?

Share this post


Link to post
Share on other sites

Захожу в Interface Queue Type и вижу что по умолчанию only-hardware-queue.

 

Тогда получается меняем на 7 = set 7 kind=pfifo pfifo-limit=1000, это имели ввиду ?

 

Вам нужно сменить этот тип буфера на PFIFO, а не менять значения аппаратной настройки, хотя это тоже можно сделать.

 

Когда меняете эту настройку (тип буфера сетевого порта), нужно понимать, что когда будут поступать данные, а через радио они не уходят, будет увеличиваться задержка до самого устройства, и если вы запустите тест скорости с большим превышением, можете потерять доступ на устройство, пока буферы не освободятся.

Этот эффект встречается не часто, однако нужно понимать, что он может иметь место.

Share this post


Link to post
Share on other sites

Ну увеличиваем мы размеры буферов pfifo... а как посмотреть статистику их использования?

Что-то не нашел такой команды, особенно для очередей интерфейсов. Для Simple Queues кое-что есть -- дропнутое, накопленное, скорости средние.

А для интерфейсов разве нет возможности мониторинга? Ну и откуда тогда берутся такие pfifo-limit? Как их подбирать оптимально?

Share this post


Link to post
Share on other sites

Тест скорости запускаете с таким потоком, который через радио не проходит, тут же запускаете и пинг с большим таймаутом, видите, что задержка начнет сильно увеличиваться. Чем больше размер буфера, тем сильнее увеличивается.

Share this post


Link to post
Share on other sites

Тест скорости запускаете с таким потоком, который через радио не проходит, тут же запускаете и пинг с большим таймаутом, видите, что задержка начнет сильно увеличиваться. Чем больше размер буфера, тем сильнее увеличивается.

Ну, положим, "тест скорости" делают клиенты, сообща -- и это слабо поддается регулированию (хотя Simple Queues настроены и в целом работают).

Канал к аплинку один, а раздача через несколько интерфейсов сразу, pfifo настроено по рекомендации выше на всех портах.

Радиолинк не насыщен в полку, поскольку Инета по тарифу не так много дают -- через внешний канал проверить тестом скорости наверное не получится.

 

Но! Есть косвенная статистика, что при нормальной такой дневной рабочей нагрузке получаем к себе до ~3Kpps, отдаем в Инет под ~2Kpps.

А pfifo-limit= у нас всего тысяча пакетов, то есть секундный объем в эту очередь конкретно не влезает.

Можно ли из этого сделать какой-то вывод? Или как-то оценить, например, через статистику Tools-Traceroute сквозь роутер?

 

Сейчас вот на сотню пакетов средний пинг 4.7мс, лучший 1.8, худший 66 и стандартное отклонение 5.7, потерь нет.

Проходим через ОДИН из интерфейсов (под нагрузкой около 700pps туда-обратно) с хорошим радиоканалом (заведомо быстрее Инета в два-три раза) и через один общий интерфейс в Инет, трассируем шлюз по умолчанию аплинка. Надо ли тут регулировать размер очереди pfifo?

Share this post


Link to post
Share on other sites

Тут есть 2 проблемы - проблема шейпера, в котором по умолчанию буфер вообще смешной - его надо поставить побольше, например 1000 пакетов, и второй вопрос шейпер на исходящем канале. Так вот, если исходящий канал быстрый и в полку не загружен, то на нем можно вообще ничего не делать.

Если же у вас канал загружен в полку, и например, имеет скорость порта 100М, то нужно повесить отдельный шейпер на входящий канал, и указать у него размер буфера такого размера, что бы не было дропов (их можно посмотреть в статистике), так же нужно поставить ограничение таким образом, что бы вышестоящий не дропал ваш канал, то есть скорость входящего потока не должна превышать 95 мегабит.

Share this post


Link to post
Share on other sites

Тут есть 2 проблемы - проблема шейпера, в котором по умолчанию буфер вообще смешной - его надо поставить побольше, например 1000 пакетов, и второй вопрос шейпер на исходящем канале. Так вот, если исходящий канал быстрый и в полку не загружен, то на нем можно вообще ничего не делать.

 

 

А можно подробней, по умолчанию на шейпере стоит 10 пакетов, Вы рекомендуете ставить 1000, при этом шейпер будет нормально резать скорость ? Торренты?

 

Было замечено если использовать Simple Queues со стандартным default-small 10 пакетов, то какое бы ограничение не ставил хоть 10 хоть 40 Мбит, смарт ТВ у клиентов при просмотре "качественного" HD контента работает плохо. Т.е. большие задержки в трансляции изображение, если отключить шейпер, проблема уходит.

Share this post


Link to post
Share on other sites

Проблема в том, что когда стоит 10 пакетов, то всегда будет такая ситуация, когда по запросу клиента пришло много данных, сверх скорости тарифа, они попадают в шейпер, все не влезают в буфер и отбрасываются, приложения запрашивают повторы, которые тоже отбрасываются. В итоге процентов 30 входящей скорости заняты повторами. Когда ставите 1000 то уже больше данных помещается в буфере и затраты на повторы уменьшаются. Можно поставить и больше размер, например 5000. Все проверяют опытным путем, желательно это делать в моменты наибольшей нагрузки, т.к. вы сможете наблюдать за изменением прокачки через оборудование.

Share this post


Link to post
Share on other sites

Проблема в том, что когда стоит 10 пакетов, то всегда будет такая ситуация, когда по запросу клиента пришло много данных, сверх скорости тарифа, они попадают в шейпер, все не влезают в буфер и отбрасываются, приложения запрашивают повторы, которые тоже отбрасываются. В итоге процентов 30 входящей скорости заняты повторами. Когда ставите 1000 то уже больше данных помещается в буфере и затраты на повторы уменьшаются. Можно поставить и больше размер, например 5000. Все проверяют опытным путем, желательно это делать в моменты наибольшей нагрузки, т.к. вы сможете наблюдать за изменением прокачки через оборудование.

 

 

Понятно, а если использовать шейпер на клиентской SXT и использовать большой буфер, скажем 5000 пакетов... Это нормальное решение?

Share this post


Link to post
Share on other sites

Нормальное, просто нужно понимать какие проблемы это может принести. Я обычно ставлю 1000 пакетов на клиентских устройствах. Тарифы до 20мбит.

Share this post


Link to post
Share on other sites

Приветствую, подскажите какой из способов изменения TTL(для йоты) будет более правильный, и почему? Если можно, в кратце их различия

add action=change-ttl chain=postrouting new-ttl=set:64

add action=change-ttl chain=output new-ttl=set:64

add action=change-ttl chain=forward new-ttl=set:64

Share this post


Link to post
Share on other sites

Приветствую столькнулся с проблемой скачет пинг база 3 абонента сигналы от -60-63 у всех CCQ 99% канал не утилизирован ,но при этом пинги 6-12 мс (проткол NV2 накручивает ?)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now