Jump to content
Калькуляторы

нужна помощь по настройке vpn на cisco

есть маршрутизатор cisco настроил все но почемуто впн на циске не подключается.

вот конфиг

что нитак сделал то?

 

Using 2023 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
!
no aaa new-model
no ip gratuitous-arps
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool lan
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1 
dns-server 10.2.2.2 
!
!
ip multicast-routing 
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
vpdn-group 1
request-dialin
protocol pptp
rotary-group 0
initiate-to ip 10.100.100.3
!
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet0
ip address 192.168.62.21 255.255.255.0
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1450
duplex auto
speed auto
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface Vlan1
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1450
!
interface Dialer0
mtu 1450
ip address negotiated
ip pim dense-mode
encapsulation ppp
ip tcp adjust-mss 1400
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe 40
ppp authentication chap callin
ppp chap hostname xxxxxxx
ppp chap password 0 xxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.62.1
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.100.100.3 255.255.255.255 FastEthernet0
!
!
no ip http server
no ip http secure-server
ip nat translation timeout 600
ip nat translation tcp-timeout 600
ip nat translation max-entries 5000
ip nat inside source list 1 interface FastEthernet0 overload
!
access-list 1 permit 10.1.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Share this post


Link to post
Share on other sites

какая информация нужна? есть cisco 1712 + провайдер который раздает инет через впн, нужно раздать инет на свит циски. что еще нужно спрашивайте

Share this post


Link to post
Share on other sites

я если чесно новичек в цисках. можно поподробнее

Share this post


Link to post
Share on other sites

Если новичек - попробуйте воспользоваться веб-интерфейсом.

Объяснить подробно - нелегко.

conf t

logging monitor

logging on

exit

Это настройка логирования в терминальную сессию.

terminal monitor

Это указывает, что именно в Вашу сессию надо логировать.

debug ppp ?

Это указывает, что нужно выводить отладочную информацию. И какую.

Share this post


Link to post
Share on other sites

веб интерфейса на моей циске, нет старенькая она, дебаг попробую.

Share this post


Link to post
Share on other sites

вообщем впн начал стартовать, проблема была тупо в обжимке провода пережал на перекрестную и впн поднялся, но сейчас он постоянно отваливается примерно раз в 1 минуту

Share this post


Link to post
Share on other sites

вообщем разобрался с впн он теперь работает стабильно, настроил нат, но он почему то не работает, непойму почему. Гляньте конфиг

Using 1521 out of 29688 bytes 
! 
version 12.4 
service timestamps debug datetime msec 
service timestamps log datetime msec 
no service password-encryption 
service internal 
! 
hostname Router 
! 
boot-start-marker 
boot-end-marker 
! 
! 
no aaa new-model 
ip cef 
! 
! 
! 
! 
ip name-server 10.2.2.2 
ip multicast-routing 
ip auth-proxy max-nodata-conns 3 
ip admission max-nodata-conns 3 
vpdn enable 
! 
vpdn-group 1 
request-dialin 
 protocol pptp 
 rotary-group 0 
initiate-to ip 10.100.100.3 
! 
! 
! 
! 
! 
! 
! 
! 
! 
! 
! 
! 
! 
! 
! 
!          
! 
! 
! 
! 
! 
! 
! 
interface BRI0 
no ip address 
encapsulation hdlc 
shutdown 
! 
interface FastEthernet0 
ip address 192.168.62.21 255.255.255.0 
duplex auto 
speed auto 
! 
interface FastEthernet1 
! 
interface FastEthernet2 
! 
interface FastEthernet3 
!          
interface FastEthernet4 
! 
interface Vlan1 
ip address 10.1.1.1 255.255.255.0 
ip nat inside 
ip virtual-reassembly 
! 
interface Dialer0 
ip address negotiated 
ip pim dense-mode 
ip nat outside 
ip virtual-reassembly 
encapsulation ppp 
dialer in-band 
dialer idle-timeout 0 
dialer string 123 
dialer vpdn 
dialer-group 1 
no peer neighbor-route 
no keepalive 
no cdp enable 
ppp pfc local request 
ppp pfc remote apply 
ppp encrypt mppe auto 
ppp chap hostname xxxxxx 
ppp chap password 0 xxxxx 
ppp ipcp route default 
! 
ip forward-protocol nd 
ip route 0.0.0.0 0.0.0.0 192.168.62.1 
! 
! 
no ip http server 
no ip http secure-server 
! 
dialer-list 1 protocol ip permit 
! 
! 
! 
control-plane 
! 
! 
! 
! 
mgcp behavior g729-variants static-pt 
!          
! 
! 
! 
! 
line con 0 
line aux 0 
line vty 0 4 
login 
! 
end 

Share this post


Link to post
Share on other sites

нет строчки для ната типа: ip nat inside source list LIST interface Dialer0 overload

ну и в acl LIST нужно описать сеть которую хочешь натить.

Share this post


Link to post
Share on other sites

добавил строки

 

ip nat inside source list 1 interface Dialer0 overload

access-list 1 permit 10.1.1.0 0.0.0.255

инета нет

Share this post


Link to post
Share on other sites

вообщем всем спасибо все заработало. конечный конфиг будет ниже. только почему то через циску скорость максимум 9-10мб\с когда напрямую кабель к компу цепляеш 25-30 мб\с. как решить такой казус?

Using 1662 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip name-server 10.2.2.2
ip multicast-routing 
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
vpdn-group 1
request-dialin
 protocol pptp
 rotary-group 0
initiate-to ip 10.100.100.3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
! 
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
interface FastEthernet0
ip address 192.168.62.21 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!         
interface FastEthernet4
!
interface Vlan1
ip address 10.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer0
ip address negotiated
ip pim dense-mode
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string 123
dialer vpdn
dialer-group 1
no peer neighbor-route
no keepalive
no cdp enable
ppp pfc local request
ppp pfc remote apply
ppp encrypt mppe auto
ppp chap hostname xxxxxxx
ppp chap password 0 xxxxxx
ppp ipcp route default
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 10.100.100.3 255.255.255.255 192.168.62.1
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.1.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!         
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this