Jump to content
Калькуляторы

[b]Мультикаст Huawei[/b] не идет мультикаст на 2326

Мультикаст Huawei

Добрый день!

прошу Вашей помощи в решении проблемы с мультикастом.

такое ощущение, что запросы проходят до маршрутизатора мультикаста, возвращается обратно до порта, а напорту не происходит переход на влан 801 (согласно мэппинга созданного на влане 4019), при этом в wire shark так же нет мультикастного траффика. по uplink'у мультикаст бегает.

Если поставить на порт в режиме аксесс только влан мультикаста то мультикаст работает, но группы при этом не регистрируются.

Так же, делал экспериментальную схему, подключал источник и потребителя мультикаста на 1 коммутатор, все равно не заработал маппинг.

пользовательский порт в режиме hybrid с нетегированными вланами в принципе не пропускает даже IGMP запросы.

Текущий конфиг:

!Software Version V100R005C01SPC100

vlan batch 20 409 800 to 824 845 to 846 1000 to 1001 4019

#

igmp-snooping enable

#

vlan 801

igmp-snooping enable

vlan 1000

description mngmnt_swth

vlan 4019

description IPTV_vlan

igmp-snooping enable

multicast-vlan enable

multicast-vlan user-vlan 801 to 824

#

interface Ethernet0/0/1

set flow-stat interval 30

port link-type access

port default vlan 801

mac-limit maximum 3

loopback-detect enable

loopback-detect action shutdown

stp disable

ntdp enable

ndp enable

unicast-suppression 5

broadcast-suppression 5

#

interface GigabitEthernet0/0/2

description line to UPLINK

port link-type trunk

port trunk allow-pass vlan 1000 4019

loopback-detect enable

stp disable

stp no-agreement-check

stp loop-protection

undo ntdp enable

ndp enable

multicast-suppression 25

broadcast-suppression 5

#

[4-211testHUAWEI]di l2-multicast forwarding-table vla 4019

VLAN ID : 4019, Forwarding Mode : IP

--------------------------------------------------------------------

(Source, Group) Interface Out-Vlan

--------------------------------------------------------------------

Router-port GigabitEthernet0/0/2 4019

(*, 238.1.1.1) Ethernet0/0/1 801

GigabitEthernet0/0/2 4019

(*, 239.255.255.250) Ethernet0/0/1 801

GigabitEthernet0/0/2 4019

--------------------------------------------------------------------

Total Group(s) : 2

[4-211testHUAWEI]di l2-multicast forwarding-table vla 4019

VLAN ID : 4019, Forwarding Mode : IP

--------------------------------------------------------------------

(Source, Group) Interface Out-Vlan

--------------------------------------------------------------------

Router-port GigabitEthernet0/0/2 4019

(*, 238.1.1.1) Ethernet0/0/1 801

GigabitEthernet0/0/2 4019

(*, 239.255.255.250) Ethernet0/0/1 801

GigabitEthernet0/0/2 4019

--------------------------------------------------------------------

Total Group(s) : 2

[4-211testHUAWEI]di igmp-snooping port-info

-----------------------------------------------------------------------

(Source, Group) Port Flag

-----------------------------------------------------------------------

VLAN 801, 2 Entry(s)

(*, 238.1.1.1) Eth0/0/1 -D-

1 port(s)

(*, 239.255.255.250) Eth0/0/1 -D-

1 port(s)

-----------------------------------------------------------------------

 

[4-211testHUAWEI]di igmp-snooping router-port vlan 4019

Port Name UpTime Expires Flags

---------------------------------------------------------------------

VLAN 4019, 1 router-port(s)

GE0/0/2 00:16:48 00:02:46 DYNAMIC

[4-211testHUAWEI]di igmp-snooping router-port vlan 801

 

[4-211testHUAWEI]di int Ethernet0/0/1

Input: 5 packets, 320 bytes

Unicast : 0,Multicast : 5

Unicast : 0,Multicast : 4

 

[4-211testHUAWEI]di int gi 0/0/2

Input: 11504 packets, 15296209 bytes

Unicast : 169,Multicast : 11202

Output: 180 packets, 18027 bytes

Unicast : 169,Multicast : 5

 

[4-211testHUAWEI-Ethernet0/0/1]di ver

Huawei Versatile Routing Platform Software

VRP ® software, Version 5.70 (S2300 V100R005C01SPC100)

Copyright © 2000-2011 HUAWEI TECH CO., LTD

Quidway S2326TP-EI Routing Switch uptime is 0 week, 5 days, 23 hours, 55 minutes

Software Version : VRP ® Software, Version 5.70 (S2300 V100R005C01SPC100)

Share this post


Link to post
Share on other sites

пользовательский порт в режиме hybrid с нетегированными вланами в принципе не пропускает даже IGMP запросы.

Вот в этом направлении нужно работать.

Share this post


Link to post
Share on other sites

пользовательский порт в режиме hybrid с нетегированными вланами в принципе не пропускает даже IGMP запросы.

Вот в этом направлении нужно работать.

 

по мануалам то видел, но говорю же... не пропускает даже IGMP запросы

Share this post


Link to post
Share on other sites

)))) оказалось все проще некуда, но до такого даже в хуавее не додумались)))))))

interface Ethernet0/0/9

port hybrid pvid vlan 801

port hybrid untagged vlan 801 4019

 

строчка указывает влан по умолчанию... без него не знает куда посылать пакеты.(при этом для мультикастового траффика без разницы через какой влан будет уходить запрос (главное чтобы на влане был включен снупинг), т.к.придет он все равно по 4019))) )

Edited by x_dimas

Share this post


Link to post
Share on other sites

Товарищщи, подскажите пожалуйста.

 

Не получается включить функцию multicast-vlan. Коммутатор Huawei Quidway S2326TP-SI, VRP ® software, Version 5.70 (S2300 V100R005C01)...

такой команды просто нет в меню, ни в глобальном, ни в настройках VLAN. Нагуглить ничего не удалось, хотя например у топикстартера данные команды в конфиге присутствуют.

Кто-нибудь еще сталкивался с подобной проблемой?

Share this post


Link to post
Share on other sites

В моделях с индексом SI функции multicast-vlan нет. Покупайте EI, там все будет.

Share this post


Link to post
Share on other sites

Bambuk, спасибо. Странно, что на сайте производителя нигде толком не указано про то, что у SI урезаны функции... Везде делается акцент только на двойное питание (220VAC/48VDC) :-(

Share this post


Link to post
Share on other sites

XaTTa6bl4

На support.huawei.com есть документация и брошюрки на S23, там можно найти документ, где указана разница.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this