Jump to content
Калькуляторы

Ericsson / Redback Smartedge. Отзывы, реальная производительность. Особенности, плюсы, минусы

В операторах нет @

Есть -cn:<context> , но для snmp v3.

 

То ли это?

В любом случае - выводит только local.

 

Redback:

snmp server
snmp view mrtg internet included
snmp view mrtg interfaces included
snmp view mrtg snmp included
snmp view mrtg ifMIB included
snmp view mrtg redBackNetworks included
snmp community *** all-contexts view mrtg

 

Такое ощущение, что миба какого то не хватает.

Хотя snmpwalk полностью всю коробку прогнал - нет данных других контекстов. Вообще нет.

 

Как мониторить multibind тоже неясно. Хотя вычитал, что это вроде как невозможно) Тоже отличная новость.

Вланы мониторить?

OID для pvc пока тоже не нашел.

Неужели никто Redback не рисует?) Или только физику, проц и сессии?

Поделитесь template для Cacti пожалуйста.

Edited by semop

Share this post


Link to post
Share on other sites

Надо поставить имя контекста через @ после community

 

/usr/bin/snmpset -v2c -c $community@$context $bras_ip $rbnSubsClearSubscriberName s $ip

Share this post


Link to post
Share on other sites

Что-то все равно не так.

 

Простой snmpwalk с командной строчки:

 

C:\>
C:\>snmpwalk -v:2c -c:****@TV -r:*.*.*.* -os:1.3.6.1.2.1.4.22.1.3 -op:1.3.6.1.2.1.4.22.1.4 | find /c "10.128."
324
C:\>

 

Все хорошо.

Забираю скриптом:

 

#!C:\Perl\bin\perl
$IPs = `snmpwalk -v:2c -c:****@TV -r:*.*.*.* -os:1.3.6.1.2.1.4.22.1.3 -op:1.3.6.1.2.1.4.22.1.4 | find /c "10.128."`;
print $IPs;

 

Получаю 0.

 

Поставлю фильтр на другие IP - вытащит контекст local зачем-то, при условии что @ стоит. Опять 25.

 

Копи-паст строчки из скрипта -> в командную строку и все показывает как надо.

Что за волшебство?( Символы все верные, контекст тоже, смущает то, что копи-пастом работает, а скриптом в контекст TV не заходит. Контекст Local опять же фильтрует правильно. В другие контексты - не заходит. Именно, когда тыкаюсь туда скриптом. В чем разница не понимаю.

Share this post


Link to post
Share on other sites

Копи-паст строчки из скрипта -> в командную строку и все показывает как надо.

Что за волшебство?( Символы все верные, контекст тоже, смущает то, что копи-пастом работает, а скриптом в контекст TV не заходит. Контекст Local опять же фильтрует правильно. В другие контексты - не заходит. Именно, когда тыкаюсь туда скриптом. В чем разница не понимаю.

Я конечто не великий спец по перлу, но может дело в том, что @ - спецсимвол, и в строке его надо экранировать?

То есть что-то типа

#!C:\Perl\bin\perl
$IPs = `snmpwalk -v:2c -c:****\@TV -r:*.*.*.* -os:1.3.6.1.2.1.4.22.1.3 -op:1.3.6.1.2.1.4.22.1.4 | find /c "10.128."`;
print $IPs;

Edited by azhur

Share this post


Link to post
Share on other sites

Нет, azhur, ты спец) Я даже что-то не подумал про это.

Думал он просто эту строчку бросает и все хорошо будет. Спасибо большое!

Теперь я вижу всё.

Share this post


Link to post
Share on other sites

Доброго времени суток, сообщество.

 

Вопросы по SE600

(Извините за кашу в голове и разные глупости - но так часто бывает, когда что-то новое изучаешь и сразу много инфы и совершенно другая философия/религия - а мозг уже старый :)

 

0. Взлетит ли на SE600 в качестве браса+бордер(BGP):

25-30K юзеров (не онлайн, а вообще) - с учетом L2 connected + vlan per customer + QinQ + белые IP (NAT не нужен) + RADIUS + DHCP + посервисный аккаунтинг + нетфлоу (не спрашивайте зачем :)

 

Как я вижу схему:

юзерcкий девайс при включении посылает DHCP запрос - тот долетает живьем до браса без всяких релеев ибо L2 Connected

далее работают на брасе RADIUS+DHCP Proxy? - биллинг должен определить юзера по QinQ в радиус запросе (аутентификация) и выдать адрес и прочие параметры (авторизация) и далее производить посервисный аккаунтинг)

Мне важно не юзать DHCP опц82 (потому что вендорозависимо и еще сюда никак не пристегнуть ipv6 (наши свичи доступа не умеют и не будут - смысла менять нету - работают хорошо)

 

1а. будет ли при этом всем что-то типа ip unnumbered (или как это называется в SE - чтобы экономно юзать белые адреса)?

1б. при этом разрулиться ли грамотно наличие не одного пула белых адресов, а несколько (не смежных)

 

2. Вопрос по поводу 10G портов

 

Можно ли вообще, чтобы аплинк был не физический фейс - а влан (опять же чтобы заюзать один физический фейс (или два объедененных))?

Есть вариант - подключать аплинк физически не к брасу, а к коммутатору ядра - т.к. на свиче порты гораздо дешевле (чисто на L1 уровне - BGP и роутинг остается на брасе)

далее разрулить вланами аплинк и даунлинк трафик браса

Выйгрыш должен быть когда трафика будет больше 10 гигабит/с (например 14 гиг/с входящего и 5 исх:

сравните - если юзать на брасе 2х10G аплинк и еще 2х10G даунлинк - 4 порта нужно.

Либо можно юзать всего 2х10G на брасе - объеденить и назад гнать в свич ядра, в которое уже втыкаем аплинк

(при расчетах не забываем про фул дуплекс).

Вроде получается экономия )

Так вот почитал я про SE - явно есть много ограничений по поводу агрегированных (bond) портов (например посервисный аккаунтинг не будет работать?),

NetFlow включается только на аплинках?

3.Какие еще разные ограничения и нюансы - на интерфейсах с ролями для сабскрайберов и для апинка

Или это вообще бредовая идея?

 

4. Можно ли разрулить (контексты?) - L2TP доступ (и сколько максимум тунелей умеет SE600 ?) и IPoE, чтобы переключить юзеров с тазиков на брас а уже затем постепенно переводить с тунелей на ipoe

 

5. По полиси/сервисам/редиректу даже спрашивать пока не готов (уже после того, как железка приедит)

 

Спасибо заранее за любые комменты.

 

P.S. Вообще как бы понятно, что прежде чем задавать вопросы - нужно дождаться железки, почитать доки и в лабе поэксперементировать.

А уж потом задавать тупые вопросы.

Но не терпится же ... : )

Share this post


Link to post
Share on other sites

1. Будет. Есть команда, которая добавляет в радиус пакет интерфейс и qinq влан. Аналогично с dhcp. Пул рулите как нравится на радиусе или dhcp-сервере.

2. С vlan никаких проблем нет, а вот с ling agg некоторые ограничения как слышал есть, но они не так актуальны на новом Софье как нежели пару лет назад.

4. Мы как разные сервисы разруливаем по контекстам. Например контекст для bgp с fullview, контекст стмаршрутами для ipoe, контекст для pppoe, контекст для mgmt. Для каждого свои настройки radius и профили абонентов. Про отдельные ограничения не слышал. Только 32к на плату и 128к на коробку.

5. Примеры radius пакетов и профилей есть в интернете.

Share this post


Link to post
Share on other sites

man781, не забывайте про переподписку 2:1 на картах 4x10GE

Share this post


Link to post
Share on other sites

блин, точно, переподписка же

(зачем тогда 4 порта вместо двух...)

Share this post


Link to post
Share on other sites

блин, точно, переподписка же

(зачем тогда 4 порта вместо двух...)

Чтобы было удобно соединять или резервирование lagg. У Вас ведь вряд ли будут все порты до верху утилизированы. Если такой подход не используете, то берите платы с 10GE. По цене идентично пропускной способности.

Share this post


Link to post
Share on other sites

Добрый день!

Есть SE100, схема обработки subscriber - non-dhcp clips

service clips auto-detect context ipoe service-policy IPOE-Users

При настройке залетел на ограничение LAG access ;-(

[local]BRAS(config)#link-group CORE access
[local]BRAS(config-link-group)#maximum-links 3
% maximum-links must be 2 for access type link-group with current PPA card
[local]BRAS(config-link-group)#

Убрал LAG для access, настроил просто 3 порта

port ethernet 2/1
no shutdown
medium-type copper
encapsulation dot1q
dot1q pvc 821
 bind interface IPOE-User1 ipoe
 service clips auto-detect context ipoe service-policy IPOE-Users
! остальные 2 другие VLAN и interface

На ядре настроил балансировку 0.0.0.0 маршрута через 3 IP (делал все в VRF)

На SE100 так же через 3 IP для клиентской сети на ядро

Залетел с тем что когда пакет с src клиента идет на разные порты, то SE100 генерирует разные clips id и соответственно RADIUS не дает SE100 поднять второй clips (читай вторую radius-сессию) т.к. IP занят от первой сессии.

Покурил технологии от Cisco, понял что меня спасет PBR для привязки трафика клиента к next-hop (на ядре). Пока не настроил. Направил трафик пока через ОДИН маршрут.

Решил за одним настроить OSPF для удобства анонса сетей и типа отказоустойчивости от условной потери порта.

Опять залетел :(

Маршруты ДО поднятия subscriber

Type    Network              Next Hop        Dist    Metric    UpTime  Interface
> S     0.0.0.0/0                               1         0  21:01:46
> O E2  CC.DDD.249.0/24      AAA.BBB.228.65   110        20  00:00:04  IPOE-User3
> C     AAA.BBB.228.64/30                       0         0  20:21:32  IPOE-User3

Маршруты ПОСЛЕ поднятия subscriber

> S     0.0.0.0/0                               1         0  21:03:00
> C     CC.DDD.249.0/24                        18         0  00:00:05  Loopback8
> SUB A CC.DDD.249.11/32     CC.DDD.249.11     15         0  00:00:05  Loopback8
> C     AAA.BBB.228.64/30                       0         0  20:22:46  IPOE-User3

И усе, трафик не идет ;-(

Добавляем маршрут РУКАМИ

[ipoe]BRAS(config)#context ipoe
[ipoe]BRAS(config-ctx)#ip route CC.DDD.249.0/24 AAA.BBB.228.65
[ipoe]BRAS(config-ctx)#end

Cмотрим маршруты:

> S     0.0.0.0/0                               1         0  21:00:35
> S     CC.DDD.249.0/24      AAA.BBB.228.65     1         0  11:14:49  IPOE-User3
> C     AAA.BBB.228.64/30                       0         0  20:20:21  IPOE-User3

Вауля! Трафик побежал.

Проблема в том что metric маршрута из OSPF 20, и маршрут на miltibind интерфейс ПЕРЕКРЫВАЕТ маршрут из OSPF.

 

Помогите люди добрые, кто знает есть варианты это побороть (перенастроить)???

Share this post


Link to post
Share on other sites

Здравствуйте.

 

Не очень понятно почему пропадает:

> O E2  CC.DDD.249.0/24      AAA.BBB.228.65   110        20  00:00:04  IPOE-User3

И становится вдруг директли:

> C     CC.DDD.249.0/24                        18         0  00:00:05  Loopback8

Share this post


Link to post
Share on other sites

Не очень понятно почему пропадает:

Дак понятно почему пропадает!

У "connected" маршрутов metric = 0 , у static еще и Dist меньше чем у "connected" = 1

А у OSPF metric всего 20 и она перекрывается "connected" маршрутом

А ну и да не понятно зачем вообще поднимается этот маршрут после активирования первого subscriber-а в сети:

  C     91.221.249.0/24                        18         0            Loopback8

Не понятно как это побороть ???

Как у маршрутов через interface Loopback8 multibind увеличить metric и dist???

А как известно без multibind интерфейсов subscriber-ы не поднимутся :(

Edited by Nik0n

Share this post


Link to post
Share on other sites

Как у маршрутов через interface Loopback8 multibind увеличить metric и dist???

РЕШЕНО! Я не туда копал ;-) Надо сменить distance у OSPF маршрутов. Static убрать.

 router ospf 101
 distance   external 14

И сразу становиться вот так:

Type    Network              Next Hop        Dist    Metric    UpTime  Interface
> S     0.0.0.0/0                               1         0     1d06h
> O E2  CC.DDD.249.0/24      AAA.BBB.228.65    14        20  00:05:28  IPOE-User3
> SUB A CC.DDD.249.11/32     CC.DDD.249.11     15         0  07:36:11  Loopback8

Работает. Спасибо всем :)

Share this post


Link to post
Share on other sites

Нет, это то я понял, что метрики у них разные.

Не понял просто почему сначала маршрут был "O E2" (пришел из другой автономки не принадлежащей роутеру), а потом вдруг стал "C" (жить на этом роутере).

Получается CC.DDD.249.0/24 - живет где то в другом месте. Но потом вдруг начинает жить на этом роутере. Естественно, что OE2 грохается.

Схема то какая?

 

Помню multibind вообще не анонсировался), поэтому сделано так:

Конф для локального ипое.

 

!
router ospf 10
 area 0.0.0.0
  interface BRAS-Billing
  interface ISM_VLAN
 redistribute connected route-map GUEST/LOCAL/IPTV 
!
ip prefix-list GUEST/LOCAL/IPTV
 seq 1 permit 172.16.0.0/16
 seq 2 permit 10.44.64.0/19
!
route-map GUEST/LOCAL/IPTV permit 1
 match ip address prefix-list GUEST/LOCAL/IPTV
!

 

/32 в оспф таблицу не совал. Можно в рут-мап конечно же все /32 запихать через le/ge. Но я не стал.

На цыске за redback'ом вижу его сетки:

Cisco_2811#sh ip ro ospf | i E2
O E2 172.16.0.0/16 [110/0] via 172.17.0.9, 4w0d, FastEthernet0/0.3892
O E2    10.44.64.0/19 [110/0] via 172.17.0.9, 4w0d, FastEthernet0/0.3892

Share this post


Link to post
Share on other sites

Упр-е и доступ для administrator настроен, но теперь я ни добавить, ни удалить старых - не могу.

В конфиге теперь отсутствует сама команда administrator.

Очень хочется прошиться, чтоб умел non-dhcp и победить эти вот косячки. Надеюсь это из-за софта.

 

Прошился. Это не софт.

Не знаю куда и копать. Подскажите пожалуйста?:

 

!
administrator semop encrypted 1 ********************
  privilege start 10
  privilege max 15
  timeout session idle 20
!

 

Хочу еще одного добавить.

 

[local]Redback(config-ctx)#
[local]Redback(config-ctx)#admi?
 admin-access-group
[local]Redback(config-ctx)#admi

 

Где administrator то?

Есть у SE особенность применять команды, которые табуляцией не бьются и вопросом не видно. Но даже так не получается.

Ни удалить, ни добавить.

 

[local]Redback#sh ver

 

Redback Networks SmartEdge OS Version SEOS-12.1.1.8-Release

Built by sysbuild@eussjlx7008.sj.us.am.ericsson.se Mon Sep 22 00:22:58 PDT 2014

Copyright © 1998-2014, Redback Networks Inc. All rights reserved.

System Bootstrap version is Mips,rev2.0.2.69

Installed minikernel version is 11.7

Router Up Time - 1 day, 5 hours 55 minutes 39 secs

[local]Redback#

Share this post


Link to post
Share on other sites

Да.

Принципиально?

 

Во всех контекстах он забыл эту команду. Даже не в local ее нет.

Share this post


Link to post
Share on other sites

Да, оказывается прав не было.

Спасибо)

Share this post


Link to post
Share on other sites

Здравствуйте.

 

Пытаюсь получить full view по BGP.

 

 router bgp 199096
 multi-paths external 2
 fast-reset 10000 milliseconds
 address-family ipv4 unicast
  flap-statistics
  network х.х.х.х/22
 address-family ipv4 multicast
!
 peer-group MEGAFON external
   address-family ipv4 unicast
     route-map MEGAFON_in in
     route-map MEGAFON_out out
   address-family ipv6 unicast

 neighbor y.y.y.y external
   remote-as 31133
   peer-group MEGAFON
   update-source P2P_BRAS-MEGAFON
!

 

Конфиг для одного из операторов.

В рут-мапе MEGAFON_out = мои префиксы

В рут-мапе MEGAFON_in = сначала был только дефолт. И я его получаю.

Но когда убираю из конфига этот рут-мап на input (MEGAFON_in) - ничего от пира не прилетает. Точнее остается только дефолт.

Пишу в рут-мапе префикс-лист, где разрешаю все - тоже самое. Не вижу full view.

Пиров дергал - без результата.

 

Операторы зафильтровали? Или что-то не хватает?

Раньше BGP был на huawei, где я пробовал получить всю табличку. И я ее получал, но умирал по оперативке. Поэтому был только дефолт. А теперь хочу FW получить на SE600, чтоб потом его размазать по остальным операторам.

Но ни с одного из нейборов я не вижу фул вью. Что то не так, но не понимаю что. Не могли же они все сразу зафильтрить.

 

Как видно - получил только 1 префикс от соседа.

Neighbor              AS  MsgRcvd  MsgSent    TblVer  InQ OutQ Rst  Up/Down  PfxRcvd/Sent  RstNeeded
y.y.y.y      31133       41       43     86484    0    0   1 00:37:08      1      7        No

Share this post


Link to post
Share on other sites

почему не могли, могли. позвоните, спросите у них, где префиксы :)

Share this post


Link to post
Share on other sites

Позвонил, спросил.

 

Действительно, все 3 оператора хором зафильтровали.

Ничо се, совпадение)

Share this post


Link to post
Share on other sites

Ребят, как сделать на SE600 sessions per-mac limit 1?

Ну тоесть на 1 mac - одно pppoe.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now