Jump to content
Калькуляторы

Ericsson / Redback Smartedge. Отзывы, реальная производительность. Особенности, плюсы, минусы

Карта крэшнулась. Может быть всё что угодно. Юзаете vlan on-demand?

Share this post


Link to post
Share on other sites

Да. в PPPoE на субскрайбер интерфейсе.

А как оно влияет ?

Саппорт говорит проблема в софте. Будем обновляться.

Share this post


Link to post
Share on other sites

Ivan Rostovikov, была аналогичная проблема, единственный софт на котором не было проблем - 12.1.1.2.

12.1.1.5 не пробовали, тупо вланы статически раскидали и проблемы исчезли сами собой. Но если on-demand вланы нормально у вас заработают (больше недели без крешей) - вы скажите :)

Share this post


Link to post
Share on other sites

Есть влан-ы в которых водятся разные пользователь (Static & DHCP). Хочу перебросить их на SE, без выделенных DHCP-Relay, тоесть SE должен пересылать DHCP запросы к серверу.

Никак не получается настроить L2 NON-DHCP-CLIPS. Клиенты со статикой работают, но динамические не получают адреса. Точнее SE не пересылает DHCP запросы.

[CLIENTS]SE-BRAS#show dhcp relay stats

************

Dropped packets-----------------------------------------------------

Bad Ack : 0 Internal Error : 0

Bad Length : 0 Bad Circuit : 0

Bad Circuit UP : 0 Bad Circuit Kern : 0

Bad Circuit EOF : 0 Bad Circuit slot : 0

Bad Context : 0 Bad Server IP : 0

No Server : 0 No Interface : 0

Unbound Circuit : 199 Disabled Interface : 0

Min Wait Error : 0 Max Hops Error : 0

Bad IP : 0 Unknown Packet Type : 0

Dropped Discover : 0 Dropped Request : 0

Dropped Offer : 0 Dropped Ack : 0

Dropped Release : 0

del_pending_dropped : 0 EP Down : 0

Error in Options : 0 max-addr dropped : 0

non-clips mac : 0 Invalid mac-addr : 0

MAC entry not found : 2 Dup cct-cfg entry : 0

Mismatch ip/mac : 0 No renewal marked : 0

Dropped invalid server: 0 Bcast/Mcast mac : 0

Context not found : 0 Interface not found : 0

Circuit not found : 0 Request entry not found: 0

Drop dup disc/del req : 0 Drop dup discover : 0

Throttle dropped disc : 0

 

************

настроенно так:

service-policy name CLIPS

allow clips ip range 192.168.4.128 192.168.4.255

 

port ethernet 2/1

mtu 1526

no shutdown

encapsulation dot1q

dot1q pvc 2002

service clips auto-detect context CLIENTS service-policy CLIPS

 

 

context CLIENTS

 

interface IF_192.168..4.128 multibind

description TEST_2002-2124

ip address 192.168.4.129/25

dhcp proxy 65535 server-group CLIPS

ip source-address dhcp-server

ip arp proxy-arp always

ip pool 192.168.4.128/25

 

 

 

 

 

 

dhcp relay server 10.10.1.1

max-hops 10

server-group CLIPS

!

dhcp relay server 10.10.1.2

max-hops 10

server-group CLIPS

 

 

 

есть у кого идеи?

Share this post


Link to post
Share on other sites

Статические и динамические клипсы на одном VLAN?

Share this post


Link to post
Share on other sites

не очень...

NON-DHCP-CLIPS (авторизация по IP пакету), и просто чтоб релай в таком случае работал.

Статические и динамические клипсы на одном VLAN?

 

Share this post


Link to post
Share on other sites

Добрый день, коллеги!

 

Достаточно давно запустили в продакшн SE100, но работал он с минимальной нагрузкой, порядка 600 PPPoE сессий и 0,5G трафика.

В предверии перехода на новый биллинг начали переносить нагрузку c Cisco7201 на SE100, вроде бы все не плохо, на нем завелось около 2900 сессий и около 1,5G Full duplex трафика.

Но через некоторое время работы под нагрузкой CPU взлетает с 10% под 100% и так и держится в полке. Скриншот с загрузкой прилагаю.

c482e1d07eb5.png

 

Грузит систему процесс aaad. После его рестарта, загрузка падает до 10% и держится на этом уровне какое-то время, после чего опять взлетает. За последние 20 часов было 2 таких взлета, и если первый был во время роста нагрузки (вечер), то второй был на явном спаде нагрузки (ночь).

 

Авторизация PPPoE, абоненты доходят до браса по QinQ поверх LACP. SEOS-11.1.2.7-Release.

 

Господа, куда копать, может надо обновить SEOS, или столько сессий слишком много для него? Какие варианты?

 

Спасибо.

Edited by MAXmks

Share this post


Link to post
Share on other sites

MAXmks, выложите полный конфиг.

Кстати, зачем лаг в сторону пппое клиентов?

Share this post


Link to post
Share on other sites
aaa global authentication subscriber radius context local
!
!
no service multiple-contexts
!
software license
 subscriber active 8000 encrypted 1 *****
 subscriber bandwidth 60 encrypted 1 *****
!
context local
domain pppoe advertise
! 
no ip domain-lookup
!
interface 2/2
 description *** ospf ***
 ip address 92.****/26
 ip access-group as_inbound_acl in
 ip access-group as_outbound_acl out
!
interface loopback0 loopback
 ip address 9****/32
!
interface mgm
 ip address 1****/27
  ip source-address snmp ssh radius syslog tftp ftp netop flow-ip 
!
interface pppoe multibind lastresort
 ip unnumbered loopback0
 ip pool *****
logging console
logging  file /md/log
logging malicious-traffic file /md/mal-log
logging  syslog 172.**** facility local7
!
router ospf 73
 router-id 9*.****
 log-neighbor-up-down
 area 0.0.0.0
  interface 2/2
   authentication md5 ospf-key-chain
  interface loopback0
   passive
!
ip access-list as_inbound_acl
!
ip access-list vty-access ssh-and-telnet-acl
 seq 10 permit ip host ****
!
ip prefix-list internal
 seq 10 permit ****
!
route-map internal permit 10
 match ip address prefix-list internal
!
key-chain ospf-key-chain key-id 1
 key-string encrypted *****
!
router bgp 4****
 router-id 9****
 address-family ipv4 unicast
  network ****
!
 neighbor 9***** internal
   update-source loopback0
  address-family ipv4 unicast
     route-map internal out
!
enable encrypted 1 *****
!
aaa authentication administrator local  
aaa authentication subscriber radius  
aaa accounting subscriber radius
aaa update subscriber 10
aaa authorization tunnel radius
aaa maximum subscriber active 6000
radius accounting server 172.17.75.9 encrypted-key *****
radius coa server 172.17.75.9 encrypted-key ****** port 3799
!
administrator rx encrypted 1 ****
  privilege max 15
!
radius server 172.17.75.9 encrypted-key *****
radius attribute nas-ip-address interface mgm
radius attribute acct-session-id access-request 
radius attribute nas-port format session-info
radius attribute acct-delay-time 
radius attribute vendor-specific Redback mac-address separator .
radius attribute calling-station-id media ETH format agent-circuit-id agent-remote-id non-ascii
radius attribute nas-identifier 172.17.75.14
!
subscriber default
  ip address pool
  qos policy policing 40960K-in
  qos policy metering 40960K-out
  ppp mtu 1492
  dns primary 9*****
  dns secondary 8.8.8.8
!
ip route **** null0
service ssh server access-group vty-access
no service telnet 

!
ntp-mode
!
 peer 172.17.75.2 version 3 
 peer 172.17.75.8 version 3 prefer 

!
!
flow collector netflow
 ip-address 172.17.75.9 context local
 port 9996
 export-version v5
!
!
!
! ** End Context **
logging tdm console
logging active
logging standby short
!
!load balancing hash key config
!
service load-balance ip layer-4
!
!
!
!
!
!
!
link-group users access
encapsulation dot1q
mac-address 00:30:88:1c:f4:a1
dot1q pvc 1100 encapsulation 1qtunnel 
 dot1q pvc on-demand 1100:96 through 110 encapsulation pppoe 
  bind authentication chap context local maximum 2000
 dot1q pvc on-demand 1100:2000 through 2063 encapsulation pppoe 
  bind authentication chap context local maximum 2000
dot1q pvc 1101 encapsulation 1qtunnel 
 dot1q pvc on-demand 1101:96 through 110 encapsulation pppoe 
  bind authentication chap context local maximum 2000
dot1q pvc 1102 encapsulation 1qtunnel 
 dot1q pvc on-demand 1102:96 through 110 encapsulation pppoe 
  bind authentication chap context local maximum 2000
maximum-links 2
lacp active
!
link-group ospf-lacp ether
bind interface 2/2 local
maximum-links 3
lacp active
!
!
!
!
snmp server
cache-counter-query
context-filter ifmib
snmp view Inet-View internet included
snmp view Inet-View interfaces included
snmp view Inet-View ifMIB included
snmp community 
!
system clock timezone ORB 6 0 local
!
!
!
port ethernet 1/1 
! XCRP management port on slot 1
no shutdown
bind interface mgm local
!
card carrier 2
mic 1 ge-2-port
mic 2 ge-2-port
!
port ethernet 2/1 
no shutdown
encapsulation dot1q
dot1q pvc explicit 95 through 150 encapsulation pppoe 
 bind authentication chap context local maximum 2000
!
port ethernet 2/2 
no shutdown
encapsulation dot1q
link-group users
!
port ethernet 2/3 
no shutdown
encapsulation dot1q
link-group users
!
port ethernet 2/4 
no shutdown
link-group ospf-lacp
!
port ethernet 2/15 
no shutdown
link-group ospf-lacp
!
port ethernet 2/16 
no shutdown
link-group ospf-lacp
! 
system hostname Bras5
! 
boot configuration /flash/redback.cfg
!
no service console-break
!
service crash-dump-dram
!
no service auto-system-recovery
!
!
!
pppoe services all-domains
pppoe always-send-padt
!
end

Edited by MAXmks

Share this post


Link to post
Share on other sites

LACP в сторону клиентов, ради одного мака для браса, на сети прописаны L2 ACL который pppoe на конкретные маки разрешает, ну и что бы самому с балансингом не заморачиваться.

Share this post


Link to post
Share on other sites

MAXmks, это же pppoe, он сам разбалансируется. А вообще попробуйте

pppoe circuit padr per-mac count 20 allow-time 120 drop-time 60

pppoe circuit padi per-mac count 20 allow-time 120 drop-time 60

с цифрами можно поиграться.

И в момент загрузки посмотрите sh radius control, большая ли там очередь на подключение.

Share this post


Link to post
Share on other sites

MAXmks, это же pppoe, он сам разбалансируется. А вообще попробуйте

pppoe circuit padr per-mac count 20 allow-time 120 drop-time 60

pppoe circuit padi per-mac count 20 allow-time 120 drop-time 60

с цифрами можно поиграться.

И в момент загрузки посмотрите sh radius control, большая ли там очередь на подключение.

Спасибо, сегодня ночью перепрошью se100, на 12 ветку, так посоветовал наговский саппорт.

Share this post


Link to post
Share on other sites

Тут уже столько копий сломали на связке PPPoE+LAG, что большинство тупо подняли РРРоЕ на каждом интерфейсе и спят спокойно.

Share this post


Link to post
Share on other sites

Товарищи. никак не могу найти команду, чтобы посмотреть МАС-адреса на порту или в VLANе. типа цисковской show mac-address-table

Подскажите пожалуйста.

Share this post


Link to post
Share on other sites

Подскажите пожалуйста.

 

Никак, если вы явно не настроите мост включающий порты или pvc.

Share this post


Link to post
Share on other sites

реквестирую ответ ещё на пару вопросов:

 

Как сделать Static CLIPS на LaG ?

В сторону ядра собран ЛаГ 2*1Г. Сейчас он dot1q.

Но к dot1q ЛаГу нельзя прибиндить сабскрайберов.

В соседней ветке обсуждаю тему. Как шейпить и контролировать абонентов, которые подключены по StaticIP.

Т.е. я правильно понимаю, либо qos policy на интерфейс в сторону ядра, либо StaticCLIPS на тот же интерфейс. А что делать если собран ЛаГ?

Или StaticCLIPS работает только когда абонентский L2 доходит до самого Redback-а? Или L3 StaticCLIPS тоже возможен?

Edited by ArhAngel_John

Share this post


Link to post
Share on other sites

Подскажите. Получится ли завести NON-DHCP-CLIPS via L3 без авторизации по радиусу на софте 11-ой версии. Если есть у кого-нибудь рабочие конфиги, поделитесь, пожалуйста.

Share this post


Link to post
Share on other sites

Подскажите. Получится ли завести NON-DHCP-CLIPS via L3 без авторизации по радиусу на софте 11-ой версии. Если есть у кого-нибудь рабочие конфиги, поделитесь, пожалуйста.

 

NON-DHCP CLIPS не работает в 11 версии.

Возможно вам подойдет static subscriber без авторизации.

А вообще задача не понятна.

Share this post


Link to post
Share on other sites

Подскажите. Получится ли завести NON-DHCP-CLIPS via L3 без авторизации по радиусу на софте 11-ой версии. Если есть у кого-нибудь рабочие конфиги, поделитесь, пожалуйста.

 

NON-DHCP CLIPS не работает в 11 версии.

Возможно вам подойдет static subscriber без авторизации.

А вообще задача не понятна.

У меня есть куча абонентов (даже не куча, а очень-очень много) у которых на сетевой карте/роутере настроен Статический IP.

Мне нужно грамотно зашейпить и проконтролировать этих абонентов, пока я их перевожу на IPoE.

 

Я так думал, что StaticCLIPS и "static subscriber без авторизации" это одно и тоже

Edited by ArhAngel_John

Share this post


Link to post
Share on other sites

А что мешает использовать сразу non-dchp в 12 версии? Она рекомендуема для новых инсталляций.

Или у вас уже сейчас эриксон в работе и вы на нем же решить обе терминации?

Share this post


Link to post
Share on other sites

А что мешает использовать сразу non-dchp в 12 версии? Она рекомендуема для новых инсталляций.

Или у вас уже сейчас эриксон в работе и вы на нем же решить обе терминации?

Да.железка боевая

Share this post


Link to post
Share on other sites

Подскажите. Получится ли завести NON-DHCP-CLIPS via L3 без авторизации по радиусу на софте 11-ой версии. Если есть у кого-нибудь рабочие конфиги, поделитесь, пожалуйста.

 

NON-DHCP CLIPS не работает в 11 версии.

Возможно вам подойдет static subscriber без авторизации.

А вообще задача не понятна.

У меня есть куча абонентов (даже не куча, а очень-очень много) у которых на сетевой карте/роутере настроен Статический IP.

Мне нужно грамотно зашейпить и проконтролировать этих абонентов, пока я их перевожу на IPoE.

 

Я так думал, что StaticCLIPS и "static subscriber без авторизации" это одно и тоже

 

 

На одинадцатой ветке делал следующим образом: В базе данных клиентов добавлял столбец последовательной нумерации. Статик клипс настраивал на атоматическую генерацию Юзернейма (например: USER1, USER2,...) FreeRadius по Юзернейму вытаскивал из базы IP, шейпы и остальные услуги.

И все это на LAG.

 

Правда получалось очень много сабскрайберов. Причем на нескольких железяках одинаковые. Однозначно Вам надо переходить на 12-ю ветку.

Share this post


Link to post
Share on other sites

Тоже крашится желещка

где то 9К подписчиков dhcp-clips

на 11 ветке было где то раз в месяц

тех под сказал перейти на 12 ветку

 

Redback Networks SmartEdge OS Version SEOS-12.1.1.6p2-Release

Built by sysbuild@eussjlx7008.sj.us.am.ericsson.se Thu Apr 3 00:42:27 PDT 2014

Copyright © 1998-2014, Redback Networks Inc. All rights reserved.

System Bootstrap version is Mips,rev2.0.2.67-esa

Installed minikernel version is 11.7

 

завалилась через 1,5 дня, думал у меня особенная железка, а тут смотрю у многих крашится

 

May 15 16:15:30: %CSM-6-CARD: PPA crash detected on 10ge-4-port card in slot 1

May 15 16:15:30: %CSM-6-PORT: ethernet 1/1 link state DOWN service state DOWN, overall admin is UP

May 15 16:15:30: %CSM-6-PORT: ethernet 1/1 link state down, trigger source: Hardware removed

May 15 16:15:30: %CSM-6-PORT: ethernet 1/2 link state DOWN service state DOWN, overall admin is UP

May 15 16:15:30: %CSM-6-PORT: ethernet 1/2 link state down, trigger source: Hardware removed

May 15 16:15:30: %PM-1-ALERT: Process IPPA IPC SLOT 1, pid 0x80010000, is not responding.

May 15 16:15:40: %PPAINFRA-3-LOG_ERR: crashSrvr(): Slot/pfe/ppa 1/0/1869769587 Crash server data collection started

May 15 16:15:40: %PM-1-ALERT: Process EPPA IPC SLOT 1, pid 0x81010000, is not responding.

Edited by AntonS

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now