Jump to content
Калькуляторы

Помогите настроить QOS на cisco 3750

Добрый день, пожалуйста помогите (начинаючему) настроить QOS на cisco 3750(1) и cisco 3750(2) на интерфейсах к которым подключены R1 и R2 соответственно, что бы трафик между ними был приоритетным по отношению ко всем остальным. cisco 3750(1) и (2) работают гейтами, каждая в своем офисе.Схему прилагаю.

post-82974-079723600 1301158627_thumb.jpg

Share this post


Link to post
Share on other sites

На выходном интерфейсе R1 окрашивайте весь исходящий трафик, на выходном интерфейсе 3750(1) ставьте service-policy на out, в котором для класса, в который попадает окрашенный трафик делайте bandwith percent 70, тогда в случае перегрузок, трафику от R1 достанется 70% полосы(ну или укажите в килобитах, если скорость по тарифу меньше чем физическая)

 

Тоже самое делайте с другой стороны

Share this post


Link to post
Share on other sites

Прошу прощения за делитанский вопрос, тудет ли работать так ?

 

включить сосы

!

mls qos

!

 

на интерфейсе 3750(1) подключенному к R1 маркировать весь трафик:

!

interface GigabitEthernet1/0/1 /Интерфейс к которому подкючен R1

switchport access vlan 100

switchport mode access

mls qos cos 5

mls qos trust dscp

!

на исходящем интерфейсе 3750(1)(в сторону провайдера):

 

!

interface GigabitEthernet1/0/2 /Интерфейс к которому подкючен провайдер

switchport access vlan 100

switchport mode access

mls qos trust dscp

!

аналогично на другой стороне.

 

Пытался зделать как предложили Вы, что-то пока не получается конфиг, если не сложно дайте ссылку или пример как должен выглядеть конфиг.

Share this post


Link to post
Share on other sites

Не совсем. Сейчас включено только "красить некрашеный трафик в 5" и "доверять раскраске, если трафик уже пришел крашеный". На том интерфейсе, на котором возможны заторы, на нем нужно настроить политику отбрасывания пакетов. Например, написав политику отбрасывания/шейпинга. Или включив очередь.

 

Но есть ли уверенность, что потери пакетов происходят именно на интерфейсах 3750 а не на сети провайдера?

 

http://www.cisco.com/en/US/products/hw/switches/ps646/products_tech_note09186a00800feff5.shtml

Share this post


Link to post
Share on other sites

Я немного недосмотрел описание вашей проблемы и сделать как я написал нельзя на 3750. Вам нужно использовать вот это http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_25_se/configuration/guide/swqos.html#wp1168422 на интерфейсе, который смотрит на провайдера

Т.е. фактически добиться того, чтобы покрашенные пакетики пошли в нужную очередь, для которые надо накрутить весовой коэффициент. Только я не знаю можно ли применять команды srr-queue bandwidth share и srr-queue bandwidth limit одновременно(это требуется, если скорость по тарифу меньше чем физическая)

Share this post


Link to post
Share on other sites

"Но есть ли уверенность, что потери пакетов происходят именно на интерфейсах 3750 а не на сети провайдера?" - уверенности нет,но хочется зделать все возможное со своей стороны.

 

а если так создать очередь ?

 

class-map match-all test

match input-interface GigabitEthernet1/0/1

!

policy-map test-bw

class test

 

 

на интерфейсе 3750(1) подключенному к R1 маркировать весь трафик:

!

interface GigabitEthernet1/0/1 /Интерфейс к которому подкючен R1

switchport access vlan 100

switchport mode access

mls qos cos 5

mls qos trust dscp

!

на исходящем интерфейсе 3750(1)(в сторону провайдера):

 

!

interface GigabitEthernet1/0/2 /Интерфейс к которому подкючен провайдер

switchport access vlan 100

switchport mode access

mls qos trust dscp

service-policy output test-bw

!

 

только не понимаю, как прописать на int GigabitEthernet1/0/2, что бы он в первую очередь пропускал пакеты маркированные "5", вне зависимости от загрузки канала.

Share this post


Link to post
Share on other sites

И ? Чего ДЕЛАТЬ-то свичке, подчиняясь политике test-bw ? Части действия нет. Звучит как : "Для всего трафика, что пришел через интерфейс 1/0/1." Так вот "для всего трафика" сделать ЧТО?

 

Вы вообще ссылку мою читали?

Share this post


Link to post
Share on other sites

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.1_12c_ea1/configuration/guide/swqos.html?referring_site=bodynav

 

Вот тут в самом начале есть ТРИ диаграммы, которые показывают все метаморфозы пакета при прохождении "системы QoS" в свичке. Первая - как доверяют внешней раскраске, перекрашивают или красят сами. Вторая - как ограничивают скорости. Третья - как управляют приоритетом.

Share this post


Link to post
Share on other sites

чтобы темы не плодить

 

есть 2 циски, между ними линк gi1/0/1 в gi1/0/1 c vlan от 2 до 100. необходимо чтобы у 100 влана всегда приоритет был выше чем у других.

дальше влан 100 уходит на access порт на цисках

 

поделитесь конфигом

 

спсб

Share this post


Link to post
Share on other sites

VLAN ACL есть на этих ваших теоретических цисках?

 

Если есть - то

 

class-map VLAN100

match vlan 100

 

policy-map QoS

class VLAN100

вот тут делаете с этин трафиком то, что вы подразумеваете под "приоритет был выше чем у других"

 

 

int <тот, с которого поступает этот трафик>

service-policy input QoS

 

int <тот, через который уходит этот трафик>

нужно включить какой-то вид очереди, зависит от циски

 

Если это свитч, то еще

mls qos

Share this post


Link to post
Share on other sites

VLAN ACL есть на этих ваших теоретических цисках?

mls qos vlan-based на порту

+

policy-map policyX

class class-default (чтоб охватить весь поток влана)

...операции

+

interface vlanXX

service-policy input policyX

service-policy output policyY

- в большинстве случаях работает.

Share this post


Link to post
Share on other sites

sol

darkagent

а по подробнее/?

общими фразами я тоже могу покидаться :)

 

надо чтобы когда забивался линк наивысший приоритет был у трафика vlan100 или чтобы для vlan100 резервировалось 200 мегабит

 

буду очень благодарен за примерную конфигурацию

Edited by mukca

Share this post


Link to post
Share on other sites

если хочется резервировать определенную полосу - то тут имеет смысл поиграться с rsvp и cbwfq. http://docwiki.cisco.com/wiki/Resource_Reservation_Protocol

если хочется просто определить приоритет трафику - то можно его маркировать с соответствием типу трафика. http://www.cisco.com/en/US/technologies/tk543/tk759/technologies_white_paper0900aecd80295aa1.pdf

Share this post


Link to post
Share on other sites

А что-бы были конкретные фразы, надо ТЗ подробнее ставить. Или хотя-бы модель циски сообщить.

 

Потом, чем мой пост или уважаемого даркагента неконкретен? там прямо куски конфига. Знай себе копипасть.

Share this post


Link to post
Share on other sites
А что-бы были конкретные фразы, надо ТЗ подробнее ставить. Или хотя-бы модель циски сообщить.

 

Потом, чем мой пост или уважаемого даркагента неконкретен? там прямо куски конфига. Знай себе копипасть.

извиняюсь, посчитал что если тема о 3750 то очевидно что и вопрос о 3750 будет :D

есть 3750 на одном конце и 3560 на другом. между ними линк 1 гигабит. там бегает 100 вланов. необходимо чтобы когда забивался линк, у 100 влана или был резерв мегабит на 200 или приоритет его трафика был самым высоким и все дропалось кроме него.

Share this post


Link to post
Share on other sites

сделал

!

policy-map policyX

class class-default

set dscp cs6

!

 

!

interface GigabitEthernet1/0/5

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 95,96

switchport mode trunk

mls qos vlan-based

!

 

 

!

interface Vlan95

no ip address

service-policy input policyX

!

 

!

interface Vlan96

ip address 10.20.243.254 255.255.255.252

!

показывает

show mls qos interface GigabitEthernet 1/0/5 statistics

GigabitEthernet1/0/5 (All statistics are in packets)

 

dscp: incoming

-------------------------------

 

0 - 4 : 1667809 0 85 0 168

5 - 9 : 0 0 0 221334 0

10 - 14 : 0 0 0 0 0

15 - 19 : 0 6795 0 0 0

20 - 24 : 0 0 0 0 0

25 - 29 : 0 0 0 0 0

30 - 34 : 0 0 100 0 0

35 - 39 : 0 0 0 0 0

40 - 44 : 0 0 0 0 0

45 - 49 : 0 0 0 163 0

50 - 54 : 0 0 0 0 0

55 - 59 : 0 0 0 0 0

60 - 64 : 0 0 0 0

dscp: outgoing

-------------------------------

 

0 - 4 : 1317678 0 0 0 0

5 - 9 : 0 0 0 0 0

10 - 14 : 0 0 0 0 0

15 - 19 : 0 0 0 0 0

20 - 24 : 0 0 0 0 0

25 - 29 : 0 0 0 0 0

30 - 34 : 0 0 0 0 0

35 - 39 : 0 0 0 0 0

40 - 44 : 0 0 0 0 0

45 - 49 : 0 0 0 425652 0

50 - 54 : 0 0 0 0 0

55 - 59 : 0 0 0 0 0

60 - 64 : 0 0 0 0

cos: incoming

-------------------------------

 

0 - 4 : 1668101 221334 6795 0 100

5 - 7 : 0 163 0

cos: outgoing

-------------------------------

 

0 - 4 : 1317679 0 0 0 0

5 - 7 : 0 425652 0

output queues enqueued:

queue: threshold1 threshold2 threshold3

-----------------------------------------------

queue 0: 0 0 0

queue 1: 1317678 928 1806

queue 2: 0 0 0

queue 3: 429256 0 2

 

output queues dropped:

queue: threshold1 threshold2 threshold3

-----------------------------------------------

queue 0: 0 0 0

queue 1: 0 0 0

queue 2: 0 0 0

queue 3: 0 0 0

 

Policer: Inprofile: 0 OutofProfile: 0

то есть типо работает ?

Share this post


Link to post
Share on other sites

то есть, типа, нет.

Еще надо сделать, чтобы dscp cs6 не появлялся ни за что в остальных виланах и организовать на ВЫХОДНОМ интерфейсе очередь с приоритетом.

Share this post


Link to post
Share on other sites

то есть, типа, нет.

Еще надо сделать, чтобы dscp cs6 не появлялся ни за что в остальных виланах и организовать на ВЫХОДНОМ интерфейсе очередь с приоритетом.

очередь это на выходном интерфейсе сделать

mls qos trust dscp

/??

Share this post


Link to post
Share on other sites

Нет. Эта команда разрешает ДОВЕРЯТЬ чужой раскраске в пакетах, приходящих на порт.

 

http://www.cisco.com...ng_site=bodynav

 

Вот тут в самом начале есть ТРИ диаграммы, которые показывают все метаморфозы пакета при прохождении "системы QoS" в свичке. Первая - как доверяют внешней раскраске, перекрашивают или красят сами. Вторая - как ограничивают скорости. Третья - как управляют приоритетом.

Share this post


Link to post
Share on other sites

еще пару нубских вопросов

если мы на порту пишем

mls qos trust dscp

то циска поидее не сбрасывает метки dscp, а если пишем

mls qos cos 5

mls qos trust cos

то что происходит??

по идее происходит маркирование всего трафика cos 5 + на данном порту все очереди будут строиться на базе cos

(или я чето нетак понял :) )

 

и еще а как на 3750g сразу поменять метки DSCP и COS

сделать вот так:

policy-map policy1
class 123
 set cos 5
 set dscp ef

непрокатывает.

можно или set cos 5 или set dscp ef (хотя на 3550 можно и так и сяк)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this