Jump to content
Калькуляторы

DHCP-server на CISCO с запросом через relay

Приветы!

 

Возможно ли в принципе такое: ???

Есть CISCO ASR1002 и коммутатор DES3028, соединенные езернетом с двумя VLAN-ами (сети 192... и 172...)

Сеть 192... - скажем так, реальная основная,

сеть 172... - для управления коммутаторами и пропуска DHCP запростов с помощью релеев-коммутаторов.

 

 

конфиг CISCO

 

ip dhcp excluded-address 192.168.1.1

ip dhcp pool pool_default

network 192.168.1.0 255.255.255.0

domain-name skynet.us

dns-server 192.168.2.1

default-router 192.168.1.1

lease 0 0 2

 

interface GigabitEthernet0/0/2

ip address 192.168.1.1 255.255.255.0

negotiation auto

!

interface GigabitEthernet0/0/2.150

description default VLAN

encapsulation dot1Q 150

ip address 172.12.0.1 255.255.255.0

 

------------------------

конфиг коммутатора D-link DES-3028 (IP = 172.12.0.100)

 

# DHCP_RELAY

 

enable dhcp_relay

config dhcp_relay hops 4 time 0

config dhcp_relay option_82 state enable

config dhcp_relay option_82 check enable

config dhcp_relay option_82 policy replace

config dhcp_relay option_82 remote_id default

config dhcp_relay add ipif System 172.12.0.1

 

----------------------------------------------

 

Получаю вот что:

 

Mar 4 08:02:25.589: DHCPD: DHCPDISCOVER received from client 0100.055d.718e.fb through relay 172.12.0.100.

Mar 4 08:02:25.589: DHCPD: using received relay info.

Mar 4 08:02:25.589: DHCPD: Sending notification of DISCOVER:

Mar 4 08:02:25.589: DHCPD: htype 1 chaddr 0005.5d71.8efb

Mar 4 08:02:25.589: DHCPD: remote id 0006f07d68fe9e72

Mar 4 08:02:25.589: DHCPD: circuit id 0004000b0002

Mar 4 08:02:25.589: DHCPD: giaddr = 172.12.0.100

Mar 4 08:02:25.589: DHCPD: interface = GigabitEthernet0/0/2.150

Mar 4 08:02:25.589: DHCPD: class id 64686370636420332e322e33

Mar 4 08:02:25.589: DHCPD: there is no address pool for 172.12.0.100.

Mar 4 08:02:25.589: DHCPD: Sending notification of ASSIGNMENT FAILURE:

 

-----------------------------------------------

Идея сделать простой DHCP сервер из CISCO с запросами через relay.

 

CISCO может от релея получать запросы (получает, адрес выдать из пула может?)? Я что-то не дописал?

Или вообще не работает такой вариант? Если кто-то победил это, можно кусок конфига показать, разберусь.

Благодарю очень и надеюсь на помощь.

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this