Jump to content
Калькуляторы

Cisco 6500 странная работа с софтроутером

Закуплена Cisco 6509. На борту стоит 1 гигабитный модуль и 1 fastethernet. Оба 48 портов. Cisco настроена. Один софтроутер на linux с ней не могу заставить работать. Пробовал как fast так gigabit модули. Конфигурация обоих:

cisco#show running-config interface g2/3
Building configuration...

Current configuration : 107 bytes
!
interface GigabitEthernet2/3
description brass10
switchport
switchport mode trunk
no ip address
end

cisco#show running-config interface f3/1
Building configuration...

Current configuration : 184 bytes
!
interface FastEthernet3/1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 500,550,560,570,580,590,600,630
switchport mode trunk
no ip address
end
cisco#show interface f3/1               
FastEthernet3/1 is up, line protocol is up (connected)
  Hardware is C6k 100Mb 802.3, address is 0002.fc24.c37c (bia 0002.fc24.c37c)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s
  input flow-control is off, output flow-control is unsupported 
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:16, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/196/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 4000 bits/sec, 4 packets/sec
     17990 packets input, 1775793 bytes, 0 no buffer
     Received 2403 broadcasts (108 multicasts)
     0 runts, 0 giants, 0 throttles
     2 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     163125 packets output, 15891150 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
cisco#show interface g2/3
GigabitEthernet2/3 is down, line protocol is down (notconnect)
  Hardware is C6k 1000Mb 802.3, address is 0002.fcbe.3d5a (bia 0002.fcbe.3d5a)
  Description: brass10
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Auto-duplex, Auto-speed
  input flow-control is off, output flow-control is off
  Clock mode is auto
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 01:23:44, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     98074 packets input, 6825201 bytes, 0 no buffer
     Received 22323 broadcasts (66 multicasts)
     0 runts, 0 giants, 0 throttles
     6 input errors, 0 CRC, 14 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     6615147 packets output, 661587891 bytes, 0 underruns
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
cisco#show mac-address-table interface f3/1
Legend: * - primary entry

  vlan   mac address     type    learn            ports
------+----------------+--------+-----+--------------------------
*  500  485b.39bc.abe1   dynamic  Yes   Fa3/1

На данный момент сервер включен в порт f3/1. Поэтому маки на g2/3 не показываю... Там ситуация аналогичная при включении.

Вот конфиг интерфейса софтроутера:

3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
5: eth1.550@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.55.0.253/24 brd 10.55.0.255 scope global eth1.550
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
6: eth1.560@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.56.2.253/16 brd 10.56.255.255 scope global eth1.560
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
7: eth1.570@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.57.2.253/16 brd 10.57.255.255 scope global eth1.570
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
8: eth1.580@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.58.2.253/16 brd 10.58.255.255 scope global eth1.580
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
9: eth1.590@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.59.2.253/16 brd 10.59.255.255 scope global eth1.590
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
10: eth1.600@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.60.2.253/16 brd 10.60.255.255 scope global eth1.600
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
11: eth1.630@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.63.0.253/16 brd 10.63.255.255 scope global eth1.630
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever
12: eth1.500@eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether 48:5b:39:bc:ab:e1 brd ff:ff:ff:ff:ff:ff
    inet 10.50.0.10/16 brd 10.50.255.255 scope global eth1.500
    inet6 fe80::4a5b:39ff:febc:abe1/64 scope link 
       valid_lft forever preferred_lft forever

Вот данные по vlan 500.

cisco#show running-config interface vlan 500
Building configuration...

Current configuration : 63 bytes
!
interface Vlan500
ip address 10.50.0.253 255.255.255.0
end

cisco#show interface vlan 500               
Vlan500 is up, line protocol is up 
  Hardware is EtherSVI, address is 00d0.2beb.a90a (bia 00d0.2beb.a90a)
  Internet address is 10.50.0.253/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
     reliability 255/255, txload 6/255, rxload 12/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/377/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 50252000 bits/sec, 6461 packets/sec
  5 minute output rate 26615000 bits/sec, 10711 packets/sec
  L2 Switched: ucast: 102255966 pkt, 64101240254 bytes - mcast: 229376 pkt, 14882009 bytes
  L3 in Switched: ucast: 2751524432 pkt, 2677698187328 bytes - mcast: 0 pkt, 0 bytes mcast
  L3 out Switched: ucast: 4479185017 pkt, 1376460588345 bytes 
     2753178593 packets input, 2677803177637 bytes, 0 no buffer
     Received 210388 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 19 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     4480630829 packets output, 1376679675970 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out

Теперь список странностей. Сама циска пингует софтроутер а он её. Но никто кроме циски это сделать не может. Соответственно сам софтроутер не видит никого кроме циски. Если с софтроутера кинуть на циску тяжелый флудпинг (ping -f -S 14500 10.50.0.253) проходит около 10к пакетов и потом связь теряется. После одной или двух перезагрузок связь восстанавливается. Пробовал включать на другие порты - результат тот же. Патчкорд многократно менялся и в итоге включен литой. Сменил сетевую на совтроутере. Софтроутер переустановлен. Если убрать на софтроутере вланы и назначить ip на сетевую а на циске выставить на этом порту нативный влан - работает..... Правда флудпингами не проверял....

Бьюсь уже две недели. Идеи закончились. Неделя упортного гугления результата не принесла. По форуму поискал, подобного не нашел. Если плохо искал ткните, пожалуйста, носом...

Share this post


Link to post
Share on other sites

Попробовал поднять вланы на другом брасе. Результат тот же. Но вспомнил про особенность. На брасс который работает установлена двух портовая сетевая:

03:01.0 Ethernet controller: Intel Corporation 82546EB Gigabit Ethernet Controller (Copper) (rev 03)
03:01.1 Ethernet controller: Intel Corporation 82546EB Gigabit Ethernet Controller (Copper) (rev 03)

На не работающих:

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
03:01.0 Ethernet controller: Sundance Technology Inc / IC Plus Corp IP1000 Family Gigabit Ethernet (rev 41)

и

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
03:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this