Jump to content
Калькуляторы

cisco 3750G IP Unnumbered проблема

Есть циска 3750g выступающая в роли агрегатора в схеме свитч влан, ip Unnumbered . Unnumbered интерфейс выступает шлюзом для клиентов, выдается по дхцп. Дхцп сервер выдает настройки, в свитче доступа в dynamic arp inspection , и дхцп снупинг данные клиента ip адресс, маска , мак и Lease в попадет и запоминается нормально. Клиенту настройки тоже приходят нормально. А вот с циской проблема, адрес держится в sh ip dhcp binding 6-7 секунд, потом пропадает, соответственно ip Unnumbered ип, выступающий шлюзом перестает пинговатся. Потом через какое то время(минут через 4-5) появляется адрес в sh ip dhcp binding и пинги идут. При обновлении настроек, все повторяется. Может кто то сталкивался с таким ?

WS-C3750G-24T 12.2(46)SE C3750-ADVIPSERVICESK9-M

 

3750G-24T-1#sh ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

193.107.112.137 001b.248d.1702 Dec 28 2010 05:37 PM Relay

 

3750G-24T-1#sh ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

Edited by X-RaY™

Share this post


Link to post
Share on other sites
Есть циска 3750g выступающая в роли агрегатора в схеме свитч влан, ip Unnumbered . Unnumbered интерфейс выступает шлюзом для клиентов, выдается по дхцп. Дхцп сервер выдает настройки, в свитче доступа в dynamic arp inspection , и дхцп снупинг данные клиента ip адресс, маска , мак и Lease в попадет и запоминается нормально. Клиенту настройки тоже приходят нормально. А вот с циской проблема, адрес держится в sh ip dhcp binding 6-7 секунд, потом пропадает, соответственно ip Unnumbered ип, выступающий шлюзом перестает пинговатся. Потом через какое то время(минут через 4-5) появляется адрес в sh ip dhcp binding и пинги идут. При обновлении настроек, все повторяется. Может кто то сталкивался с таким ?

WS-C3750G-24T 12.2(46)SE C3750-ADVIPSERVICESK9-M

 

3750G-24T-1#sh ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

193.107.112.137 001b.248d.1702 Dec 28 2010 05:37 PM Relay

 

3750G-24T-1#sh ip dhcp binding

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

cмени İOS на 12.55 ED IPservices

 

Share this post


Link to post
Share on other sites

Сменил, то же самое. Адрес попадает при выдаче секунд на 5-7, потом исчезает и появляется через минут 5 . Даже не знаю куда копать, дхцп сервер от радиуса, может там что не не так ... Но все остальное распознается корректно(у клиента, на свитчах доступа, та и пакеты вроде в норме судя по tcpdump)

Share this post


Link to post
Share on other sites

Сменил, то же самое. Адрес попадает при выдаче секунд на 5-7, потом исчезает и появляется через минут 5 . Даже не знаю куда копать, дхцп сервер от радиуса, может там что не не так ... Но все остальное распознается корректно(у клиента, на свитчах доступа, та и пакеты вроде в норме судя по tcpdump)

Скорее там что-то не так. У меня все работает: проверил на двух прошивках одинаково нормально. Только у меня DHCP без радиуса.

Edited by Traskalata

Share this post


Link to post
Share on other sites

sh ip dh sn binding

 

у меня так:

sh conf | in dhcp

ip dhcp snooping vlan 2011-2034

ip dhcp snooping information option allow-untrusted

ip dhcp snooping database tftp://x.x.x.x/dhcpsnoop

ip dhcp snooping database write-delay 3600

ip dhcp snooping

errdisable recovery cause dhcp-rate-limit

ip dhcp snooping limit rate 2048

 

работает нормально

Share this post


Link to post
Share on other sites

хмм у меня оно на циске релеем проходит, а не снупингом, но не думаю что в этом дело. Адрес то попадает и время аренды корректно показывается, но потом исчезает. А у клиента и на доступе адрес остается на месте везде. Просто не понимаю по какой причине, кроме истечения аренды или релиза адреса, циска может выкидывать его из списка своего, и тем более, не понимаю почему он через минут 5 появляется и потом до конца аренды нормально работает.

 

хмм у меня оно на циске релеем проходит, а не снупингом, но не думаю что в этом дело. Адрес то попадает и время аренды корректно показывается, но потом исчезает. А у клиента и на доступе адрес остается на месте везде. Просто не понимаю по какой причине, кроме истечения аренды или релиза адреса, циска может выкидывать его из списка своего, и тем более, не понимаю почему он через минут 5 появляется и потом до конца аренды нормально работает.

Share this post


Link to post
Share on other sites

дхцп сервер через радиус

циска из того что имеет какое то отношение, вроде

 

no aaa new-model

switch 1 provision ws-c3750g-24t

system mtu routing 1500

vtp mode transparent

ip subnet-zero

ip dhcp smart-relay

ip dhcp relay information option

ip dhcp relay information policy keep

no ip dhcp relay information check

ip dhcp relay information trust-all

 

interface Loopback1

ip address 10.2.0.1 255.255.255.0

 

interface Vlan1101

ip dhcp relay information trusted

ip unnumbered Loopback1

ip helper-address 10.1.0.2

no ip redirects

ip local-proxy-arp

ip route-cache same-interface

 

или делать через снупинг как то ? У меня доступ вставляет опцию 82, влан на свитч.

Share this post


Link to post
Share on other sites

Кто то может поделится строчками конфига, которые отвечают за релей на агрегации ? Может я что то не так понимаю\делаю ? А то не могу понять в чем проблема (конфиг вверху) Есть идеи ?

Спасибо

Share this post


Link to post
Share on other sites

Убрал смарт-релей(что бы ушел, пришлось бутатся), сделал через снупинг, убрал опцию 82. Все выдает, вдрес висит в снупинге, но теперь не пингуется аннамберед интерфейс от клиента. Скиньте пожалустса кусок конфига - интерфейс влан и что еще надо включать для нормальной работы в качестве аннамберед агрегатора. За несколько месяцев столько ращ все переделывалось, я уже и не помню как было правильно настроено на циске, когда оно работало на исц-дхцп.

Спасибо

Share this post


Link to post
Share on other sites

Или хотя бы просто подскажите, в чем дело

в sh ip dh sn binding есть ипы,лизы, в sh ip dh binding пусто - пингов нету,

потом после 5-6 мин появляется в sh ip dh binding запись и пинг идет, пока не кончается лиза, сил больше нет разбиратсяс чем это связано (

Share this post


Link to post
Share on other sites
interface Vlan2
description 1 port
ip unnumbered Loopback2
ip helper-address x.x.x.x
ip helper-address x.x.x.x
no ip redirects
no ip unreachables
ip pim sparse-mode
ip route-cache same-interface
end

interface Loopback2
ip address x.x.x.254 255.255.255.255 secondary
ip address x.x.x.254 255.255.255.255
no ip redirects
ip route-cache same-interface
end

Edited by Slad

Share this post


Link to post
Share on other sites

А зачем снупинг на агрегаторе?

Share this post


Link to post
Share on other sites

чтобы dhcp snoop заполнялось само.

Share this post


Link to post
Share on other sites

Так это ж агрегатор? Зачем ему? На всякий пожарный?

Он адреса и так узнает, когда клиент себя в сети проявит.

Share this post


Link to post
Share on other sites

Я тоже так думал, но почему то перед тем как оно начинает работать, проходит 5 минут(см первый пост ) прошивки менял, настраивал и релей и снупинг, результат 1.

Адрес появляется в sh ip dhcp binding на пару сек в начале, потом пропадает, пинг на аннамберед интерфейс не идет, через 5 минут появляется адрес и пинг. При этом в sh ip dh sn binding адрес висит все время...

Share this post


Link to post
Share on other sites

Перечитал еще раз все на циско ком по дхцп, вообще не понимаю.

3750G-24T-1#sh ip dhcp sn bi

MacAddress IpAddress Lease(sec) Type VLAN Interface

------------------ --------------- ---------- ------------- ---- --------------------

00:1B:24:8D:17:02 193.107.112.196 490 dhcp-snooping 1101 Port-channel2

Total number of bindings: 1

 

3750G-24T-1#sh ip dhcp bi

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

 

так нет пинга на аннамберед интерфейс, проходит ровно 5 минут от начала аренды и

 

3750G-24T-1#sh ip dhcp sn bi

MacAddress IpAddress Lease(sec) Type VLAN Interface

------------------ --------------- ---------- ------------- ---- --------------------

00:1B:24:8D:17:02 193.107.112.196 299 dhcp-snooping 1101 Port-channel2

Total number of bindings: 1

 

3750G-24T-1#sh ip dhcp bi

Bindings from all pools not associated with VRF:

IP address Client-ID/ Lease expiration Type

Hardware address/

User name

193.107.112.196 001b.248d.1702 Jan 12 2011 04:44 PM Relay

 

все работает, до переполучения адреса. Не могу понять откуда эти ровные 5 минут. И почему в первые секунды , после получения адреса он есть в sh ip dhcp bi

 

вот конф

3750G-24T-1#sh conf | i dhcp

ip dhcp snooping vlan 1101

ip dhcp snooping information option allow-untrusted

ip dhcp snooping

ip dhcp relay information trusted

ip dhcp relay information option-insert none

ip dhcp relay information policy-action keep

 

interface Loopback1

ip address 193.107.112.129 255.255.255.128

no ip redirects

ip route-cache same-interface

 

interface Vlan1101

ip dhcp relay information trusted

ip dhcp relay information option-insert none

ip dhcp relay information policy-action keep

ip unnumbered Loopback1

ip helper-address 10.1.0.2

no ip redirects

ip local-proxy-arp

ip route-cache same-interface

 

Я думаю может я что то недопонял с ip dhcp snooping database и её надо обязательно указывать и настраивать?

Единственное что я нашел с 5ти минутами в дхцп, это

3750G-24T-1#sh ip dhcp sn database detail

Agent URL :

Write delay Timer : 3600 seconds

Abort Timer : 300 seconds

 

Я уже столько всего накрутил и начитался, надумал за эти пару недель, что вообще ступор, не понимаю, что за 5 минут таких =(

Edited by X-RaY™

Share this post


Link to post
Share on other sites

мне почему то кажется, что запутались вы основательно...

для начала нарисуйте кусок сети от шлюза до абонента, чтоб прийти к общему пониманию вашей проблемы - там ли вы ее ищите..

Share this post


Link to post
Share on other sites

Абонент->управляемый свитч->абонентский влан на 3750->3750 dhcp relay и шлюз, через ip Unnumbered->дхцп сервер на freebsd.

Дхцп сервер выдает настройки, в свитче доступа в dynamic arp inspection , и дхцп снупинг данные клиента ip адресс, маска , мак и Lease в попадет и запоминается нормально. Абоненту настройки тоже приходят нормально.

Адрес выдается из пула 193.107.112.128/25 , на лупбеке висит адрес 193.107.112.129\25, когда проходит ровно 5 минут(300 сек) и у циски появляется адрес в show ip dhcp binding, все отлично пингуется. Сидел ждал этот момент и оно все происходит одновременно. Возможно есть еще какое то 3йе событие которое приводит к появлению записи в show ip dhcp binding ровно через 5 минут после начала аренды.

Share this post


Link to post
Share on other sites

зачем на агрегаторе dhcp snooping?(вам вопрос этот задавали)

свич доступа какой?

вы дебаг на циске dhcp (debug ip dhcp snooping event ) смотрели? может там ответ внутри него?

Share this post


Link to post
Share on other sites

А по какому принципу запись попадает в sh ip dhcp bi ? Точнее почему оно релеит запрос нормально, в базу снупинга попадает, а туда только через 5 минут...

а снупинг что был, что его небыло, все равно.

доступ edge-core es3528M и алкатель(тот же es3528 +-)

Все хорошо проходит, свитч присылает опцию 82, циска релеит юникастом на сервер, сервер отвечает, циска нормально его передает, абонент получает все настройки. Но вот unnumbered инетрфейс не пингуется пока не пройдет 5 мин и запись не попадет в sh ip dhcp b.

Share this post


Link to post
Share on other sites

Дело было не в бобине ...

Настроил isc-dhcp с опцией 82 и юникастом, записи появляются сразу везде и все работает...

Куда копать в радиус дхцп можно, если винда, свитчи доступа, да и сама циска в снупинг базу его кладет корректно, но sh ip dhcp b тут он появляется только спустя время... дурдом какой то ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this