Jump to content
Калькуляторы

Конфигурирование VLAN(Cisco 2960) + PC-router(FreeBSD 8.1) Проблема организации сабжа.

Ситуация следующая.

Есть PC маршрутизатор под управлением FreeBSD 8.1, у маршрутизатора 1(одна) сетевая карта.

Хочется сделать так, чтоб он маршрутизировал трафик из локальной сети в Internet и обратно

Хочу "поместить провайдера" и маршрутизатор в один vlan, маршрутизатор и хосты LAN в другой vlan, чтоб на аппаратном уровне оградить локальный и внешний трафик.

 

При организации сабжа маршрутизатор не пингуется из локальной сети, шлюз провайдера также не доступен с роутера.

VLAN2(Fa0/1) - сеть провайдера, VLAN3(Fa0/2) - ЛВС. Fa0/2 - trunk port.

нет ping-а c 10.0.0.2 на 10.0.0.3 c Fa0/3

Буду признателен за любой совет! Далее привожу конфигурацию роутера, коммутатора:

 

/etc/rc.conf

gateway_enable="YES"
ifconfig_re0="up media 100baseTX mediaopt full-duplex"
cloned_interfaces="vlan2 vlan3"
ifconfig_vlan2="inet 172.20.60.2 netmask 255.255.255.240 vlan 2 vlandev re0"
ifconfig_vlan3="inet 10.0.0.3 netmask 255.255.255.0 vlan 3 vlandev re0"

 

ifconfig

re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAG
IC>
  ether 20:cf:30:0b:29:33
  media: Ethernet 100baseTX <full-duplex> (none)
  status: no carrier
plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> metric 0 mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
  options=3<RXCSUM,TXCSUM>
  inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4 
  inet6 ::1 prefixlen 128 
  inet 127.0.0.1 netmask 0xff000000 
  nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
vlan2: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=3<RXCSUM,TXCSUM>
  ether 20:cf:30:0b:29:33
  inet 172.20.60.2 netmask 0xfffffff0 broadcast 172.20.60.15
  media: Ethernet 100baseTX <full-duplex> (none)
  status: no carrier
  vlan: 2 parent interface: re0
vlan3: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
  options=3<RXCSUM,TXCSUM>
  ether 20:cf:30:0b:29:33
  inet 10.0.0.3 netmask 0xffffff00 broadcast 10.0.0.255
  media: Ethernet 100baseTX <full-duplex> (none)
  status: no carrier
  vlan: 3 parent interface: re0

 

Catalist 2960

    Switch#show vlan

   VLAN Name                             Status    Ports
   ---- -------------------------------- --------- -------------------------------
   1    default                          active    Fa0/4, Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                          Fa0/18, Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/23, Fa0/24, Gi0/1, Gi0/2
   2    ISP_network                  active    Fa0/1
   3    LAN                              active    Fa0/3
   1002 fddi-default                     act/unsup
   1003 token-ring-default               act/unsup
   1004 fddinet-default                  act/unsup
   1005 trnet-default                    act/unsup

   VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
   ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
   1    enet  100001     1500  -      -      -        -    -        0      0
   2    enet  100002     1500  -      -      -        -    -        0      0
   3    enet  100003     1500  -      -      -        -    -        0      0
   1002 fddi  101002     1500  -      -      -        -    -        0      0
   1003 tr    101003     1500  -      -      -        -    -        0      0
   1004 fdnet 101004     1500  -      -      -        ieee -        0      0
   1005 trnet 101005     1500  -      -      -        ibm  -        0      0

   Remote SPAN VLANs
   ------------------------------------------------------------------------------


   Primary Secondary Type              Ports
   ------- --------- ----------------- ------------------------------------------

      Switch#show interface fa0/2 trunk

   Port        Mode         Encapsulation  Status        Native vlan
   Fa0/2       on           802.1q         trunking      3

   Port      Vlans allowed on trunk
   Fa0/2       1-3

   Port        Vlans allowed and active in management domain
   Fa0/2       1-3

   Port        Vlans in spanning tree forwarding state and not pruned
   Fa0/2       1-3



Share this post


Link to post
Share on other sites
Ситуация следующая.

re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAG

IC>

ether 20:cf:30:0b:29:33

media: Ethernet 100baseTX <full-duplex> (none)

status: no carrier

status: no carrier - кабель проверьте, на каталисте проверьте vlan data - есть ли там vlan 2 и vlan 3

Share this post


Link to post
Share on other sites
Ситуация следующая.

re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAG

IC>

ether 20:cf:30:0b:29:33

media: Ethernet 100baseTX <full-duplex> (none)

status: no carrier

status: no carrier - кабель проверьте, на каталисте проверьте vlan data - есть ли там vlan 2 и vlan 3

Прошу великодушно меня извинить. Снимая конфигурацию с роутера забыл присоединить кабель после многочисленных экспериментов.

Остался в другом интерфейсе, здесь не приведенном.

 

Switch(vlan)#show

  VLAN ISL Id: 1
   Name: default
   Media Type: Ethernet
   VLAN 802.10 Id: 100001
   State: Operational
   MTU: 1500
   Backup CRF Mode: Disabled
   Remote SPAN VLAN: No

 VLAN ISL Id: 2
   Name: ISP_network
   Media Type: Ethernet
   VLAN 802.10 Id: 100002
   State: Operational
   MTU: 1500
   Backup CRF Mode: Disabled
   Remote SPAN VLAN: No

 VLAN ISL Id: 3
   Name: LAN
   Media Type: Ethernet
   VLAN 802.10 Id: 100003
   State: Operational
   MTU: 1500
   Backup CRF Mode: Disabled
   Remote SPAN VLAN: No

Share this post


Link to post
Share on other sites

а что у вас с мас и arp таблицами с обеих сторон ? хоть что нить там ихучается ? в каких vlan ?

 

 

Share this post


Link to post
Share on other sites
а что у вас с мас и arp таблицами с обеих сторон ? хоть что нить там ихучается ? в каких vlan ?

show mac-address-table

          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  3    20cf.300b.2933    DYNAMIC     Fa0/2
  2    20cf.300b.2933    DYNAMIC     Fa0/2
  3    0018.f3c5.0c0c    DYNAMIC     Fa0/3

Share this post


Link to post
Share on other sites

а arp ? вы с циски пингануть

не можете

 

я не знаю FreeBSD, но у мя вопрос ?

ifconfig_vlan2="inet 172.20.60.2 netmask 255.255.255.240 vlan 2 vlandev re0"

ifconfig_vlan3="inet 10.0.0.3 netmask 255.255.255.0 vlan 3 vlandev re0"

 

что здесь значит 172.20.60.2 и 10.0.0.3 , на cisco У вас почему то тоже самое

Share this post


Link to post
Share on other sites

Энкапсуляция разная у вас

На циске ISL

На фряхе dot1q

 

switchport trunk encapsulation dot1q на каждом интерфейсе или ренче

Share this post


Link to post
Share on other sites
а arp ? вы с циски пингануть

не можете

 

я не знаю FreeBSD, но у мя вопрос ?

ifconfig_vlan2="inet 172.20.60.2 netmask 255.255.255.240 vlan 2 vlandev re0"

ifconfig_vlan3="inet 10.0.0.3 netmask 255.255.255.0 vlan 3 vlandev re0"

 

что здесь значит 172.20.60.2 и 10.0.0.3 , на cisco У вас почему то тоже самое

WindowsXP (Fa0/3 vlan 3, access port)
ip: 10.0.0.2, mask 255.255.255.0
===================================================================
C:\Documents and Settings\Admin>arp -a

Интерфейс: 10.0.0.2 --- 0x2
 Адрес IP              Физический адрес      Тип
 10.0.0.3              20-cf-30-0b-29-33     динамический


FreeBSD 8.1 (Fa0/2 trunk port, allow vlan 1,2,3)
ip: 
 vlan2: 172.20.60.2
 vlan3: 10.0.0.3
===================================================================
#arp -a
? (10.0.0.2) at (incomplete) on vlan3 expires in 19 seconds [vlan]
? (10.0.0.3) at 20:cf:30:0b:29:33 on vlan3 permanent [vlan]
? (172.20.60.2) at 20:cf:30:0b:29:33 on vlan2 permanent [vlan]
? (172.20.60.3) at (incomplete) on vlan2 expires in 19 seconds [vlan]

Cisco Catalyst 2960
===================================================================
Switch#show mac-address-table
         Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  3    0018.f3c5.0c0c    DYNAMIC     Fa0/3
  3    20cf.300b.2933    DYNAMIC     Fa0/2
  2    20cf.300b.2933    DYNAMIC     Fa0/2

Switch#ping 172.20.60.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.20.60.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Switch#ping 10.0.0.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Share this post


Link to post
Share on other sites
Энкапсуляция разная у вас

На циске ISL

На фряхе dot1q

 

switchport trunk encapsulation dot1q на каждом интерфейсе или ренче

Switch(config-if)#switchport trunk encapsulation dot1q
                                  ^
% Invalid input detected at '^' marker.

 

Прошу прощения. Я не большой специалист по Cisco коммутаторам.

Скажите нижеприведенный листинг не говорит о том что коммутатор использует на портах Fa0/2, Fa0/3 инкапсуляцию dot1q?

 

Switch#show interface fa0/3 switchport
Name: Fa0/3
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Switch#show interface fa0/2 trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/2       on           802.1q         trunking      3

Port      Vlans allowed on trunk
Fa0/2       1-3

Port        Vlans allowed and active in management domain
Fa0/2       1-3

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/2       1-3

 

Кстати на sysadmins.ru пишут что Cisco 2960 поддерживает только инкапсуляцию dot1q и только.

 

Edited by TkIgor

Share this post


Link to post
Share on other sites
Прошу прощения. Я не большой специалист по Cisco коммутаторам.

Скажите нижеприведенный листинг не говорит о том что коммутатор использует на портах Fa0/2, Fa0/3 инкапсуляцию dot1q?

Что то запутался, а что за листинг в третьем посте?

Share this post


Link to post
Share on other sites
Switch#ping 172.20.60.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.20.60.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch#ping 10.0.0.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

 

а default gatewa ? на Cisco и show ip inter breif ?

 

 

Share this post


Link to post
Share on other sites
Прошу прощения. Я не большой специалист по Cisco коммутаторам.

Скажите нижеприведенный листинг не говорит о том что коммутатор использует на портах Fa0/2, Fa0/3 инкапсуляцию dot1q?

Что то запутался, а что за листинг в третьем посте?

enable

conf t

vlan data

show

Share this post


Link to post
Share on other sites
Switch#ping 172.20.60.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.20.60.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch#ping 10.0.0.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

 

а default gatewa ? на Cisco и show ip inter breif ?

Switch#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  xxx.xxx.xxx.xxx   YES NVRAM  up                    up
Vlan3                  10.0.0.1        YES manual up                    up
FastEthernet0/1        unassigned      YES unset  down                  down
FastEthernet0/2        unassigned      YES unset  up                    up
FastEthernet0/3        unassigned      YES unset  up                    up

 

default gateway - не установлен.

Я не собираюсь осуществлять роутинг с помощью даного коммутатора.

Для роутинга собираюсь использовать РС-роутер подключенный к trank-порту Fa0/2

Share this post


Link to post
Share on other sites

Укважаемый TkIgor.

В первом посте присутствует аля sh run для bsd и в впринципе видно за искл описки стсуса "no carrier"

, что там все верно с vlan.

Приведите плз листинг для коммутатора. Скорее всего дело в транке сос тороны коммутатора.

Share this post


Link to post
Share on other sites
Switch#ping 172.20.60.2

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.20.60.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Switch#ping 10.0.0.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

 

а default gatewa ? на Cisco и show ip inter breif ?

Switch#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  xxx.xxx.xxx.xxx   YES NVRAM  up                    up
Vlan3                  10.0.0.1        YES manual up                    up
FastEthernet0/1        unassigned      YES unset  down                  down
FastEthernet0/2        unassigned      YES unset  up                    up
FastEthernet0/3        unassigned      YES unset  up                    up

 

default gateway - не установлен.

Я не собираюсь осуществлять роутинг с помощью даного коммутатора.

Для роутинга собираюсь использовать РС-роутер подключенный к trank-порту Fa0/2

 

 

ну вот и вас и получается что коммутатор не знает где ему искать 10.0.0.3 это не его сеть.

и зачем вам тогда пинговать 10.0.0.3 с коммутатора ? непонятно!

Share this post


Link to post
Share on other sites

Прошу прощения , еще раз посморел то, что вы показали и судя по всему транк у вас работает.

config прав , дефолт нужен

Edited by aap

Share this post


Link to post
Share on other sites
Прошу прощения , еще раз посморел то, что вы показали и судя по всему транк у вас работает.

config прав , дефолт нужен

по одному совету попробовал назначить trunk-порту native vlan 1.

И роутер 10.0.0.3 стал пинговаться с порта коммутатора fa0/3(vlan 3).

Правда не понял почему так.

Share this post


Link to post
Share on other sites
Прошу прощения , еще раз посморел то, что вы показали и судя по всему транк у вас работает.

config прав , дефолт нужен

по одному совету попробовал назначить trunk-порту native vlan 1.

И роутер 10.0.0.3 стал пинговаться с порта коммутатора fa0/3(vlan 3).

Правда не понял почему так.

 

Уверены что не совпало это с другими действиями ?

Share this post


Link to post
Share on other sites

лучше покажи последнюю конфигурацию циски и фряхи

 

sh run на циске

 

ifconfig на фряхе

Share this post


Link to post
Share on other sites

И вдогон - смените vtp domain, еще лучше включите vtp transparent, ну и отключите cdp на порту провайдера, а то мало-ли что прилетит :)

Share this post


Link to post
Share on other sites

ппц скока вариантов предложили / скока всяких show выложили а самого главного - конфига циски нету

 

sh run на циске и результаты в студию

 

а потом еще раз что хотите получить в итоге :D

Share this post


Link to post
Share on other sites
ппц скока вариантов предложили / скока всяких show выложили а самого главного - конфига циски нету

А хотите, я его конфиг угадаю :) ?

 

interface FastEthernet0/1

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/2

switchport trunk allowed vlan 2,3

switchport mode trunk

!

interface FastEthernet0/3

switchport access vlan 3

switchport mode access

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this