Jump to content
Калькуляторы

NAT на MikRotik

Подскажите, как создать правило, которое будет автоматически пробрасывать порты для всех IP адресов и портов?

Например на 2-х компах запущен торрент клиент, у одного в настройках указан порт 44444, а у второго 44445, нужно сделать так, чтобы микротик сам пробрасывал порты для всех клиентов.

 

Нечто подобное делал на модеме Huawei MT 880

Share this post


Link to post
Share on other sites

UPnP

Прошу помочь с настройкой UPnP, настроек там мало, перепробовал все возможные варианты, порты не пробрасываются :(

Share this post


Link to post
Share on other sites

там достаточно просто

 

[admin@Mikrotik01] > interface print

Flags: D - dynamic, X - disabled, R - running, S - slave

# NAME TYPE MTU L2MTU

0 R ether1 ether 1500

1 R ether2 ether 1500

ether1 = wan

ether2 = lan

 

на ether1 включен masquerade

 

/ip upnp set enable=yes

/ip upnp interfaces add interface=ether1 type=external disabled=no

/ip upnp interfaces add interface=ether2 type=internal disabled=no

 

[admin@Mikrotik01] > /ip upnp export

/ip upnp

set allow-disable-external-interface=yes enabled=yes show-dummy-rule=yes

/ip upnp interfaces

add disabled=no interface=ether1 type=external

add disabled=no interface=ether2 type=internal

Share this post


Link to post
Share on other sites
там достаточно просто

Все так и было настроено, но к сожалению не работает :(

[b]interface print[/b]
Flags: D - dynamic, X - disabled, R - running, S - slave 
#     NAME                                        TYPE             MTU   L2MTU
0  R  ether1-gateway                              ether            1500  1526 
1  R  ether2-local-master                         ether            1500  1524 
2  R  ether3-local-slave                          ether            1500  1524 
3     ether4-local-slave                          ether            1500  1524 
4  R  ether5-local-slave                          ether            1500  1524

 

/ip upnp export
# dec/09/2010 23:31:59 by RouterOS 5.0rc5
# software id = 4CUG-WAZY
#
/ip upnp
set allow-disable-external-interface=no enabled=yes show-dummy-rule=yes
/ip upnp interfaces
add disabled=no interface=ether1-gateway type=external
add disabled=no interface=ether2-local-master type=internal

Создаются такие правила:

post-76828-1291927092_thumb.png

Но чтобы пробросить порты у себя или например на вебкамере правила нужно создавать только вручную :(

Если я создаю правило вручную, указываю протокол, порт и IP клиента (больше ничего, внешний айпи могу указывать, могу не указывать), то все работает.

post-76828-1291927199_thumb.png

Edited by WhyMax

Share this post


Link to post
Share on other sites

Спасибо verhoum, сделал -все получилось. Странно конечно, но через чекбоксы в Winbox не хотело работать. Но встал еще один вопрос, и чувствую, сам его я не перееду.

 

Моя схема:

1. с микротика 192.168.1.1 раздается DHCP клиентам пулом 192.16.1.0-192.168.1.254 без привязки к мак адресу (сделано, чтобы они могли обмениваться информацией внутри сети, любой комп включенный в сеть получает IP)

2. Поднят pppoe сервер 10.2.2.1 и клиенты по паролю цепляются к микротику (получают второй IP PPPOE пула 10,2,2,2-10.2.2.254 тоже автоматом). Чтобы в случае чего отключать доступ клиентов в инет (по юзеру). + только при ПППОЕ соединении они выходят в Инет.

3. В firewall прописано правило блокирующее доступ 192.16.1.0 к ВАН интерфейсу (обычный drop по источнику).

4. Внешний IP получаю от провайдера Statiс.

 

Вопрос следующий: Если клиент подключается просто по DHCP и не поднимает PPPOE соединение, то UPnP работает без проблем. Как только пользователь подключает PPPOE, UPnP не работает. При тестах выключаю правило блокировки пользователей по IP в Firewall. Как прописать правила, чтобы при подключении по ПППОЕ работал UPnP?

Edited by shan1504

Share this post


Link to post
Share on other sites

PPPoE интерфейсы в список UPnP добавлены как internal?

Share this post


Link to post
Share on other sites

Вопрос, а как их добавить, если они динамические типа pppoe-user0001? Добавить их в UPnp можно, но при отключении юсера, в UPnp порт становиться - unknown. И заново не восстанавливается при подключении юсера.

Или мы про разные интерфейсы pppoe говорим?

 

Понял, как сделать статический pppoe интерфейс с привязкой к пользователю, добавил в UPNP этот интерфейс, но все равно, как только цепляюсь к микротику пппое - UPNP перестает работать.

Edited by shan1504

Share this post


Link to post
Share on other sites

На прошивке 3.3 все работает, настройки как на моих скриншотах, пробрасывает для всех клиентов.

Возник такой вопрос - я отключил интерфейс ethernet1, оставил включенным только один ethernet2 - он и external, и internal (т.е. и принимает инет, и раздает его).

Раньше я просто замыкал 1 и 2 порт, как когда-то делал это на роутере dir-320. А ethernet1 буду использовать для резервного канала.

 

Реально ли настроить NAT при таком подключении? Порт ethernet2 внастройках UPnP нельзя сделать внешним и внутренним, только что-то одно.

Нужно создать виртуальный езернет интерфейс, который будет привязан ко 2-му порту? Но как? Какого типа интерфейс добавлять?

Edited by WhyMax

Share this post


Link to post
Share on other sites

я не вижу в картинках, чтобы ты раздавал инет через пппое. При простом DHCP, как я написал, все работает. Не работает именно при PPPOe или PPTP подключении.

Share this post


Link to post
Share on other sites
shan1504, Тип интерфейса Internal задал для PPPoE и PPTP ?

Share this post


Link to post
Share on other sites

Может я что-то не допонимаю, скорее всего. Итак, что делаю: В Интерфейсах создаю новый интерфейс pppoe server с именем pppoe-in1. Два раза на нем щелкаю. В user прописываю имя пользователя (одного из юзеров) в Service (сервис, которым у меня обозван pppoe сервер в закладке PPP, к примеру pppoe internet)

Добавляю pppoe-in1 в UPNP как internal.

Что имеем: когда юсер подключается, активируется pppoe-in1 и через него пошел трафик. А UPNP не работает у юсера на ПК, хоят в нате появляются какие-то правила с портами для этого ИП адреса. А тот же DC++ говорит-что не может создать UPNP порт, но как юсер отключается по ппое-соединению, остаются одно DHCP подключение к Микротик, DC++ говорит все ок. порт создал готов работать.

 

Может я как-то интерфейс не так создаю?

Edited by shan1504

Share this post


Link to post
Share on other sites

Заметил странную закономерность: на прошивке 3.3 (возможно 4.16) UPnP работает как надо.

Сейчас поставил 5-ю версию (слава богу хоть что-то у меня заработало без сбоев) - на всех моих ПК, которые подключены к одному свитчу, а свитч в езернет порт микротика порты не пробрасываются (на 3.3 и 4 пробрасывались), а у других порты пробрасываются автоматически со всеми прошивками.

Share this post


Link to post
Share on other sites
Заметил странную закономерность: на прошивке 3.3 (возможно 4.16) UPnP работает как надо.

Сейчас поставил 5-ю версию (слава богу хоть что-то у меня заработало без сбоев) - на всех моих ПК, которые подключены к одному свитчу, а свитч в езернет порт микротика порты не пробрасываются (на 3.3 и 4 пробрасывались), а у других порты пробрасываются автоматически со всеми прошивками.

Возможно глюк ОС.

Share this post


Link to post
Share on other sites

WhyMax

у тебя не то, проблема PPPoE и VPN клиентами.... тоже очень интересует вопрос меня... как добавить PPPoE сервер и VPN

Share this post


Link to post
Share on other sites
WhyMax

у тебя не то, проблема PPPoE и VPN клиентами.... тоже очень интересует вопрос меня... как добавить PPPoE сервер и VPN

Судя по скринам у меня нет PPPoE, инет приходят напрямую по NAT.

Раньше пппое не было, щас появился второй канал с пппое.

 

Проблему решил оч просто - от свитча идет 2 кабеля, один на интерфейс LAN, второй WAN, все работает без сбоев!!! На любой прошивке.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this