Jump to content
Калькуляторы

ISG + ip subscriber l2-connected + ip unnumbered + DHCP relay

Cisco 7206VXR.

IOS: c7200-advipservicesk9-mz.122-33.SRE1.bin

 

Есть куча вланов приходящие на 72-ую. Надо:

1. Подключившемуся клиенту в любом из вланов выдать ИП адрес по DHCP из 192.168.0.0/24

2. Попробывать авторизовать его по МАС адресу.

3. В случае неудачи пункта 2, клиента редиректят на страницу авторизации (портал).

 

Пример одного сабинтерфейса:

interface GigabitEthernet0/2.25
encapsulation dot1Q 25
ip dhcp relay information option-insert
ip dhcp relay information check-reply
ip dhcp relay information policy-action replace
ip unnumbered Loopback1
ip helper-address 192.168.1.2
ip nat inside
no cdp enable
service-policy type control ISG-WIFI-SESSION
ip subscriber l2-connected
  initiator unclassified mac-address

 

Loopback 1:

interface Loopback1
ip address 192.168.0.1 255.255.255.0

 

Проблема:

При таком конфиге, клиент подключается к сети, получает по DHCP адрес из 192.168.0.0/24, пытается выйти в Интернет - и получает болт.

Пинг гейтвея (192.168.0.1) с клиента какой то эпизодический... то пингует, то не пингует.

Пинг DHCP сервера (192.168.1.2) - также отсутствует.

На циске отсутствует информация об клиенте:

sh subsc sess | incl IP - ничего не показывает.

 

 

Теперь приведем конфиг к такому виду:

удаляем Лупбэк 1

избавимся от ip unnumbered и пропишем явно ип адрес на сабинтерфейсе.

interface GigabitEthernet0/2.25
encapsulation dot1Q 25
ip dhcp relay information option-insert
ip dhcp relay information check-reply
ip dhcp relay information policy-action replace
ip address 192.168.0.1 255.255.255.0
ip helper-address 192.168.1.2
ip nat inside
no cdp enable
service-policy type control ISG-WIFI-SESSION
ip subscriber l2-connected
  initiator unclassified mac-address

 

В этом случае - все работает хорошо.

Вначале клиент прозрачно пытается авторизоваться по МАСу. Потом его редиректят на страницу авторизации.

на циске:

Router_PPPoE#sh subsc sess | incl IP
1500    IP           unauthen      Local Term   192.168.0.100        00:00:00

- клиент пытается выйти в интернет.

 

Теперь другой случай:

Исключим DHCP. Оставим ip unnumbered и на клиенте пропишем ИП из 192.168.0.0/24 статически и на циске впишем роут до клиента.

interface GigabitEthernet0/2.25
encapsulation dot1Q 25
ip dhcp relay information option-insert
ip dhcp relay information check-reply
ip dhcp relay information policy-action replace
ip unnumbered Loopback1
ip nat inside
no cdp enable
service-policy type control ISG-WIFI-SESSION
ip subscriber l2-connected
  initiator unclassified mac-address

ip route 192.168.0.13 255.255.255.255 GigabitEthernet0/2.25

В этом случае также все работает.

Router_PPPoE#sh subsc sess | incl IP

624 IP unauthen Local Term 192.168.0.13 00:00:07

- клиент на циске в unauth. Его редиректят на страницу авторизации.

 

Вот как теперь заставить работать два конфига воедине - как показано в самом начале.

Как соединить

ISG + ip unnumbered + ip subscriber l2-connected + DHCP relay

вместе?

Edited by Macro

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this