Jump to content
Калькуляторы

Проблемы с настройкой nat mt2.9.27

Добрый день. Помогите решить такую задачу:

Есть определённая система управления (клиент-сервер), работающая по протоколу udp. Перед клиентом стала задача поставить mt v2.9.27 в роутере. Одна сетевая карта смотрит на сервер(wan), другая на клиента(lan). Необходимо чтобы клиент обращался на сервер с ip адресом wan порта. На клиенте возможно изменение настроек айпи и шлюза.

Для клиена, ip адрес 192.168.0.2, шлюз 192.168.0.1

Сервер ip адрес 10.0.0.2

Делаю следующее:

/ip address add address=10.0.0.1 interface=wan

/ip address add address=192.168.0.1 interface=lan

/ip firewall nat add chain=dstnat dst-address=10.0.0.1 action=dst-nat \

to-addresses=192.168.0.2

/ip firewall nat add chain=srcnat src-address=192.168.0.1 action=src-nat \

to-addresses=10.0.0.1

Со стороны сервера смотрю снифером – обращений нет.

Меняю на клиенте шлюз на 10.0.0.2. Пакеты пошли, но с ip адресом клиента – 192.168.0.2, соответственно сервак не отвечает.

Что делаю не так подскажите пожалуйста

Edited by spyek

Share this post


Link to post
Share on other sites

/ip firewall nat add chain=srcnat src-address=192.168.0.1 action=src-nat \

to-addresses=10.0.0.1

Указан не тот адрес.

 

А вообще - здесь раздел по беспроводке.

Share this post


Link to post
Share on other sites

Да, совершенно верно, раздел по беспроводке, но я считаю что данный пример будет актуален и для построения беспроводных сетей, где используется mt 2.9.27 в качестве роутера.

С выше стоящей задачей я проигрался более 4 дней. После чего точно могу сказать, что в mt 2.9.27 есть довольно много глюков.

Выше указанные мной правила для проброса портов - верны, есть только не большое но, если заходить на wan или lan порт – Вас автоматически пробрасывает на другой айпи, соответственно работать не будет, указав к данным правилам протокол и порт проброса - всё заработало как часы!

Огромное спасибо за поддержку, всё работает ))

 

 

Share this post


Link to post
Share on other sites

2.x ветка давно уже EoL, кому она актуальна? пионэру, который запускает ломаный МТ на компе?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this