Jump to content
Калькуляторы

Настройка маршрутизации VLAN в Catalist WS-C3560G-24TS

В инете полно инструкций как это сделать.

делаю

так

vlan database

vlan 50

 

interface Vlan50

ip address 192.168.50.1 255.255.255.0

no shutdown

 

Switch#show ip interface brief

Interface IP-Address OK? Method Status Protocol

Vlan1 192.168.30.33 YES NVRAM up up

Vlan50 192.168.50.1 YES manual up down

GigabitEthernet0/1 unassigned YES unset up up

GigabitEthernet0/2 unassigned YES unset up up

GigabitEthernet0/3 unassigned YES unset up up

GigabitEthernet0/4 unassigned YES unset up up

GigabitEthernet0/5 unassigned YES unset down down

GigabitEthernet0/6 unassigned YES unset down down

GigabitEthernet0/7 unassigned YES unset down down

. . .

Switch#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

 

Gateway of last resort is 192.168.30.20 to network 0.0.0.0

 

C 192.168.30.0/24 is directly connected, Vlan1

S* 0.0.0.0/0 [1/0] via 192.168.30.20

 

Маршрут на 192.168.50.0/24 в таблице не появился, интерфейс Vlan50 в down

 

мой конфиг

 

--------------

Current configuration : 3424 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Switch

!

!

username admin privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx

no aaa new-model

system mtu routing 1500

vtp mode transparent

ip subnet-zero

ip routing

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 20

name DMZ

!

vlan 50

!

vlan 501

name UPstream1

!

vlan 502

name UPstream2

!

vlan 503

name UPstream3

!

interface GigabitEthernet0/1

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/2

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/3

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/4

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/5

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/6

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/7

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/8

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/9

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/10

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/11

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/12

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 20,501,502

switchport mode trunk

speed 1000

duplex full

!

interface GigabitEthernet0/13

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 20,501,502

switchport mode trunk

speed 1000

duplex full

!

interface GigabitEthernet0/14

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 20,501,502

switchport mode trunk

speed 1000

duplex full

!

interface GigabitEthernet0/15

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/16

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/17

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/18

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/19

switchport mode access

load-interval 30

speed 1000

duplex full

!

interface GigabitEthernet0/20

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/21

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/22

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/23

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/24

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/25

switchport mode access

!

interface GigabitEthernet0/26

switchport mode access

!

interface GigabitEthernet0/27

switchport mode access

!

interface GigabitEthernet0/28

switchport access vlan 54

switchport mode access

!

interface Vlan1

ip address 192.168.30.33 255.255.255.0

!

interface Vlan50

ip address 192.168.50.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.30.20

ip http server

!

duplex full

!

interface GigabitEthernet0/24

switchport mode access

speed 1000

duplex full

!

interface GigabitEthernet0/25

switchport mode access

!

interface GigabitEthernet0/26

switchport mode access

!

interface GigabitEthernet0/27

switchport mode access

!

interface GigabitEthernet0/28

switchport access vlan 54

switchport mode access

!

interface Vlan1

ip address 192.168.30.33 255.255.255.0

!

interface Vlan50

ip address 192.168.50.1 255.255.255.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.30.20

ip http server

!

snmp-server community public RO

snmp-server location SERVER-ROOM

snmp-server contact user@domain

!

control-plane

!

!

line con 0

login local

line vty 0 4

exec-timeout 15 0

logging synchronous

login local

line vty 5 15

login

!

end

 

--------------

 

Vlan ы vlan 501

name UPstream1

!

vlan 502

name UPstream2

!

vlan 503

name UPstream3

настраивали раньше, они сейчас не используются, могут ли эти vlan мешать созданию маршрутизации ?

Share this post


Link to post
Share on other sites

Чтобы int vlan50 был в UP, нужно чтобы он был прописан хотя бы на одном физическом порту, который в UP. У вас большинство аксессных портов в 1 влане, в транках также нет 50 влана.

Share this post


Link to post
Share on other sites

Спасибо John

 

т.е. если в моем случае

int gi 0/5

switchport mode access

switchport access vlan 50

а в 5 порт воткнуть патчкорд -- интерфейс Vlan50 поднимется ?

 

А с транковыми портами аналогично, тоже порт Catalist-а соединить с другим коммутатором с транковым портом ? Или достаточно добавить Vlan50 в транковый порт, даже если он в down ?

 

P.S. сейчас не могу проверить

Share this post


Link to post
Share on other sites
т.е. если в моем случае

int gi 0/5

switchport mode access

switchport access vlan 50

а в 5 порт воткнуть патчкорд -- интерфейс Vlan50 поднимется ?

Да, если на другом конце патчкорда тоже что то будет подключено.
А с транковыми портами аналогично, тоже порт Catalist-а соединить с другим коммутатором с транковым портом ? Или достаточно добавить Vlan50 в транковый порт, даже если он в down ?
Физика также должна быть в UP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this