Jump to content
Калькуляторы

Заворот тестового трафика на Cisco Сisco

Добрый День!

Возникла следующая ситуация: необходимо установить заворот на интерфейсе (например 10.10.10.191) циски 2600, чтобы все входящие пакеты заворачивались обратно отправителю.

Поясню, у меня локальная сетка 10.10.10.0

В ней есть циска 2600 с адресом 10.10.10.191

Есть некая железка 10.10.10.180 которая умеет создавать тестовый UPD трафик.

Так вот, 180 железка создает серию UPD пакетов и посылает на 191 адрес. Как сделать так чтобы эти пакеты дойдя до 191 адреса, заворачивались обратно и приходили на 180 адрес?

Loopback не помогает.

 

WellinkCisco2600#sh run

Building configuration...

 

Current configuration : 1189 bytes

!

! Last configuration change at 12:01:46 UTC Fri Oct 22 2010

! NVRAM config last updated at 11:59:18 UTC Fri Oct 22 2010

!

version 12.2

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WellinkCisco2600

!

enable secret 5 $1$2Gnk$EzmTZTN/WJMZSReDoepB2.

enable password 12345678

!

ip subnet-zero

!

!

ip domain-list bi-telecom

ip name-server 10.10.10.1

ip name-server 10.10.10.3

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.191 255.255.255.0

ip nat outside

ip route-cache flow

loopback

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

ip nat inside source static 192.168.5.2 10.10.10.195

ip flow-export version 5

ip flow-export destination 10.10.10.70 9996

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 192.168.2.0 255.255.255.0 10.10.10.250

ip http server

no ip pim bidir-enable

!

!

tftp-server flash:

!

line con 0

line aux 0

line vty 0 4

password GfHjkm!@

login

line vty 5 15

password GfHjkm!@

login

!

ntp clock-period 17210551

ntp peer 62.117.76.130 source FastEthernet0/0

!

end

 

WellinkCisco2600#

 

Заранее благодарен за помощь!

 

 

 

Share this post


Link to post
Share on other sites

int x/x

ip add 10.10.10.192 255.255.255.0

ip policy route-map PBR

!

route-map PBR

match ip address 101

set ip next-hop 10.10.10.180

!

access-list 101 permit ip 10.10.10.0 0.0.0.255 any <<<<<<<<<<В зависимости од подсети от которой идет трафик

Edited by applx

Share this post


Link to post
Share on other sites

Спасибо за ответ! Не уверен, что все правильно сделал, но что-то не получается...

WellinkCisco2600#sh run

Building configuration...

 

Current configuration : 1343 bytes

!

! Last configuration change at 07:08:02 UTC Mon Oct 25 2010

! NVRAM config last updated at 11:59:18 UTC Fri Oct 22 2010

!

version 12.2

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WellinkCisco2600

!

enable secret 5 $1$2Gnk$EzmTZTN/WJMZSReDoepB2.

enable password 12345678

!

ip subnet-zero

!

!

ip domain-list bi-telecom

ip name-server 10.10.10.1

ip name-server 10.10.10.3

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.191 255.255.255.0

ip nat outside

ip route-cache flow

ip policy route-map PBR

loopback

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

ip nat inside source static 192.168.5.2 10.10.10.195

ip flow-export version 5

ip flow-export destination 10.10.10.70 9996

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 192.168.2.0 255.255.255.0 10.10.10.250

ip http server

no ip pim bidir-enable

!

!

access-list 101 permit ip 10.10.10.0 0.0.0.255 any

route-map PBR permit 10

match ip address 101

set ip next-hop 10.10.10.180

!

tftp-server flash:

!

line con 0

line aux 0

line vty 0 4

password GfHjkm!@

login

line vty 5 15

password GfHjkm!@

login

!

ntp clock-period 17210551

ntp peer 62.117.76.130 source FastEthernet0/0

!

end

 

 

Share this post


Link to post
Share on other sites
access-list 101 permit ip 10.10.10.0 0.0.0.255 any

route-map PBR permit 10

match ip address 101

set ip next-hop 10.10.10.180

Получается, что весь трафик с сетки 10.10.10.0/24 будет завернут на 10.10.10.180

Если хочется завернуть обратно трафик только хоста 10.10.10.180, то наверное надо делать такой ACL:

access-list 101 permit ip host 10.10.10.180 any

Share this post


Link to post
Share on other sites

Не получается, тестер не получает обратно своих пакетов... Кстати, а это нормально что я по 191 адресу могу зайти на циску? По идее пакеты telnet тоже должны на 180 машину отправляться?

Вот текущий конфиг:

WellinkCisco2600#sh run

Building configuration...

 

Current configuration : 1330 bytes

!

! Last configuration change at 06:17:26 UTC Thu Oct 28 2010

! NVRAM config last updated at 06:17:35 UTC Thu Oct 28 2010

!

version 12.2

service config

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname WellinkCisco2600

!

enable secret 5 $1$2Gnk$EzmTZTN/WJMZSReDoepB2.

enable password 12345678

!

ip subnet-zero

!

!

ip domain-list bi-telecom

ip name-server 10.10.10.1

ip name-server 10.10.10.3

!

!

!

!

interface FastEthernet0/0

ip address 10.10.10.191 255.255.255.0

ip nat outside

ip route-cache flow

ip policy route-map PBR

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip route-cache flow

duplex auto

speed auto

!

ip nat inside source static 192.168.5.2 10.10.10.195

ip flow-export version 5

ip flow-export destination 10.10.10.70 9996

ip classless

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

ip route 192.168.2.0 255.255.255.0 10.10.10.250

ip http server

no ip pim bidir-enable

!

!

access-list 101 permit ip host 10.10.10.180 any

route-map PBR permit 10

match ip address 101

set ip next-hop 10.10.10.180

!

tftp-server flash:

!

line con 0

line aux 0

line vty 0 4

password GfHjkm!@

login

line vty 5 15

password GfHjkm!@

login

!

ntp clock-period 17210551

ntp peer 62.117.76.130 source FastEthernet0/0

!

end

 

WellinkCisco2600#

 

Edited by ddyakiv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this