Jump to content
Калькуляторы

потери пакетов на 10G линке

Добрый день!

 

Мучаюсь со следующей проблемой:

 

Cisco 7606 c RSP720 3C и модулем ES20-2TG-3C через XFP подрублена к Edge-Core 4624.

На 4624 заведен влан, на 7606 сабинтерфейс. при пинге - потери 1%. Это магистраль, загружена на 5Гигов где-то.

Менял и модули XFP(Cisco,Opticin) менял 4626, менял ES20. ничего не помагает, разве что RSP не менял.

Длинна оптического пачкорда около 10 метров. Пачкорд тоже меняли.

 

В чем может быть дело?

 

Спасибо!

 

Share this post


Link to post
Share on other sites
Добрый день!

 

Мучаюсь со следующей проблемой:

 

Cisco 7606 c RSP720 3C и модулем ES20-2TG-3C через XFP подрублена к Edge-Core 4624.

На 4624 заведен влан, на 7606 сабинтерфейс. при пинге - потери 1%. Это магистраль, загружена на 5Гигов где-то.

Менял и модули XFP(Cisco,Opticin) менял 4626, менял ES20. ничего не помагает, разве что RSP не менял.

Длинна оптического пачкорда около 10 метров. Пачкорд тоже меняли.

 

В чем может быть дело?

 

Спасибо!

Аттенюаторы есть на 10G?

Share this post


Link to post
Share on other sites

нет, но точно такая же схема работает в других местах без потерь. а в одном конкретном вот такая балалайка.

Edited by bokl

Share this post


Link to post
Share on other sites
нет, но точно такая же схема работает в других местах без потерь. а в одном конкретном вот такая балалайка.

Не страшно XFPшки попалить?

поставьте, децибел на 10

Share this post


Link to post
Share on other sites
bokl

Суммарная нагрузка на ES карту какая?

5 гигов даже нет. один порт на одной карте второй порт на другой карте.

И это фулдуплекс, тоесть входящего 2,5 и исходящего 2,5. где-то так.

На то что шина забивается не похоже.

Share this post


Link to post
Share on other sites
bokl

Суммарная нагрузка на ES карту какая?

5 гигов даже нет. один порт на одной карте второй порт на другой карте.

И это фулдуплекс, тоесть входящего 2,5 и исходящего 2,5. где-то так.

На то что шина забивается не похоже.

Я б не на шину сначала, а на лазер. Поставьте аттенюатор, а потом уж дальше.... По любому затухание нужно для XFP на 10 метрах.

Edited by Konstantin Klimchev

Share this post


Link to post
Share on other sites
bokl

Суммарная нагрузка на ES карту какая?

5 гигов даже нет. один порт на одной карте второй порт на другой карте.

И это фулдуплекс, тоесть входящего 2,5 и исходящего 2,5. где-то так.

На то что шина забивается не похоже.

Я б не на шину сначала, а на лазер. Поставьте аттенюатор, а потом уж дальше.... По любому затухание нужно для XFP на 10 метрах.

я б тоже подумал на лазер, если бы не 4 точно таких же коннекта на тех же 10 метрах без таких проблем((

Share this post


Link to post
Share on other sites

Покажите DDM интерфейсов, так недолго и приемник убить.

Share this post


Link to post
Share on other sites
Покажите DDM интерфейсов, так недолго и приемник убить.

DDM? эмм.. какую команду показать?

Share this post


Link to post
Share on other sites

Не знаю насчет XFP, для XENPAK работет sh interfaces transceiver.

Share this post


Link to post
Share on other sites

 

Optical Optical

Temperature Voltage Current Tx Power Rx Power

Port (Celsius) (Volts) (mA) (dBm) (dBm)

--------- ----------- ------- -------- -------- --------

Te2/0/0 35.1 0.00 34.8 -1.9 -3.2

Te2/0/1 41.0 0.00 26.5 -2.5 -6.9

 

проблемный 2/0/1

Share this post


Link to post
Share on other sites

Накрутите на отвёртку 5 витков патчкорда и пингуйте.

Share this post


Link to post
Share on other sites
Накрутите на отвёртку 5 витков патчкорда и пингуйте.

Что это даст? Затухания увеличит?

Share this post


Link to post
Share on other sites
Накрутите на отвёртку 5 витков патчкорда и пингуйте.

Что это даст? Затухания увеличит?

Да

Share this post


Link to post
Share on other sites

По ddm видно, что у автора, по крайней мере в циске, стоит LR на 1310, который оверлоаду или выжиганию не подвежен.

Ну на крайний случай, пусть проверит, что на другой стороне аналогичная.

Автор, выложите конфиги с обоих сторон, и расскажите как проблемный участок сети устроен, какой трафик бежит, какой qos есть, откуда пингуете, что пингуете, пинговали ли для проверки с обратной стороны, когда появилась проблема, сама появилась или вы что-то делали ну и т.д.

 

 

 

 

Share this post


Link to post
Share on other sites

в предыдущем посте обманул вас. проблемный 2/0/0 =)

 

#show interfaces tenGigabitEthernet 2/0/0

TenGigabitEthernet2/0/0 is up, line protocol is up (connected)

Hardware is TenGigEther SPA, address is 001b.0def.5fc0 (bia 001b.0def.5fc0)

Description: INF:xxx

MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,

reliability 255/255, txload 5/255, rxload 17/255

Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set

Keepalive not supported

Full-duplex, 10Gb/s

Transport mode LAN (10GBASE-R, 10.3125Gb/s)

input flow-control is on, output flow-control is on

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/55242/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 676114000 bits/sec, 84968 packets/sec

5 minute output rate 229900000 bits/sec, 72366 packets/sec

L2 Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes

L3 in Switched: ucast: 0 pkt, 0 bytes - mcast: 0 pkt, 0 bytes mcast

L3 out Switched: ucast: 0 pkt, 0 bytes mcast: 0 pkt, 0 bytes

15685903671 packets input, 15575670417069 bytes, 0 no buffer

Received 841162 broadcasts (0 IP multicasts)

0 runts, 0 giants, 308 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 58551435 multicast, 0 pause input

0 input packets with dribble condition detected

13668941298 packets output, 5266131048653 bytes, 0 underruns

0 output errors, 0 collisions, 2 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out

 

interface TenGigabitEthernet2/0/0

description INF:ххх

ip arp inspection limit none

no ip address

mls qos trust dscp

no cdp enable

service instance 440 ethernet

encapsulation dot1q 440

bridge-domain 440

!

service instance 499 ethernet

description IPTV_TEST_ZONE

encapsulation dot1q 499

rewrite ingress tag translate 1-to-2 dot1q 401 second-dot1q 201 symmetric

bridge-domain 499

!

service instance 800 ethernet

description MCAST:TEST_VoD_SERVER

encapsulation dot1q 778

bridge-domain 800

!

service instance 3101 ethernet

description CUST:MGS02_PPPoE_all_rings

encapsulation dot1q 550 second-dot1q 201-310

rewrite ingress tag pop 1 symmetric

bridge-domain 3000

!

service instance 3102 ethernet

description INF:MGSm5a_AGSW_MANAGEMENT

encapsulation dot1q 551 second-dot1q 100

rewrite ingress tag pop 2 symmetric

bridge-domain 100 split-horizon

!

service instance 3103 ethernet

description INF:MGSm5a_ACSW_MANAGEMENT

encapsulation dot1q 551 second-dot1q 10

rewrite ingress tag pop 2 symmetric

bridge-domain 10 split-horizon

!

service instance 3104 ethernet

description CUST:MGSm5a_PPPoE_all_rings

encapsulation dot1q 551 second-dot1q 201-210

rewrite ingress tag pop 1 symmetric

bridge-domain 3000 split-horizon

!

service instance 4000 ethernet

description INF:TEST-STP

encapsulation dot1q 4001 second-dot1q 4080

rewrite ingress tag pop 2 symmetric

l2protocol forward

bridge-domain 4000

 

interface TenGigabitEthernet2/0/0.3

encapsulation dot1Q 3

ip address 2.2.2.2 255.255.255.252

no cdp enable

!

interface TenGigabitEthernet2/0/0.19

description INF: EoMPLS

encapsulation dot1Q 19

no ip redirects

no ip proxy-arp

xconnect x.x.x.x 19 encapsulation mpls

!

interface TenGigabitEthernet2/0/0.199

encapsulation dot1Q 199

ip address y.y.y.y 255.255.255.192

no ip proxy-arp

ip ospf message-digest-key xxx

ip ospf 1 area 0

mpls ip

no cdp enable

 

 

СВИЧ

 

Ethernet1/25 is up, line protocol is up

Ethernet1/25 is layer 2 port, alias name is ххх, index is 25

Hardware is XFP, address is 00-12-cf-fa-2d-a7

PVID is 1

MTU 1500 bytes, BW 10000000 Kbit

Encapsulation ARPA, Loopback not set

Auto-duplex: Negotiation full-duplex, Auto-speed: Negotiation 10G bits

FlowControl is off, MDI type is auto

5 minute input rate 29018742 bytes/sec, 72250 packets/sec

5 minute output rate 83147024 bytes/sec, 83743 packets/sec

The last 5 second input rate 32237680 bytes/sec, 77429 packets/sec

The last 5 second output rate 87224247 bytes/sec, 87947 packets/sec

Input packets statistics:

305471958343 input packets, 118512650906687 bytes, 0 no buffer

521140262 unicast packets, 6403264 multicast packets, 1736801 broadcast packets

2596847 input errors, 16 CRC, 3 frame alignment, 0 overrun, 0 ignored,

2596703 abort, 0 length error, 0 pause frame

Output packets statistics:

356899721362 output packets, 349066876093861 bytes, 0 underruns

3200859531 unicast packets, 1477220861 multicast packets, 34322698 broadcast packets

125 output errors, 0 collisions, 0 pause frame

Input and output packets by length:

(64) bytes:3103976591, (65~127) bytes: 235033390,

(128~255) bytes: 375417377, (256~511) bytes:2447175037,

(512~1023) bytes: 953305024, (1024~1518) bytes: 964833993

Output packets dropped because of no buffer: 0

Input IPv4 L3 packets:

34769 unicast packets, 0 multicast packets,

0 IP header error packets, 0 discard packets

Output IPv4 L3 packets:

0 unicast packets, 0 multicast packets, 0 aged and dropped packets

Input IPv6 L3 packets:

0 unicast packets, 0 multicast packets,

0 IP header error packets, 0 discard packets

Output IPv6 L3 packets:

0 unicast packets, 0 multicast packets,

0 aged and dropped packets

Input tunnel packets:

0 tunnel packets, 0 tunnel error packets

Output tunnel packets:

0 tunnel packets, 0 tunnel error packets

 

 

Interface Ethernet1/25

name INF:xxx

switchport mode trunk

switchport trunk allowed vlan 3;6;12;19;54;124-125;129;150;199

switchport trunk allowed vlan add 233;235;238;245;261;432;437;440

switchport trunk allowed vlan add 444;451;499;550-551;560;615;617

switchport trunk allowed vlan add 652;655;657;673;676;778

!

interface Vlan3

ip address 2.2.2.1 255.255.255.252

!

 

интерфейсы 2/0/0 и 1/25 соединены пачкордом.

 

на этом линке в 3-ем вилане наблюдаю потери.

в других вланах тоже, но 3-ий я специально делал чтоб сузить круг поисков.

 

Проблема появилась непонятно когда, но когда заметили, то ничего особо не делали на этом железе.

Edited by bokl

Share this post


Link to post
Share on other sites

Не сказали, делали ли пинг в обратном направлении и дайте еще раз вывод интерфейсов, чтоб сравнить счетчики.

"2596847 input errors"

Edited by rus-p

Share this post


Link to post
Share on other sites
Не сказали, делали ли пинг в обратном направлении и дайте еще раз вывод интерфейсов, чтоб сравнить счетчики.

"2596847 input errors"

в обратном тож делали, та же фигня.

счетчики не растут

Share this post


Link to post
Share on other sites

Если эти же модули включить между двумя цисками, проблема сохраняется?

Share this post


Link to post
Share on other sites
Если эти же модули включить между двумя цисками, проблема сохраняется?

говорю же модули меняли на те которые работали без ошибок.

Share this post


Link to post
Share on other sites
flow control?

проверим, щас вижу что на циске включен, а на эджкоре выключен. хотя в других местах тоже самое(

Edited by bokl

Share this post


Link to post
Share on other sites

Намотайте патчкорд.

Edited by Kostja

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this