Jump to content
Калькуляторы

медные GBIC и SFP не хотят жить дружно необъяснимые ошибки на интерфейсах

Доброго времени суток!

 

Есть у меня три каталиста: два -3550 и один 3750. Соединены они друг с другом так:

3550 Gig0/1 <--Cat5e--> Gig1/0/1 3750 Gig1/0/2 <--Cat5e--> Gig0/1 3550

В 3550 стоят медные (приобретенные на наге) GBIC'и, на 3750 - медные (тоже наговские) SFP.

 

Все это работало около полугода. Вчера внезапно начались проблемы: на ОБОИХ портах 3750 каталиста сыпятся ошибки (причем со стороны 3550 - все чисто).

Пробовал менять на 3750 режимы скорости и дуплекса с auto на 1000/full и наоборот, поменял патчкорды. Выдернул/вставил GBIC'и. Перегрузил все каталисты. Чего еще можно сделать - ума не приложу!

 

Вот конфигурация 1-го 3550:

interface GigabitEthernet0/1

switchport access vlan 50

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport mode trunk

load-interval 30

no cdp enable

end

 

Вот конфигурация 2-го 3550:

interface GigabitEthernet0/1

switchport access vlan 50

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport mode trunk

load-interval 30

no cdp enable

end

 

Вот конфигурация 3750:

interface GigabitEthernet1/0/1

switchport access vlan 50

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport mode trunk

load-interval 30

end

interface GigabitEthernet1/0/2

switchport access vlan 50

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport mode trunk

load-interval 30

speed 1000

duplex full

no cdp enable

 

Вот ошибки на 3750:

GigabitEthernet1/0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0013.7ff8.a901 (bia 0013.7ff8.a901)

MTU 1508 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 63/255, rxload 54/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:01:08

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 212435000 bits/sec, 47486 packets/sec

30 second output rate 247705000 bits/sec, 48469 packets/sec

3235296 packets input, 1817238760 bytes, 0 no buffer

Received 3570 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

17115 input errors, 17 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 2814 multicast, 0 pause input

0 input packets with dribble condition detected

3304947 packets output, 2122965141 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

 

GigabitEthernet1/0/2 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0013.7ff8.a902 (bia 0013.7ff8.a902)

MTU 1508 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 53/255, rxload 53/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:05, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:01:43

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 210412000 bits/sec, 43597 packets/sec

30 second output rate 209954000 bits/sec, 44323 packets/sec

4443417 packets input, 2690346083 bytes, 0 no buffer

Received 5144 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

22877 input errors, 25 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 992 multicast, 0 pause input

0 input packets with dribble condition detected

4517203 packets output, 2676554913 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

 

Вот sh int с одного и 3550:

GigabitEthernet0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0015.fadd.0c19 (bia 0015.fadd.0c19)

MTU 1508 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 54/255, rxload 54/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseTX

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

1000BaseT module (WS-G5483) in GBIC slot.

Last input 00:00:00, output 00:00:03, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 212876000 bits/sec, 44630 packets/sec

30 second output rate 214661000 bits/sec, 44048 packets/sec

122954696 packets input, 3981321537 bytes, 0 no buffer

Received 317238 broadcasts (0 multicasts)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 268671 multicast, 0 pause input

0 input packets with dribble condition detected

121921798 packets output, 1077974488 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

 

Вот sh int gigabitEthernet 1/0/1 transceiver properties с 3750:

Name : Gi1/0/1

Administrative Speed: auto

Administrative Duplex: auto

Administrative Auto-MDIX: on

Administrative Power Inline: N/A

Operational Speed: 1000

Operational Duplex: full

Operational Auto-MDIX: on

Вот sh int gigabitEthernet 1/0/2 transceiver properties с 3750:

Name : Gi1/0/2

Administrative Speed: 1000

Administrative Duplex: full

Administrative Auto-MDIX: on

Administrative Power Inline: N/A

Operational Speed: 1000

Operational Duplex: full

Operational Auto-MDIX: off

 

А вот еще sh int gigabitEthernet 1/0/2 controller с 3750:

GigabitEthernet1/0/2 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0013.7ff8.a902 (bia 0013.7ff8.a902)

MTU 1508 bytes, BW 1000000 Kbit, DLY 10 usec,

reliability 255/255, txload 51/255, rxload 52/255

Encapsulation ARPA, loopback not set

Keepalive not set

Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:04, output 00:00:00, output hang never

Last clearing of "show interface" counters 00:04:38

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

30 second input rate 205192000 bits/sec, 42399 packets/sec

30 second output rate 203113000 bits/sec, 43396 packets/sec

11969347 packets input, 2974142521 bytes, 0 no buffer

Received 15288 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

61637 input errors, 77 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 3778 multicast, 0 pause input

0 input packets with dribble condition detected

12202874 packets output, 2911160978 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

 

Transmit GigabitEthernet1/0/2 Receive

2482047611 Bytes 3564170448 Bytes

127401562 Unicast frames 125744516 Unicast frames

276867 Multicast frames 45537 Multicast frames

50121 Broadcast frames 149574 Broadcast frames

0 Too old frames 2687254812 Unicast bytes

0 Deferred frames 5614483 Multicast bytes

0 MTU exceeded frames 11953593 Broadcast bytes

0 1 collision frames 0 Alignment errors

0 2 collision frames 702 FCS errors

0 3 collision frames 0 Oversize frames

0 4 collision frames 0 Undersize frames

0 5 collision frames 363 Collision fragments

0 6 collision frames

0 7 collision frames 21741584 Minimum size frames

0 8 collision frames 39344470 65 to 127 byte frames

0 9 collision frames 9568146 128 to 255 byte frames

0 10 collision frames 5418103 256 to 511 byte frames

0 11 collision frames 7683184 512 to 1023 byte frames

0 12 collision frames 42646394 1024 to 1518 byte frames

0 13 collision frames 0 Overrun frames

0 14 collision frames 0 Pause frames

0 15 collision frames

0 Excessive collisions 505294 Symbol error frames

0 Late collisions 6246 Invalid frames, too large

0 VLAN discard frames 1 Valid frames, too large

0 Excess defer frames 37858 Invalid frames, too small

31495931 64 byte frames 0 Valid frames, too small

31946275 127 byte frames

9425385 255 byte frames 0 Too old frames

5655180 511 byte frames 0 Valid oversize frames

7143832 1023 byte frames 0 System FCS error frames

42061947 1518 byte frames 0 RxPortFifoFull drop frame

0 Too large frames

0 Good (1 coll) frames

0 Good (>1 coll) frames

 

 

Из за этих ошибок (в самом центре сети) качество сервиса очень сильно упало.... Помогите, плз, если кто знает что делать.

 

Кстати, на том же 3750 есть еще один (такой же точно как и первые два) SFP, к которому подключен роутер 3825 и там все хорошо... Так что каталист, в принципе рабочий... Да и на 3550 есть еще оптический GBIC, на котором тоже нет ошибок.

Edited by survivor

Share this post


Link to post
Share on other sites

полгода конечно не срок, хотя сильно зависит от влажности.. попробуйте контакты спиртиком протереть

Share this post


Link to post
Share on other sites
полгода конечно не срок, хотя сильно зависит от влажности.. попробуйте контакты спиртиком протереть

может лучше внутрь? на проблему это примерно одинаково повлияет...

 

наверное я чего-то упустил, но, честно говоря, первый раз слышу, чтоб медный езернет спиртом протирали :-) но, тем не менее - спасибо за участие.

 

Share this post


Link to post
Share on other sites
может лучше внутрь? на проблему это примерно одинаково повлияет...

 

наверное я чего-то упустил, но, честно говоря, первый раз слышу, чтоб медный езернет спиртом протирали :-) но, тем не менее - спасибо за участие.

были случаи при повышенной влажности очень шустро rj45 окислялся. сначала так же crc/input error'ы нарастали, потом на дуплексах дурить начинало, а апосля и вовсе линк пропадал.

Share this post


Link to post
Share on other sites
может лучше внутрь? на проблему это примерно одинаково повлияет...

 

наверное я чего-то упустил, но, честно говоря, первый раз слышу, чтоб медный езернет спиртом протирали :-) но, тем не менее - спасибо за участие.

были случаи при повышенной влажности очень шустро rj45 окислялся. сначала так же crc/input error'ы нарастали, потом на дуплексах дурить начинало, а апосля и вовсе линк пропадал.

Офигеть. Очень похоже на мою проблему. Правда свичи не в трюме :-) а на атс в шкафу стоят, но - все может быть. Сегодня буду менять гбики и сфп, отпишусь о результатах.

Share this post


Link to post
Share on other sites

Проблема решилась перестановкой SFP на 3750 с 1 и 2-го портов в 7-й и 8-й. Причем сами SFP я не менял.

Толи где-то внутри каталиста перегрелись контактные порты, то ли действительно их там ржавчина поела :-) А может как-то с этим связано:

 

Bill, I also found the following in the release notes for v12.2(40):

 

 

When a Catalyst 3750-12S switch boots up, ports 1, 2, 5, 6, 9, and 10 can become active before the Cisco IOS software loading process is complete. Packets arriving at these ports before the switch software is completely loaded are lost. This is a hardware limitation when the switch uses small form-factor pluggable (SFP) modules with copper connections.

 

The workaround is to use switch ports other than those specified for redundancy and for applications that immediately detect active links. (CSCeh70503)

 

 

The link:

 

http://www.cisco.com/en/US/products/hw/swi...008089a797.html

Не знаю точно. Но знаю теперь, что проблема - не в кабелях и разъемах, не в GBIC'ах и не в 3550 каталистах. И не в самих SFP тоже. И не в неправильной логике MDI/MDIX или auto speed/duplex...

 

Да, кстати, проблема легко воспроизводится - если SFP вернуть обратно на 1 и 2-й порты - ошибки снова появляются.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this