Jump to content
Калькуляторы

HP GbE2c не видит все vlan'ы

Добрый день.

Второй день пытаюсь решить проблему, но до сих пор даже зацепки нету.

Подскажите пожалуйста может кто сталкивался.

 

Есть c6500 к которой через LACP trunk подключена blade корзина на которой установлен коммутатор HP GbE2c.

Проблема в том что из трех vlan которые я посылаю транком c6500 видит маки только в двух.

То есть на стороне HP я вижу маки в fdb во всех vlan, но на c6500 вижу только в двух.

 

с6500#sh mac-addr int po40 vlan 12

Legend: * - primary entry

age - seconds since last seen

n/a - not available

 

vlan mac address type learn age ports

------+----------------+--------+-----+----------+--------------------------

No entries present.

 

 

 

HP

 

>> FDB Manipulation# vlan

Enter VLAN number: (1-4095) 12

------------------------------------------------------------------

MAC address VLAN Port Trnk State Permanent

----------------- ---- ---- ---- -----

00:00:0c:xx:xx:xx 12 13 TRK

00:00:0c:xx:xx:xx 12 13 TRK

00:00:0c:xx:xx:xx 12 13 TRK

00:04:23:xx:xx:xx 12 13 TRK

00:04:23:xx:xx:xx 12 13 TRK

00:13:80:xx:xx:xx 12 13 TRK

00:13:80:xx:xx:xx 12 13 TRK

00:13:80:xx:xx:xx 12 13 TRK

00:18:18:xx:xx:xx 12 13 TRK

00:19:bb:xx:xx:xx 12 13 TRK

00:1b:78:xx:xx:xx 12 13 TRK

00:1b:78:xx:xx:xx 12 13 TRK

00:1c:c4:xx:xx:xx 12 13 TRK

 

 

После обновления прошивки на HP проблема не решилась.

Заранее спасибо за любую помощь/мысли.

 

еще хочу добавить что между собой сервера в blade'e в проблемном vlan могут общаться, а за пределы блейда соответственно нет.

Share this post


Link to post
Share on other sites

Покажите весь конфиг. У меня почти такая же схема, на порт-ченеле много вланов, проблем нет

Share this post


Link to post
Share on other sites

Дело в том что у нас тоже стоят несколько таких корзин и с ними все нормально, но вот два дня назад столкнулся с такой проблемой и не могу найти в чем разница. Конфиги вроде похожий...

 

HP:

 

/c/sys
        dhcp dis
        bannr "enclosure xx"
/c/sys/ssnmp
        rcomm "xxx"
/c/port  1
        pvid 120
        tagpvid dis
/c/port  2
        pvid 120
        tagpvid dis
/c/port  3
        pvid 120
/c/port  4
        pvid 120
/c/port  5
        pvid 120
/c/port  6
        pvid 120
/c/port  7
        pvid 120
/c/port  8
        pvid 120
/c/port  9
        pvid 120
/c/port 10
        pvid 12
/c/port 11
        pvid 12
/c/port 12
        pvid 12
/c/port 13
        pvid 120
/c/port 14
        pvid 120
/c/port 15
        pvid 120
/c/port 16
        pvid 120
/c/port 21
        tag ena
        pvid 12                           
        tagpvid dis
/c/port 22
        tag ena
        pvid 12
        tagpvid dis
/c/port 23
        tag ena
        pvid 12
        tagpvid dis
/c/port 24
        tag ena
        pvid 12
        tagpvid dis
/c/l2/vlan 1
        def 17 18 20
/c/l2/vlan 12
        ena
        name "VLAN 12"
        def 10 11 12 21 22 23 24
/c/l2/vlan 120
        ena
        name "WEBc40 PUB"
        def  1  2  3  4  5  6  7  8  9 13 14 15 16 21 22 23 24
/c/l2/vlan 500                            
        ena
        name "VLAN 500"
        def 21 22 23 24
/c/l2/stp 1/off
/c/l2/stp 1/clear
/c/l2/stp 1/add 1 12 120 500
/c/l2/trunk 1
        dis
        rem 17
        rem 18
/c/l2/lacp/port 21
        mode passive
        adminkey 100
/c/l2/lacp/port 22
        mode passive
        adminkey 100
/c/l2/lacp/port 23
        mode passive
        adminkey 100
/c/l2/lacp/port 24
        mode passive
        adminkey 100
/c/l3/if 254                              
        ena
        addr 10.10.40.51
        mask 255.255.0.0
        broad 10.10.255.255
        vlan 500
/c/l3/gw 1
        ena
        addr 10.10.0.4

 

 

Cisco:

 

interface Port-channel40
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12,40,120
switchport mode trunk

interface GigabitEthernet3/35
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12,120,500
switchport mode trunk
channel-protocol lacp
channel-group 40 mode active

Edited by CNick

Share this post


Link to post
Share on other sites

Ну всё понятно с Вами, 12 влан на HP у вас нетегированной, а на циске, он тегированный

 

К сожаленью, я так и не осилил этот язык для телефонистов(могу только читать конфиг), но проблему через веб можно решить так:

 

 

Switch Ports Configuration

 

21 enabled enabled 1 enabled disabled disabled disabled 0

22 enabled enabled 1 enabled disabled disabled disabled 0

 

(у меня транк 2Г)

 

т.е. суть в том, что default pvid на портах 21-24 должен быть не 12, а 1 !

 

Потом заходите в vlan 12, добавляете в него физические порты, из которых собран порт-ченел (если порты в него будут не добавлены)

Edited by s.lobanov

Share this post


Link to post
Share on other sites

Ужас, как я мог так протупить. Дело в том что на остальных есть vlan 1 на стороне HP и нету на циске. Тоесть HP 1 использует как нативный :)

Спасибо Вам большое!

Share this post


Link to post
Share on other sites

Более точно, на HP один влан должен быть нативным(без тега), вообще говоря не обязательно у первый, у Вас получился 12ый

 

А вообще хорошо, что тут есть люди, у кого есть эти свитчи, будет у кого спросить, если у самого вопросы возникнут.

Share this post


Link to post
Share on other sites
Более точно, на HP один влан должен быть нативным(без тега), вообще говоря не обязательно у первый, у Вас получился 12ый
Это и было моей проблемой :) Спасибо!

 

 

 

А вообще хорошо, что тут есть люди, у кого есть эти свитчи, будет у кого спросить, если у самого вопросы возникнут.
Да конечно, постараемся помочь чем сможем :) Насколько я помню тут уже подымали один вопрос по поводу автоматических backup'ов для этих свичей.

 

P.S. по субъективной оценке cisco cbs3020 намного лучше HP, мы сейчас стараемся новые блейды покупать только с cisco.

 

Share this post


Link to post
Share on other sites

У меня похожий вопрос. На этапе покупки и во время внедрения C3000 с двумя Gbe2c как то (чисто по интуиции) настроил их под текущие задачи (vlan-1 дефолтная сеть предприятия, vlan-2 iscsi трафик) сейчас на блейдах крутятся много производственных задач и эксперименты не желательны...

 

20 порт SW1 (PVID-1) физически соединен с локальной сетью предприятия (SW-LAN) (несколько 3com управляемых коммутаторов)

От провайдера интернет шнурок подключен в один из свичей, и тегированный VLAN33 идет по свичам и попадает в один из Башенных хостов VMWARE

Но хосты живущие в шасси C3000 не смотря на аналогичные вмварские настройки не видят этот vlan-33

Думаю что причина в настройках Gbe2c ( SW1 и SW2) они не пропускают трафик VLAN-33)

 

Продвинутых спецов по настройках коммутаторов у нас нет, кто может помочь по BLade свичей?

Share this post


Link to post
Share on other sites

вот уже год как я не настраивал эти свитчи, но в принципе всё помню, можете связаться со мной через ЛС

Share this post


Link to post
Share on other sites

Если создать на разных блейдах (все хосты идентичные, VMWARE ESXi5.5) VLAN с тегом (например 22), то через блейдовые свичи трафик не проходит.

1 и 2 сервера смотрят соответственно 1 и 2 порты Gbe2C, оба порта PVID-1 (без каких либо настроек), а 20 порт (тоже PVID-1) подключен в сеть предприятия.

 

Как разрешить между некоторыми портами BLswitch проходит тегированному трафику?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this