Jump to content
Калькуляторы

Cat 4948 помогите срочно проблеммы с arp

После сменыы коммутатора ядра с 3560 на 4948 стали на время отваливатся клиенты, в логах ничего нет, самое интересное что отваливаются только клиенты у которых белые ip, те клиенты которых натим и они соответственно находятся на другом маршрутизаторе все ок. И еще когда отчищаю arp на маршрутизаторе на которм белые ip то все начинает работать. Не знаю что и делать. Если нужны конфиги то выложу. О железках: 7206vxr и 4950 за ними 3560.

Share this post


Link to post
Share on other sites

ip unnumbered используется?

в 49xx есть arp pool, rtfm

ip arp poll queue (Default for the queue size is 1000)

ip arp poll rate (Default number of arp requests is 1000 packet per second)

 

 

Share this post


Link to post
Share on other sites
ip unnumbered используется?

в 49xx есть arp pool, rtfm

ip arp poll queue (Default for the queue size is 1000)

ip arp poll rate (Default number of arp requests is 1000 packet per second)

у меня 49xx используется тупо как l2 свич мне от него пока больше ничего не надо, вытыщили 3560 вставили 4948 и все приехали без отчистки arp неработает ничего.

 

 

40, 41 порт идет на 72-ю циску, из наблюдений все клиенты с белыми адресами за 26-м портом глючат. Пока поставил на клиентских интерфейсах на 72ой arp timeout 60 вроде помогает но не всегда.

 

 

 

конфиг 4948:

 

#sh run

Building configuration...

 

Current configuration : 7867 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

service compress-config

!

hostname

!

boot-start-marker

boot-end-marker

!

enable secret 5

!

username xxx privilege 15 secret

 

 

aaa new-model

!

!

aaa authentication login default local group tacacs+

aaa authorization exec default local group tacacs+

!

!

!

aaa session-id common

ip subnet-zero

!

!

ip vrf mgmtVrf

!

vtp mode transparent

!

power redundancy-mode redundant

!

!

!

!

!

archive

log config

logging enable

notify syslog contenttype plaintext

hidekeys

!

spanning-tree mode pvst

spanning-tree logging

spanning-tree extend system-id

no spanning-tree vlan 2-97,104-2000

!

vlan internal allocation policy ascending

!

vlan 2-1001,1006-2000

!

!

!

interface FastEthernet1

ip vrf forwarding mgmtVrf

no ip address

speed auto

duplex auto

!

interface GigabitEthernet1/1

description ----- All UpLink vlan 221 712

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 219,221,222,302,712,715,744,763,778

load-interval 30

speed 100

duplex full

qos trust dscp

no cdp enable

!

interface GigabitEthernet1/2

description ---

switchport access vlan 773

switchport mode access

speed 100

duplex full

qos trust dscp

no cdp enable

!

interface GigabitEthernet1/3

switchport trunk encapsulation dot1q

switchport mode trunk

no cdp enable

!

interface GigabitEthernet1/4

!

interface GigabitEthernet1/5

!

interface GigabitEthernet1/6

!

interface GigabitEthernet1/7

!

interface GigabitEthernet1/8

!

interface GigabitEthernet1/9

 

interface GigabitEthernet1/10

description -- monitor --

!

interface GigabitEthernet1/11

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/12

description -- --

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 98-103

switchport mode trunk

!

interface GigabitEthernet1/13

description -- col_mgm---

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/14

shutdown

!

interface GigabitEthernet1/15

switchport access vlan 383

switchport mode access

!

interface GigabitEthernet1/16

!

interface GigabitEthernet1/17

switchport trunk encapsulation dot1q

switchport mode trunk

no cdp enable

!

interface GigabitEthernet1/18

description --- ---

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,103

switchport mode trunk

qos trust dscp

!

interface GigabitEthernet1/19

description

switchport access vlan 103

switchport mode access

!

interface GigabitEthernet1/20

description ---

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100,103

switchport mode trunk

qos trust dscp

!

interface GigabitEthernet1/21

description

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/22

description -

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/23

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/24

description -

switchport access vlan 103

switchport mode access

speed 100

duplex full

qos trust dscp

 

 

interface GigabitEthernet1/25

description --

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 11,56,80,98-100,103,109,111,112,114-116,119,121

switchport trunk allowed vlan add 124,126-130,132,134,142-144,150,151,156,157

switchport trunk allowed vlan add 159,169,172-174,176,178,180-184,186,187,190

switchport trunk allowed vlan add 196,198,201,202,205,207,210,215,222-224,229

switchport trunk allowed vlan add 235,236,245,246,248,258,259,261,263,264,266

switchport trunk allowed vlan add 275,281,285,293,296,297,304,307,308,311-313

switchport trunk allowed vlan add 315,319-321,328-332,338,339,342,344,348-351

switchport trunk allowed vlan add 353,355,363-366,372,378,384,390,400,401,409

switchport trunk allowed vlan add 410,422,425,428,429,431,434,441,442,444,447

switchport trunk allowed vlan add 448,452,454,462,470,474,476,477,479,481,492

switchport trunk allowed vlan add 497,498,500-502,513,516,522,541,544,549,552

switchport trunk allowed vlan add 555,556,569,574-576,578,582,585,590,593,595

switchport trunk allowed vlan add 599-601,605,607,609,612,613,618,619,624,625

switchport trunk allowed vlan add 629,631-633,637,639,645,646,650,661,663

switchport trunk allowed vlan add 666-671,675,676,685,686,692,693,699,704,708

switchport trunk allowed vlan add 712,714,715,720,722,726,743,756,759,768,773

switchport trunk allowed vlan add 805,810,812,850-853,857-859,862,875,881,883

switchport trunk allowed vlan add 884,886,901,902,907,909,912,918,929,940,942

switchport trunk allowed vlan add 944,946,950,951,953,956,961,971,983,985

switchport trunk allowed vlan add 988-992,994,996,1001

switchport mode trunk

!

interface GigabitEthernet1/26

description - -

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet1/27

description ---

shutdown

!

interface GigabitEthernet1/28

description --

shutdown

!

interface GigabitEthernet1/29

description -

switchport access vlan 200

switchport mode access

speed 10

!

interface GigabitEthernet1/30

description --

switchport access vlan 99

switchport mode access

!

interface GigabitEthernet1/31

!

interface GigabitEthernet1/32

!

interface GigabitEthernet1/33

description

switchport access vlan 103

switchport mode access

speed 100

duplex full

!

interface GigabitEthernet1/34

description

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/35

description

switchport access vlan 100

switchport mode access

 

 

interface GigabitEthernet1/35

description

switchport access vlan 100

switchport mode access

!

interface GigabitEthernet1/36

shutdown

!

interface GigabitEthernet1/37

!

interface GigabitEthernet1/38

!

interface GigabitEthernet1/39

!

interface GigabitEthernet1/40

description --- -

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-49,51-4094

switchport mode trunk

!

interface GigabitEthernet1/41

description --- t1 ---

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2,3,221,222,712,777,899

switchport mode trunk

!

interface GigabitEthernet1/42

description --- /1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3,777

switchport mode trunk

!

interface GigabitEthernet1/43

description ---

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-49,51-4094

switchport mode trunk

!

interface GigabitEthernet1/44

description r3

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/45

!

interface GigabitEthernet1/46

!

interface GigabitEthernet1/47

!

interface GigabitEthernet1/48

!

interface Vlan1

no ip address

!

interface Vlan100

description --- Management ---

ip address 10.xx.0.xx 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 10.xx.0.xx

ip http server

!

!

!

snmp-server community

tacacs-server host 192.168.xx.xx

tacacs-server directed-request

tacacs-server key

!

control-plane

!

!

line con 0

stopbits 1

line vty 0 4

privilege level 15

password

transport input telnet

!

!

monitor session 1 source vlan 1 - 2000

monitor session 1 filter packet-type good rx

monitor session 1 destination interface Gi1/10

end

 

 

Share this post


Link to post
Share on other sites

Если она у вас только свитчит и не роутит вообще и айпишник на ней только для менеджмента, то очистка арпов точно не должна влиять. Может быть вы маки все-таки чистите? И покажите уже в момент проблемы sh ip arp summ и sh mac addr count

Share this post


Link to post
Share on other sites

это на свиче :

sh ip arp summ

3 IP ARP entries, with 0 of them incomplete

 

sh mac addr count

MAC Entries for all vlans:

Dynamic Unicast Address Count: 1093

Static Unicast Address (User-defined) Count: 0

Static Unicast Address (System-defined) Count: 1

Total Unicast MAC Addresses In Use: 1094

Total Unicast MAC Addresses Available: 32768

Multicast MAC Address Count: 2009

Total Multicast MAC Addresses Available: 32768

 

на маршрутизаторе естественно таких команд нет.

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Я чесно вобще не понимаю причем сдесь ARP почему начинает работать коммутатор когда я отчищаю ARP на маршрутизаторе, из-за бродкаста что ли, и еще позже я выяснил такой глюк наблюдается на вех маршрутизаторах а не только 72xx так же на брасе и на натовой молотилке тоже, трафик вобще мизерный а загрузка у 4948 29 процентов это разве нормально ? из них span-tree занимает 11 процентов это притом что он включен в 100 vlan всего.

Share this post


Link to post
Share on other sites

Кольца не может быть нигде? Попробуйте на вланы включить stp типа spanning-tree mode rapid-pvst.

 

И какая версия ios ?

 

Только решил написать про stp и вы про него сами написали :). Эта 4948 связана какими нибудь вланами с какимми нибудь l2 свитчами в сети? Возможно завёлся какой то глючный(а может даже и с выгоревшим портом). Не раз такое замечал на 4948 когда какой то л2 свитч в сети(который вланом до неё дотягивается) начинает глючить, то и у 4948 начинаются глюки с коммутацией маков.

Share this post


Link to post
Share on other sites
Кольца не может быть нигде? Попробуйте на вланы включить stp типа spanning-tree mode rapid-pvst.

 

И какая версия ios ?

 

Только решил написать про stp и вы про него сами написали :). Эта 4948 связана какими нибудь вланами с какимми нибудь l2 свитчами в сети? Возможно завёлся какой то глючный(а может даже и с выгоревшим портом). Не раз такое замечал на 4948 когда какой то л2 свитч в сети(который вланом до неё дотягивается) начинает глючить, то и у 4948 начинаются глюки с коммутацией маков.

ios cat4500-ipbase-mz.122-53.SG1.bin

 

 

конечно связанна с l2 свичами с 3560 двумя и длинком еще одним тупым.

 

может таада поставить на некоторых портах bpdufilter и bpduguard я просто в span-tree не знаток, но походу и правдо в нем дело, может кто подскажет из знатоков как вычислить это все ?

 

Share this post


Link to post
Share on other sites

Постройте графики загрузки по интерфейсам(mrtg, cacti, прочее) и будет понятно где петля(если она есть) или откуда приходит флуд.

Share this post


Link to post
Share on other sites

*Sep 19 01:31:25.306: %PARSER-5-CFGLOG_LOGGEDCMD: User: logged command:no spanning-tree mode pvst

*Sep 19 01:32:20.130: %PARSER-5-CFGLOG_LOGGEDCMD: User: logged command:spanning-tree mode rapid-pvst

*Sep 19 01:32:22.514: %SPANTREE-5-ROOTCHANGE: Root Changed for vlan 100: New Root Port is GigabitEthernet1/25. New Root Mac Address is 001e.4a0b.5000

*Sep 19 01:32:22.854: %SPANTREE-5-TOPOTRAP: Topology Change Trap for vlan 99

*Sep 19 01:32:51.142: %SPANTREE-5-TOPOTRAP: Topology Change Trap for vlan 1

*Sep 19 01:33:00.758: %SYS-5-CONFIG_I: Configured from console by yegor on vty0 (

 

 

походу точно петля, где то, но как найти ? вроде порты не блокируются если петля ведь должен порт заблокироватся по span-tree так ?

 

Gi1/25 Root FWD 19 128.25 P2p Peer(STP)

Gi1/26 Desg FWD 19 128.26 P2p Peer(STP)

 

 

показывает пиров походу по stp за этими портами две разные 3560

Share this post


Link to post
Share on other sites

завел на кактусе свич этот и порты все его которые в апе

Share this post


Link to post
Share on other sites

Выключил везде stp и помогло вроде пока все работает, но у меня ходит телефония в 103 влан и пакеты частично теряются походу. При этом загрузка CPU 4948 27 процентов это просто дофига трафик через нее идет мизерный.

 

 

sh processes cpu sorted 1

CPU utilization for five seconds: 26%/0%; one minute: 29%; five minutes: 29%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

104 15785696 4167711 3787 11.00% 10.48% 10.46% 0 Spanning Tree

52 11686204 4685053 2494 7.83% 9.79% 9.60% 0 Cat4k Mgmt LoPri

51 6637524 16492665 402 6.65% 7.04% 7.07% 0 Cat4k Mgmt HiPri

91 441772 188541 2343 0.00% 0.34% 0.33% 0 CDP Protocol

36 611580 158411 3860 0.31% 0.30% 0.31% 0 IDB Work

7 678828 45768 14831 0.00% 0.28% 0.38% 0 Check heaps

182 60 52 1153 0.31% 0.07% 0.01% 1 Virtual Exec

40 139636 4683 29817 0.00% 0.05% 0.05% 0 Per-minute Jobs

98 36020 95422 377 0.07% 0.05% 0.03% 0 IP Input

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this