Jump to content
Калькуляторы

Acorp с wive-ng не прошивается ни на что другое

Вопсчем проблема такая, есть Acorp WR-G. У провайдера русский PPTP. Родная прошивка не держит его. Решил перепрошить на Zyxel P-330W ee. Всё сделал по инструкции (через tftp). Но пишет, что "тайм аут истек, соединение запрещено". Ну вроде так. Тогда решил прошить на Wive-ng. Та же история. Не хочет прошиваться и всё. Тайм аут и всё тут. Потом через веб-интерфейс с отчаяния запустил обновление на wive-ng (это я потом прочитал, что так крайне не рекомендуется делать). Но тем не менее процесс заливки прошёл на Success! И стал у меня wive-ng. Но там всё сложно. Хочу прошивку от ZyXEL. Но мне все также выдаёт ошибку, что тайм аут истёк и всё такое. Может как-то по другому можно прошить, без JTAGa? Ну или помогите настроить wive-ng. У провайдера динамический PPTP.

 

З.Ы.: поиском пользовался, 3 дня жил в мире гугла и яндекса. Уже бородой покрылся. Спасайте!

Edited by ritchie

Share this post


Link to post
Share on other sites

Да, и если это важно - когда удерживая ресет включаю питание лампочка "power" не гаснет, гаснет лампочка "wlan".

Share this post


Link to post
Share on other sites

А чего там сложного? Прописываешь WAN, потом идёшь в VPN и там настраиваешь pptp

Share this post


Link to post
Share on other sites

Ок, щас заново настрою и выложу что получилось. версия 0.3.18.

Share this post


Link to post
Share on other sites

Меню Boot выглядит так:

 

IPV4_FORWARD_ENABLE=yes

 

MASQUERADE=yes

 

CLIENTSNET=

 

LOOSEUDP=yes

 

START_IPTABLES=yes

 

FASTPATH=yes

 

START_SHAPER=yes

 

START_DHCPSERVER=no

 

START_DNSSERVER=no

START_WINSSERVER=no

 

START_PPPOE_RELAY=no

SERVER_IF=wlan0

CLIENT_IF=eth0

 

START_UDPXY=no

START_IGMPPROXY=no

MCASTNET=224.0.0.0/4

MCASTDEV=br0

 

SYSLOG_ENABLE=yes

 

LLDT_ENABLE=yes

 

ICMP_DISABLE=no

PROXY_ARP=no

 

TIME_SYNC_ON_START=no

PERIODIC_TIME_SYNC=no

NTP_SERVER=10.7.0.254

 

PINGER=no

PINGER_HOST=10.0.0.233

 

WIFI_DOG=no

WIFI_DOGHOST=10.0.0.233

 

ZOMBIE_DOG=yes

HARD_DOG=yes

OPTIMIZE_TCP_MEM=yes

CONNTRACK_OPT=yes

KEEPALIVE_OPT=yes

ARP_FAST_CLEAN=yes

SPOOF_PROTECT=yes

STEALTH=yes

REMOVE_UNUSED=no

 

MOUNT_CIFS=no

CIFS_SERVER=10.0.0.254

SHARE_NAME=incoming

CIFS_USER=guest

CIFS_PASSWD=

 

MMC_FLASH=no

MMC_MOUNT_POINT=/mnt/mmc

 

Меню Interfaces выглядит так:

 

VLAN_START=yes

 

DHCPOPTS="-S -t 3 -b -R"

 

BUGGY_NAS=no

 

PPP_DEBUG=no

 

PPP_SLEEP=10

 

PPTP_CALL_START=yes

PPTP_SERVER=unlim.is74.ru

PPTP_MPPE=no #yes - always, no - refuse, auto - allow mppe

PPTP_MTU=1460

PPTP_MRU=

PPTP_USER=МойЛогин

PPTP_PASSWORD=МойПароль

PPTP_DEFROUTE=no #(yes|no|replace)

PPTP_PEERDNS=yes

PPTP_AUTO_REDIAL=yes

 

BRIDGE_START=yes

BR0_USE_DHCP=no

BR0_IPADDR=192.168.1.254/24 #ipv4 adress is 192.168.1.254 netmask 255.255.255.0

STP_ENABLE=no

FD_TIMER=0

GCINT_TIMER=0

 

PORT_FILT=eth0

MCAST_BND_ETH0=80000

MCAST_BND_ETH1=80000

MCAST_BND_WLAN=40000

MACCLONE_IF="" #"eth0 wlan0" to clone MAC from eth0 to wlan0

 

WDS_IN_BR0=yes

 

ETH0_ENABLED=yes

ETH0_FORCEIP=no

ETH0_IN_BR0=yes

ETH0_USE_DHCP=no

ETH0_IPADDR=192.168.1.254

 

ETH1_ENABLED=yes

ETH1_FORCEIP=no

ETH1_IN_BR0=no

ETH1_USE_DHCP=no

ETH1_IPADDR=

 

WLAN_ENABLED=yes

WLAN_FORCEIP=no

WLAN_IN_BR0=yes

WLAN_USE_DHCP=no

WLAN_IPADDR=192.168.1.1

 

ETH0_MACADDR=00028a8b0800

ETH1_MACADDR=00028a8b0801

WLAN_MACADDR=00028a8b0802

Edited by ritchie

Share this post


Link to post
Share on other sites

Меню iptables выглядит так:

 

 

iptables -P INPUT ACCEPT

iptables -P OUTPUT ACCEPT

 

iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

 

 

Меню Routing выглядит так:

 

ip ro add default via 192.168.0.1

Share this post


Link to post
Share on other sites

МЕНЮ?! 8-Q

 

У меня оно совсем по-другому выглядит:

[bull@/]# menu
-sh: menu: not found
[bull@/]# uname -a
Linux bull 2.6.21.7 #1 Thu Aug 19 05:30:22 OMSST 2010 mips GNU/Linux
[bull@/]# ls
bin      etc      lib      mnt      sbin     tmp      web
dev      etc_ro   linuxrc  proc     share    usr      xml
dev.gz   home     media    rwfs.gz  sys      var
[bull@/]#

Share this post


Link to post
Share on other sites

Там наверное и веб есть.

Видел я один девайс с вебом. флайроутер. там с веба через цги шелл запускался :)

 

Share this post


Link to post
Share on other sites

веб есть, да, но тоже другой

Share this post


Link to post
Share on other sites

::Wive-NG-0.3.18::RTL8186-REALTIME::

Base station firmware version

Enter 'menu' for config router

Sat, 01 May 2010 18:23:48 +0700

Please report of any bug to sfstudio@mail.ru

 

-=General menu=-

 

1) Boot 2)Interfaces 3)General 4)WPA 5)Stat 6)Scan 7)RSSI 8)ExtendedMenu

9) Change password 10) WiFi reset 11)Save 12)Reboot 13)Quit

 

Enter choice number:

 

 

Вот такое меню.

Share this post


Link to post
Share on other sites
а нормальный шелл там есть?

 

Нормальный это как?

Share this post


Link to post
Share on other sites

Не нунжно путать wive-ng, wive-ng-dsl, wive-ng-rtnl это разные прошивки.

 

Маршрутизаторы на RTL8186 не настраивать нужно а на помойку нести, им на кладбище уже давно прогулы ставят. Риалтэк эти чипы давно не производит, фирмварь протухла в усмерть никакой поддержки уже с год ни за деньги ни без никто не оказывает.

 

Wive-NG-RTNL это фирмварь под ралинк RT305* а не риалтэк, вот там есть морда. Полноценный шелл есть везде. Wive-RTNL лишь в малой доли поход на Wive-NG для Realtek.

 

P.S. Предупреждая вопросы на тему сколько стоит чтобы настроил я. Отвечаю, раз в 10 больше чем покупка маршрутизатора на RT3052.

Share this post


Link to post
Share on other sites

Хорошо, тогда подскажите как перепрошить не через tftp?

Share this post


Link to post
Share on other sites

Короче пришлось самому разбираться что к чему. Подняли инет для Домру у брата по PPPoE. Все ништяк работает.

 

А для своего провайдера не могу инет поднять. Сеть роутер поднимает, а VPN - нет. Пинг до провайдера идет, а дальше нет.

 

Как настроить динамический PPTP?

 

У меня такие настройки:

 

#--PPTP

PPTP_CALL_START=yes

PPTP_SERVER=unlim.is74.ru

PPTP_MPPE=no #yes - always, no - refuse, auto - allow mppe

PPTP_MTU=1500

PPTP_MRU=1500

PPTP_USER="Мой логин"

PPTP_PASSWORD="Мой пароль"

PPTP_DEFROUTE=no #(yes|no|replace)

PPTP_PEERDNS=yes

PPTP_AUTO_REDIAL=yes

 

 

Настройки PPTPPEERS

 

# name of tunnel, used to select lines in secrets files

remotename pptp

 

# name of tunnel, used to name /var/run pid file

linkname pptp

 

#on connect add route to VPN server to route table

#connect "ip route add `ip route get 10.0.0.254 | head -1`; exit 0"

 

# domain and username, used to select lines in secrets files

name pptp

 

file /etc/ppp/options.pptp

 

 

Настройки PPTPOPTIONS

 

#only for pptp options

# We don't need the tunnel server to authenticate itself

noauth

 

#For buggy peers recive all LCP packets and will not transmit

#LCP packets to initiate a connection until a valid LCP packet

#is received from the peer

#silent

#receive-all

 

#Options for redial

idle 0

maxfail 0

holdoff 5

 

# We won't do PAP, EAP, CHAP, or MSCHAP, but we will accept MSCHAP-V2

# (you may need to remove these refusals if the server is not using MPPE)

refuse-pap

refuse-eap

refuse-chap

 

#Disable it to change kernel settings.

noktune

 

#Disable ARP proxy and IPX protocol

noproxyarp

noipx

 

# Turn off compression protocols we know won't be used

novj

novjccomp

nopcomp

noaccomp

nobsdcomp

nodeflate

 

 

Напомню у провайдера динамический PPTP. Без использования шифрования.

Share this post


Link to post
Share on other sites
P.S. Предупреждая вопросы на тему сколько стоит чтобы настроил я. Отвечаю, раз в 10 больше чем покупка маршрутизатора на RT3052.

Это же ты производитель этих прошивок? Ну должен же быть какой-то сервис. :)

 

 

 

Share this post


Link to post
Share on other sites
Маршрутизаторы на RTL8186 не настраивать нужно а на помойку нести, им на кладбище уже давно прогулы ставят. Риалтэк эти чипы давно не производит, фирмварь протухла в усмерть никакой поддержки уже с год ни за деньги ни без никто не оказывает.

Тем не менее роутеры на 8186 продаются в магазинах. Да и твоя сборка 0.3.18 от 01 мая сего года. Мне же роутер просто достался free. И как студенту нет возможности купить новый роут.

Share this post


Link to post
Share on other sites

Че-то не допру. Когда выхожу через роут, ругается типа "Вы вышли с другого компа". Хотя макадрес я прописал в роуте. И ещё интересно: в компе 2 сетевухи, соответственно 2 мака. Куда втыкать влан - без разницы, провайдер не ругается. Т.е. получается, что провайдер не по маку определяет комп? А по чему тогда? Неужто к железу привязывается?

Edited by ritchie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this