Jump to content
Калькуляторы

PCQ queue, или шейпинг на микротике

Столкнулся с такой интересной штукой на микротике, шейпер на 100 мбит не пропускает трафика более 23-25Мбит.

 

История:

 

Есть шейпер, на базе микротика. Нарисовано множество правил и PCQ типов. До 20 мбит включительно все работает отлично. Проблема начинается с очередями, скорости которых определены выше 20 мбит.

Вот кусок конфига:

 

 

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \

max-limit=0 name=Total_download packet-mark="" parent=ether1 priority=1

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \

max-limit=0 name=Total_upload packet-mark="" parent=ether2 priority=8

 

/queue type

add kind=pcq name=PCQ_down_100M pcq-classifier=dst-address pcq-limit=200 pcq-rate=100000000 pcq-total-limit=2000

 

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \

max-limit=0 name=Bezlim_100M_download packet-mark=Bezlim_100M_traffic \

parent=Total_download priority=8 queue=PCQ_down_100M

 

/ip firewall address-list

add address=172.16.16.7 comment="" disabled=no list=Bezlim_100M

 

/ip firewall mangle

add action=mark-connection chain=forward comment="Mark traffic bezlimit 100M" \

disabled=no new-connection-mark=Bezlim_100M_conn passthrough=yes \

src-address-list=Bezlim_100M time=0s-1d,sun,mon,tue,wed,thu,fri,sat

add action=mark-packet chain=forward comment="" connection-mark=\

Bezlim_100M_conn disabled=no new-packet-mark=Bezlim_100M_traffic \

passthrough=no time=0s-1d,sun,mon,tue,wed,thu,fri,sat

 

 

 

В цепочке стоят 3 роутера, фаервол - шейпер - бгп

 

полоса тестировалась с помощью микротиковской утилиты btest с БГП сервером.

 

В итоге - если на айпи адрес 172.16.16.7 повесить шейп в 100 мбит, реально больше 20-25 мбит не получаю. Только я отключаю в адресс-листе запись, скорость прыгает до 80 мбит.

Edited by SuiSide

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this