Jump to content
Калькуляторы

Ограничить мультикаст на порту 2960/2950

Есть у меня нехороший клиент, который получает мультикаст от меня и затем отправляет мне его обратно на те же мультикаст адреса. Хочется ограничить получение мультикаста с этого порта, не запрещая отправку мультикаста пользователю. На руках cisco 2960. Есть мысли как это можно сделать?

 

На том же длинке есть команда: router_ports_forbidden, которая обеспечивает необходимый функционал.

Share this post


Link to post
Share on other sites

Как-то так:

 

access-list 101 deny ip any 224.0.0.0 15.255.255.255

access-list 101 permit ip any any

int <int>

ip access-group 101 in

 

Только похоже у клиента L2 loop имеется. Так что правильнее будет этот L2 loop залечить.

Share this post


Link to post
Share on other sites
Как-то так:

 

access-list 101 deny ip any 224.0.0.0 15.255.255.255

access-list 101 permit ip any any

int <int>

ip access-group 101 in

 

Только похоже у клиента L2 loop имеется. Так что правильнее будет этот L2 loop залечить.

Нет, это просто клиент так VLC настроил :)

Странно, я почему-то думал, что acl эти для мультикаст пакетов не подходят. Ошибся.

Спасибо.

Share this post


Link to post
Share on other sites
switchport block multicast

весь unknown multicast с порта убивается.

В том то и дело, что мультикаст known. Т.к. клиент подписался на мультикаст группу, а затем её же начинает вещать. Подписка по igmp есть, значит мультикаст становится известным.

Share this post


Link to post
Share on other sites
switchport block multicast

весь unknown multicast с порта убивается.

В том то и дело, что мультикаст known. Т.к. клиент подписался на мультикаст группу, а затем её же начинает вещать. Подписка по igmp есть, значит мультикаст становится известным.

группа то создалась с router портом другим, не клиентским.

у вас мультикаст в отдельном влане идёт?

Share this post


Link to post
Share on other sites

Нет, multicast vlan не используем.

А где посмотреть router port? Я вижу только порты участвующие в группе, а кто из них router не указано.

#  sh ip igmp snooping groups        
Vlan      Group                    Type        Version     Port List
-----------------------------------------------------------------------
14        231.0.0.1                igmp                    Gi0/6, Gi0/8
14        239.195.1.17             igmp                    Gi0/6, Gi0/8
14        239.195.1.18             igmp                    Gi0/6, Gi0/8
14        239.195.1.19             igmp                    Gi0/6, Gi0/8

Share this post


Link to post
Share on other sites

Лью мультикаст в 14 вилане. Сервер вещает с порта g0/6 в порт g0/8.

interface GigabitEthernet0/6
description 2950T-24
switchport access vlan 14
switchport trunk native vlan 14
switchport trunk allowed vlan 7,14,16,25,50,56,60,321,932
switchport mode trunk
switchport block multicast
mls qos trust dscp
end

#sh ip igmp s mrouter vlan 14
Vlan    ports
----    -----
  14    Gi0/8(static)

Мультикасту ничего не мешает доходить до получателя в порту G0/8. Что я делаю не так?

Share this post


Link to post
Share on other sites

Документация утверждает, что 'switchport block multicast' блокирует отправку трафика в порт, а не прием. И еще она не действует на IPv4 и IPv6 пакеты.

Share this post


Link to post
Share on other sites

nnm

Действительно. Как-то не внимательно прочитал. Значит единственный способ - писать acl?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this