Jump to content
Калькуляторы

Приоритет трафика на каком оборудовании

Нужен приоритет трафика, а именно сначала разбить канал на приоритет - например сайты, tcp, udp,

а потом еще нарезать каждому клиенту канал.

какое оборудование с этим справляется без проблем?

в данный момент работает Микротик, но вот это в нем достаточно хорошо

реализовать нет возможности, то-есть возможность в нем есть, но реализована она не достаточно хорошо.

Share this post


Link to post
Share on other sites
в данный момент работает Микротик, но вот это в нем достаточно хорошо

реализовать нет возможности, то-есть возможность в нем есть, но реализована она не достаточно хорошо.

ну наверно вы недостаточно хорошо настроили. потому как микротик с этим справляется на ура.

Share this post


Link to post
Share on other sites
ну наверно вы недостаточно хорошо настроили. потому как микротик с этим справляется на ура.
резать скорость для клиентов PCQ, то проблем нет, а вот что бы еще и был приоритет...

если следовать этому мануалу

то вроде да, но не видел рабочих решений.

если Вам не трудно, покажите как у Вас выглядит дерево шейпера, где сначала канал делится по приоритету,

а потом еще режется скорость для клиентов.

Share this post


Link to post
Share on other sites

лично я для приоритетов отдельный микротик поставил. мне так удобнее было. сделать все на одной машине пока что у меня неполучилось.

а в мануале что вы привели это расписано очень даже хорошо как сделать приоритеты. маркируете сначала виды трафика а в дереве шейпера раставляйте приоритетты.

Edited by Fog

Share this post


Link to post
Share on other sites

если не сложно скиньте export queue tree с тика где вы режете приоритет

Share this post


Link to post
Share on other sites

приоритеты не режутся а раставляются (хотя можно и порезать).

 

вид примерно такой:

/queue tree
add disabled=no limit-at=100M max-limit=100M name="Tx to Client" parent=ether1 priority=8
add disabled=no limit-at=0 max-limit=0 name=icmp packet-mark=icmp parent="Tx to Client" priority=1 queue=default
add disabled=no limit-at=0 max-limit=0 name=http packet-mark=http parent="Tx to Client" priority=3 queue=default

где add disabled=no limit-at=100M max-limit=100M name="Tx to Client" parent=ether1 priority=8

нужно указать вашу действующую скорость канала.

ну а дальше нашпигуйте ваши приоритеты по типу трафика..

Share this post


Link to post
Share on other sites

спасибо, буду пробовать...

не первый раз встречаю, что в шейпере приоритетов нужно указывать

ширину канала, а вот тут то и проблема, нет у меня гарантированной ширины,

но думаю я ее уменьшу примерно на столько сколько она бывает гарантирована.

в Вашем примере я так понял это на исходящий трафик, а на входящий

надо вместо parent=ether1 указать внешний интерфейс, то есть в моем случае PPPoE.

спасибо еще раз, может и удастся у меня прикрутить к ним еще шейпер с ограничением

скорости на пользователя....отдельно тик на это ставить не хочется...

Share this post


Link to post
Share on other sites

пингуйте канал. если пинг превышает скажем 100мс уменьшайте гарантированую ширину.

 

чтоб не ставить отдельный тик, сделайте виртуальный.

да и непонятно о каких скоростях идет речь. может проще купить рб750г

Edited by Fog

Share this post


Link to post
Share on other sites

в том то и дело, что нет гарантированной ширины канала,

есть только до 20М., из которых не всегда бывает и 15....

виртуальный не получится, у меня не компьютер а RB450G.

и проблема не в том что бы купить еще тик, есть и еще RB450G,

просто не хочется городить огород, а сделать все на одном оборудовании.

Share this post


Link to post
Share on other sites
лично я для приоритетов отдельный микротик поставил. мне так удобнее было. сделать все на одной машине пока что у меня неполучилось.
месяц настойчивой работы и QoS и PCQ работают на одном RB450G так как надо, если бы у меня входной канал был бы

один, то с этим проблем бы не было, а так как у меня каналов несколько и групп клиентов тоже несколько да еще

у каждой группы разная скорость и все они разбросаны по каналам, в общем с этим пришлось повозится и уже было

подумывал ставить на каждый канал еще по одному мтику, но в последний момент, а именно ночь добил то что хотел...

жалко, что QoS нужно выставлять max-limit, а так как наружные каналы не стабильны придется теперь это контролировать....

Share this post


Link to post
Share on other sites

время пинга на яндекс через QoS. как тока время растет (скажем должно быть 20 а становится 100) то уменшить скорость на 1мбит.

хотя непонятно какой критерий позволит узнать свободный ли канал. как вариант. тот же пинг но в обход QoS с точностью наоборот - если время уменьшается с 100 до 20 добавить 512кбит

сделаете может поделитесь со мной...

Edited by Fog

Share this post


Link to post
Share on other sites

это надо скриптами делать, а я в них не селен, пока времени нет с ними разбираться,

и у меня не так часто прыгает канал только к вечеру...

я зажимаю его процентов на 20 ниже чем он есть,что бы очереди образовывались

у меня на мтике а не у провайдера...

 

P.S.

на вскидку думаю, что с пингом не получится, потому что если у Вас внешний канал

упал и у Вас max-limit постоянно загружен, то и пинги будут высокие, главное

что бы max-limit был ниже процентов на 10 от реальной скорости, тогда хоть

пинги и вырастут но будет работать приоритет...

Edited by sherwood

Share this post


Link to post
Share on other sites

есть проблема с маркировкой пакетов в прероутинге.

то есть одни правила пере-маркировывают другие, хотя у первых

стоит passthrough=no...

как с этим разобраться и почему это происходит?

например этим правилом мечу пакеты группы 01.Unlimit для направления на один из

двух внешних интерфейсов:

add action=mark-routing chain=prerouting comment=\
    "Mark routing for Unlimit" disabled=no new-routing-mark=Unlim \
    passthrough=no src-address-list=01.Unlimit

далее мечу пакеты для Qos:

add action=mark-packet chain=prerouting comment=www disabled=no in-interface=\
    pppoe-unlimit new-packet-mark=www_in_unl passthrough=no protocol=tcp \
    src-port=80
add action=mark-packet chain=prerouting comment="" disabled=no dst-port=80 \
    in-interface=LAN new-packet-mark=www_out_unl passthrough=no protocol=\
    tcp

проверяем, если с компьютера который находится в группе 01.Unlimit например сделать

тест скорости в интернете, то пакеты попадают как под первое правило так и под второе,

единственное, что под вторые правила не попадает исходящий трафик...

и что самое интересное если два последних правила переместить выше первого, то

ни чего не меняется....такое ощущение что правило о том что правила в Мангле обрабатываются

сверху вниз НЕ РАБОТАЕТ.

Edited by sherwood

Share this post


Link to post
Share on other sites
Используйте галочку passthrough.
для чего? :)

passthrough - если ДА то продолжает использовать эти пакеты в прероутинге, если НЕТ то выкидываем

из прероутинга дальше по цепочки Packet Flow...

мне вот и надо что бы пакеты которые помечены для роутинга дальше не пере-маркировывались

следующими правилами, а вылетали из прероутинга...поэтому и стоит passthrough=no...

но этого не происходит.... или я уже совсем запутался...

Share this post


Link to post
Share on other sites

Если пакет помечен он уже выходит и больше не используется. Возможно у вас что-то не так. Может версию обновить.

Share this post


Link to post
Share on other sites
Если пакет помечен он уже выходит и больше не используется. Возможно у вас что-то не так. Может версию обновить.
вот в том то вся и проблема, что должен но не обязан, версия 4.11

по справки если пакет помечен и стоит passthrough=no то он должен выходить,

а если стоит passthrough=yes, то пакету можно присвоить еще метку для и потом эти метки можно

обрабатывать не зависимо друг от друга...

если кто разбирается могу выложить export мангла...

Share this post


Link to post
Share on other sites

Тут надо разобратся дополнительно.

 

У меня есть правило одно, которое ловит весь трафик не попадающий под другие нарезки, в нем стоит passthrough=yes.

Есть другие правила в которых стоит passthrough=no.

 

И в итоге получается что в правило где passthrough=yes попадает только тот трафик, который не учелся другими правилами.

 

Например при трафике 100 мегабит все другие правила режут 70 а в passthrough=yes попадает только 30.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this