Jump to content
Калькуляторы

Cisco 1801 два pppoe-client на одном ethernet

Доброго времени суток

 

появилась задача поднять на с1801, на одном интерфейсе два PPPOE клиента

попробовал настроить, в лучшем случае, поднимается только один, причем debug ppp negotiation и т.п. ничего не выводит

 

реально ли вообше поднять на одном интерфейсе два клиента?

 

вот все настройки касающиеся pppoe:

...
aaa authentication ppp default local
...
interface FastEthernet0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
pppoe-client dial-pool-number 2
...
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer pool 1
ppp authentication chap callin
ppp chap hostname *****
ppp chap password *****
...
interface Dialer2
mtu 1492
ip address negotiated
encapsulation ppp
no ip mroute-cache
dialer pool 2
ppp authentication chap callin
ppp chap hostname *****
ppp chap password *****
...
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
...

 

перерыл на сайте циски кучу мануалов, так и не нашел примеров с несколькими диллерами на одном интерфейсе

может быть я что-то упустил в настройках?

Edited by v.v.s.

Share this post


Link to post
Share on other sites

Может что-то уже изменилось, но раньше нельзя было поднять больше одного клиентского pppoe соединения.

Share this post


Link to post
Share on other sites
Может что-то уже изменилось, но раньше нельзя было поднять больше одного клиентского pppoe соединения.
не больше одного на порт, или не больше одного на всю железку?

если на порт, то понадобятся ли какие небудь дополнительные настройки, если написать

pppoe enable
pppoe-client dial-pool-number 2

на сабинтерфейсе с dot1Q?

Edited by v.v.s.

Share this post


Link to post
Share on other sites

Одно pppoe на физический интерфейс.

IP адреса на интерфейсе быть не должно, если адрес есть то pppoe не поднимается. pppoe клиент описывается на самом интерфейсе, на саб интерфейсе описать нельзя.

Насколько мне помнится надо написать примерно следующее (из архива конфигов):

 

interface FastEthernet0/0

no ip address

pppoe enable group global

pppoe-client dial-pool-number 1

 

interface Dialer0

mtu 1492

bandwidth 60

ip address negotiated previous

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

 

dialer-list 1 protocol ip permit

Edited by LiuPing

Share this post


Link to post
Share on other sites

нашли споособ как решить проблему

 

договорились с провайдером

сделали как описано в моем предыдущем посте сабинтерфейс с dot1q

на нем завели второго клиента, со стороны провайдера пробросили pppoe в этот вилан

полет нормальный))

Edited by v.v.s.

Share this post


Link to post
Share on other sites

А так заработает ?

если dialer pool один и тот же указать?

 

interface FastEthernet0/0

pppoe-client dial-pool-number 1

!

!

interface Dialer1

mtu 1492

ip address negotiated

encapsulation ppp

ip tcp adjust-mss 1412

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

keepalive 30

no cdp enable

ppp authentication chap callin

ppp chap hostname v40000000000

ppp chap password 0 yyyyyyyyyy

!

interface Dialer2

mtu 1492

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1412

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

keepalive 30

no cdp enable

ppp authentication chap callin

ppp chap hostname v44444444

ppp chap password 0 xxxxxxxx

!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this