Jump to content
Калькуляторы

проблема с натом на с1801

Добрый день

Столкнулся с непонятной проблеммой на с1801

На циске поднял нат, и теперь через нат открывается только несколько сайтов например yandex.ru,

причем с каналом все в порядке, подключался напрямую с ноутбука, все работает

 

версия IOS была c180x-broadband-mz.150-1.M2, попробовал с c180x-advipservicesk9-mz.124-15.T8, ничего не изменилось

 

конфиг абсолютно типовой, нормально работает на других роутерах

циска новая, привезли буквально неделю назад

может это как-то с связано с тем, что ios теперь нужно регистрировать на сайте циски?

но насколько я понимаю это распространяется только на ноые иосы, а у меня даже на 124-15 та же проблема

 

конфиг вот такой:

 

Current configuration : 3192 bytes

!

! Last configuration change at 17:05:08 MSD Sun Aug 22 2010

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c180x-advipservicesk9-mz.124-15.T8.bin

boot-end-marker

!

enable secret *******

!

aaa new-model

!

!

aaa authentication login vpn_auth local

aaa authorization exec default local

aaa authorization network vpn_auth local

!

!

aaa session-id common

clock timezone MSK 3

clock summer-time MSD recurring last Sun Mar 2:00 last Sun Oct 2:00

!

!

dot11 syslog

!

!

ip cef

!

!

ip domain name ****.servebbs.com

ip host members.dyndns.org 204.13.248.112

ip name-server 80.82.32.9

ip name-server 80.82.33.65

ip ddns update method DynDNS

HTTP

add http://****:****@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 28 0 0 0

!

!

multilink bundle-name authenticated

vpdn enable

!

vpdn-group pptp

! Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

!

!

username admin privilege 15 password *******

!

!

archive

log config

hidekeys

!

!

!

!

!

interface Loopback11

description ip address for pptp vpn

ip address 10.62.11.1 255.255.255.255

!

interface FastEthernet0

description internet from vci

no ip address

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet1

switchport mode trunk

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface Virtual-Template1

ip unnumbered Loopback11

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1420

peer default ip address pool vpn_pool

ppp mtu adaptive

ppp authentication ms-chap ms-chap-v2 vpn_auth

ppp authorization vpn_auth

!

interface Vlan1

no ip address

!

interface Vlan10

ip address 10.62.10.1 255.255.255.252

ip nat inside

ip virtual-reassembly

!

interface Dialer1

mtu 1492

ip ddns update hostname ****.servebbs.com

ip ddns update DynDNS

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname ****

ppp chap password 7 ****

!

ip local pool vpn_pool 10.62.11.2 10.62.11.254

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 10.62.0.0 255.255.0.0 10.62.10.2

ip route 192.168.1.0 255.255.255.0 10.62.11.2

!

!

no ip http server

no ip http secure-server

ip dns server

ip nat inside source list 10 interface Dialer1 overload

!

access-list 10 permit 10.62.0.0 0.0.255.255

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password 7 140600115F0530

transport input all

transport output all

!

ntp source Dialer1

ntp master

ntp server 194.87.0.32

ntp server 195.2.64.5

 

end

Edited by v.v.s.

Share this post


Link to post
Share on other sites

Зря Вы так просто публикуете "password 7"

исправил, хотя какая разница, все равно неизвестно на какой железке этот password

Share this post


Link to post
Share on other sites

например делаю вот так

 

в браузере набираю google.ru

ничего не открывается

хотя пинг ходит нормально, и DNS имена нормально разрешаются

 

sh ip nat translations

Pro Inside global Inside local Outside local Outside global

icmp *.*.*.*:1 10.62.4.1:1 74.125.232.19:1 74.125.232.19:1

tcp *.*.*.*:56314 10.62.4.1:56314 91.203.99.45:80 91.203.99.45:80

tcp *.*.*.*:56315 10.62.4.1:56315 74.125.232.19:80 74.125.232.19:80

tcp *.*.*.*:59652 10.62.4.1:59652 91.198.174.232:80 91.198.174.232:80

Edited by v.v.s.

Share this post


Link to post
Share on other sites

От размера пакета зависимости нет? Может с MSS или MTU проблема?

Share this post


Link to post
Share on other sites

спасибо

 

поогло

interface Vlan10

ip tcp adjust-mss 1452

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this