Jump to content
Калькуляторы

большой бродкаст домен в VLAN

Помогите решить проблему.

Есть Catalyst 3750, на котором поднят роутинг для vlan-ов. Порядка 10 SVI , подсети /24 /28 /30.

 

На нее транком приходит vlan в котором "живет" плоская сеть 192.168.0.0/16 vlan111, в ней ~ 2000 хостов онлайн. (!)

L3 интерфейс этого влана поднят на PCrouter-е.

При переносе L3 ифейса на Catalyst , выборочно, недоступна большая часть хостов из этой сети.

 

#clear mac-address-table dynamic

#clear arp-cache

ситуации не меняют

 

Подскажите куда смотреть? Уж очень нужно роутить этот vlan c остальными.

 

 

Из конфига:

 

ip routing

 

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk native vlan 111

switchport trunk allowed vlan 10,11

switchport mode trunk

interface Vlan111

ip address 192.168.100.1 255.255.0.0

 

interface Vlan10

ip address 172.16.100.1 255.255.255.0

Edited by dreambox

Share this post


Link to post
Share on other sites
При переносе L3 ифейса на Catalyst , выборочно, недоступна большая часть хостов из этой сети.
то есть часть ип адресов из 192.168.0.0/16 перестает пинговаться??

а у абонентов прописан шлюз

interface Vlan111

ip address 192.168.100.1 255.255.0.0

а у абонентов указаны необходимые маршруты??!

 

зы а с какова железа приходит vlan 111 ??? он идет тегированые или нетегированный/?

Edited by mukca

Share this post


Link to post
Share on other sites
он идет тегированые или нетегированный/?

Приходит не тегированным.

 

 

 

а у абонентов указаны необходимые маршруты??!
Маршруты указаны верно.

 

зы а с какова железа приходит vlan 111

Catalyst -trunk if <-> DES3200-16

 

Дело в том, что из catalyst ping не проходят, по этому влану на некоторые хосты.

Edited by dreambox

Share this post


Link to post
Share on other sites

А вы уверены что эти строки правильны? :)

switchport trunk native vlan 111
switchport trunk allowed vlan 10,11

 

Реально так или обрезали когда вставляли?

Share this post


Link to post
Share on other sites

Смотрите профиль 3750. Возможно он просто не может выучить больше чем 2К маков.

Я на эти грабли наступал.

Share this post


Link to post
Share on other sites

to Ivan Rostovikov

темплейт в default

6К вполне достаточно

 

sh sdm prefer

The current template is "desktop default" template.

The selected template optimizes the resources in

the switch to support this level of features for

8 routed interfaces and 1024 VLANs.

 

number of unicast mac addresses: 6K

number of IPv4 IGMP groups + multicast routes: 1K

number of IPv4 unicast routes: 8K

number of directly-connected IPv4 hosts: 6K

number of indirect IPv4 routes: 2K

number of IPv4 policy based routing aces: 0

number of IPv4/MAC qos aces: 512

number of IPv4/MAC security aces: 1K

 

to SokolovS

switchport trunk encapsulation dot1q

switchport trunk native vlan 111

switchport trunk allowed vlan 101,111

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 111

switchport trunk allowed vlan 101,111

switchport mode trunk

Не все скопировал.

 

 

 

 

Share this post


Link to post
Share on other sites
Приходит не тегированным.
на длинке влан делайте тегированным, а на cisco:

interface GigabitEthernet1/0/1 
switchport trunk encapsulation dot1q 
switchport trunk allowed vlan 10,11,111
switchport mode trunk

так и правильнее и так работать надо. (весь трафик между свичами надо тегированный пускать)

 

Возможно он просто не может выучить больше чем 2К маков.
не смешите мои тапки. для такой железяки 2к маков... если даже не может изучить циска должена тогда как хаб работать...

 

dreambox

90% проблема в маршрутизации

также больше ип шлюза больше негде не указан??! может он где нибуть у юзвера вбит и забирает на себя часть сегмента

 

симптомы получше опишите.

как проверяете ип адреса доступны или нет?!?

с циски пингуете или с ип адреса в другом влане?!?

пробовали проверить с ип из сетки 192,168,0,0/16 ??!?

не забывайте что если это обычные компы или домашние роуторы то большая часть и не будет пинговаться так как существуют всякие фаерволы/антивирусы и опять же маршруты

Edited by mukca

Share this post


Link to post
Share on other sites

А вы учли, что большинство компов arp запись роутера обновят только через некоторое время? Т.е в течение некоторого времени будут продолжать отслылать пакеты на мак компа.

 

Включите снифер в пустой порт в этом вилане.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this