Jump to content
Калькуляторы

GRT <-> VRF dynamic routes

Уважаемые коллеги!

 

Решая задачу, описанную в посте про перехват PPTP, сделал обмен между GRT и vrf динамическими маршрутами, связав их туннелем на лупбэках (Cisco 3662, 12.4(9)T2):

 

ip vrf ACCESS
rd 21270:10
import ipv4 unicast 1000000 map ACCESS-import
route-target export 21270:10
route-target import 21270:10

...

interface Tunnel1
ip address 10.100.100.1 255.255.255.252
tunnel source Loopback1
tunnel destination 10.10.10.2
!
interface Tunnel2
ip vrf forwarding ACCESS
ip address 10.100.100.2 255.255.255.252
tunnel source Loopback2
tunnel destination 10.10.10.1

...

interface Loopback1
description VRF linker: global end
ip address 10.10.10.1 255.255.255.255
!
interface Loopback2
description VRF linker: ACCESS vrf end
ip vrf forwarding ACCESS
ip address 10.10.10.2 255.255.255.255

...

router ospf 2 vrf ACCESS
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface Tunnel2
network 10.0.0.0 0.255.255.255 area 0.0.0.0

...

router ospf 1
log-adjacency-changes
passive-interface default
no passive-interface Tunnel1
network 10.0.0.0 0.255.255.255 area 0.0.0.0

...

ip route 10.10.10.2 255.255.255.255 Loopback2

 

Идентичная конструкция на 7206 VXR (12.2(31)SB18) не работает: пакеты не ходят сквозь туннель (проверял пингом). Это как-то лечится? Если это баг ИОС-а, то не посоветуете ли ISG прошивку, в которой это решено?

 

Share this post


Link to post
Share on other sites

Попробуйте оба Loopback оставить в GRT.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this