Jump to content
Калькуляторы

Как назначить разные cost в OSPF ? Разные cost для разных neighbor, возможно ли ?

Доброго дня!

Есть вот такая схемка центра сети:

to_nag.jpg

состоит из(снизу вверх):

Dlink DGS-3627 (ip 10.50.0.99) в качестве районного L3

Dlink DGS-3612 (ip 10.50.0.199) так же в качестве районного L3

Данные роутеры подключены через L2 Switch в NAT1 и NAT2 (оба FreeBSD+quagga).

 

Задача организовать OSPF между данными маршрутизаторами таким образом, что бы NAT1 и NAT2 отдавали дефолт роут на себя каждому 36xx, но так, что бы для 3627 cost 10.50.0.111 был меньше чем 10.50.0.222, а для 3612 наоборот (cost для 10.50.0.222 был меньше, чем 10.50.0.111). Т.е. сделать без баллансировки. Ну а в свою очередь 36хх отдавали маршруты на свои сети обоим натам.

 

На данный момент удалось выполнить задачу почти на 100%, за исключением как раз выставление cost для 36xx.

Конфиги такие:

NAT1:

ospfd.conf

hostname nat1
password 123
enable password 123
!
interface em1
!
router ospf
ospf router-id 10.50.0.111
default-information originate always
network 10.50.0.0/24 area 0.0.0.0

 

NAT2:

hostname nat2
password 123
enable password 123
!
interface em1
!
router ospf
ospf router-id 10.50.0.222
default-information originate always
network 10.50.0.0/24 area 0.0.0.0

 

3627:

config ospf ipif System state enable
config ospf ipif NET1 state enable
config ospf ipif NET2 state enable
enable ospf

 

3612:

config ospf ipif System state enable
config ospf ipif NET3 state enable
config ospf ipif NET4 state enable
enable ospf

 

При таком раскладе каждый 36хх отдаёт натам маршруты на свои сети и получает 2 дефолта: 10.50.0.111 и 10.50.0.222, но с одинаковыми cost (чего нам совсем не надо). Где и как выставить cost для определённого neighbor найти нигде не могу :(

 

До кучи нарисовалась такая проблема на натах: каждый нат стал дефолтным для другого, т.е. 10.50.0.111 получил дефолт роут на 10.50.0.222 и наоборот.

Настоящий дефолт роут наты должны получать по iBGP сверху, но маршруты OSPF видать приоритетнее.

Пока решили проблему прописав defaultrouter в rc.conf, который в принципе приоритетнее чем quagga. Удалось установить, что эти дефолты натам раздают 36хх, т.к. трафик между натами заблокировал в pf.

 

Но вопрос с выставление cost стоит острым углом. Может кто-то делал что-то подобное ?

Share this post


Link to post
Share on other sites

Cost у Quagga выставляется в настройках интерефейса. На D-Link к сожалению не подскажу где он ставится, на старой серии DXS ставился тоже в настройках ospf интерфейса.

Share this post


Link to post
Share on other sites
Cost у Quagga выставляется в настройках интерефейса. На D-Link к сожалению не подскажу где он ставится, на старой серии DXS ставился тоже в настройках ospf интерфейса.

Если Вы про это:

...
interface em1
ip ospf cost xx
...

 

то во-первых Dlink всё равно видит маршрут с cost 1; а во-вторых это будет глобально для двух Dlink...а нам надо что бы для 3612 роут на 10.50.0.111 имел один cost, а для 3627 этот же маршрут имел другой cost.

Share this post


Link to post
Share on other sites

OSPF это Link-State протокол, боюсь ваша задача решается только созданием виртуальных линков.

Share this post


Link to post
Share on other sites

А VLAN на натах пойдёт как виртуальный интерфейс ?

 

Share this post


Link to post
Share on other sites

Поменяйте метрику у интерфейсов и все будет пахать как надо.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this