Jump to content
Калькуляторы

Juniper local-switching Juniper local-switching в одном и том же интерфейсе

Вопрос по local-switching.

В Cisco то работает на ура, а вот в Juniper возникла проблема, работает только если номара VLAN одинаковы т.е.

 

interface ge-1/3/1.438 {

end-interface {

interface ge-1/3/2.438;

}

}

 

Но иногда бывает что обе точки на одном интерфейсе, и нужно их загнать для потсчета трафика, но не работает т.е.

 

interface ge-1/3/1.440 {

end-interface {

interface ge-1/3/1.439;

}

}

 

Ни кто не подскажет, может просто что-то делаю неправильно.

 

есть есче раздел

connections {

interface-switch l2vpn-local-switch {

interface ge-1/3/2.427;

interface ge-1/3/2.430;

}

}

Это было уже давно и уже не помню, вроде как ничего не пошло.

Share this post


Link to post
Share on other sites

Проблема с разными Vlan-id решается использованием vlan-map'ов.

Share this post


Link to post
Share on other sites
Проблема с разными Vlan-id решается использованием vlan-map'ов.
А по подробнее можно.

 

Share this post


Link to post
Share on other sites

Необходимо поменять тэги, варианты swap, pop/push.

Вот пример, с одной стороны vlan 11, с другой - 27, vlan-map применяем 1 раз используя swap:

unit 11 {

encapsulation vlan-ccc;

vlan-id 11;

}

unit 27 {

encapsulation vlan-ccc;

vlan-id 27;

input-vlan-map {

swap;

vlan-id 11;

}

output-vlan-map swap;

}

 

Вот что получается:

show interfaces ge-1/1/7.27

Logical interface ge-1/1/7.27 (Index 633) (SNMP ifIndex 838)

Flags: 0x4000 VLAN-Tag [ 0x8100.27 ] In(swap .11) Out(swap .27) Encapsulation: VLAN-CCC

 

Второй вариант, используя pop/push убираем теги совсем, с одной стороны QinQ:

show configuration interfaces ge-5/0/3.111

encapsulation vlan-ccc;

vlan-id 111;

input-vlan-map pop;

output-vlan-map push;

 

show configuration interfaces ge-1/3/0.111

encapsulation vlan-ccc;

vlan-tags outer 513 inner 111;

input-vlan-map pop-pop;

output-vlan-map push-push;

 

show interfaces ge-1/3/0.111

Logical interface ge-1/3/0.111 (Index 189) (SNMP ifIndex 302)

Flags: SNMP-Traps 0x4000 VLAN-Tag [ 0x8100.513 0x8100.111 ] In(pop-pop) Out(push-push 0x8100.513 0x8100.111) Encapsulation: VLAN-CCC

 

 

Ссылка на документацию:

http://www.juniper.net/techpubs/software/j...-vlan-tags.html

Share this post


Link to post
Share on other sites

Добрый день.

Разбираюсь с аналогичной задачей.

собствено вот схема:

 

(ex4200)-(mx80 PE5)- (mx80 PE7)- (ex4200)

 

То как есть пинг от одного коммутатора до другого:

устройство 7

routing-instances {

l2vpn-over-mpbgp-null-vpn {

instance-type l2vpn;

interface ge-1/1/7.763;

route-distinguisher 65535:763;

vrf-target {

import target:65535:763;

export target:65535:763;

}

protocols {

l2vpn {

encapsulation-type ethernet-vlan;

site l2vpn-over-mpbgp-null-vpn-7 {

site-identifier 7;

interface ge-1/1/7.763 {

remote-site-id 5;

}

}

}

}

}

interfaces {

ge-1/1/7 {

vlan-tagging;

encapsulation vlan-ccc;

unit 763 {

encapsulation vlan-ccc;

vlan-id 763;

}

 

устройство 5

routing-instances {

l2vpn-over-mpbgp-null-vpn {

instance-type l2vpn;

interface ge-1/1/7.763;

route-distinguisher 65535:763;

vrf-target {

import target:65535:763;

export target:65535:763;

}

protocols {

l2vpn {

encapsulation-type ethernet-vlan;

site l2vpn-over-mpbgp-null-vpn-5 {

site-identifier 5;

interface ge-1/1/7.763 {

remote-site-id 7;

}

}

}

}

}

interfaces {

ge-1/1/7 {

vlan-tagging;

encapsulation vlan-ccc;

unit 763 {

encapsulation vlan-ccc;

vlan-id 763;

}

 

 

--------------------------------------

--------------------------------------

Необходимо снять тэги с 763-го влана, таким образом, чтобы клиент получил не тэгированный(802.1Q) трафик. Как если бы у клиенты был просто ноутбук.

 

То как нет пинга от одного ноута до другого:

(ноут)-(mx80 PE5)- (mx80 PE7)- (ex4200)

устройство 7

routing-instances {

l2vpn-over-mpbgp-null-vpn {

instance-type l2vpn;

interface ge-1/1/7.763;

route-distinguisher 65535:763;

vrf-target {

import target:65535:763;

export target:65535:763;

}

protocols {

l2vpn {

encapsulation-type ethernet-vlan;

site l2vpn-over-mpbgp-null-vpn-7 {

site-identifier 7;

interface ge-1/1/7.763 {

remote-site-id 5;

}

}

}

}

}

interfaces {

ge-1/1/7 {

vlan-tagging;

encapsulation vlan-ccc;

unit 763 {

encapsulation vlan-ccc;

vlan-id 763;

}

 

устройство 5

routing-instances {

l2vpn-over-mpbgp-null-vpn {

instance-type l2vpn;

interface ge-1/1/7.763;

route-distinguisher 65535:763;

vrf-target {

import target:65535:763;

export target:65535:763;

}

protocols {

l2vpn {

encapsulation-type ethernet-vlan;

site l2vpn-over-mpbgp-null-vpn-5 {

site-identifier 5;

interface ge-1/1/7.763 {

remote-site-id 7;

}

}

}

}

}

interfaces {

ge-1/1/7 {

vlan-tagging;

encapsulation vlan-ccc;

unit 763 {

encapsulation vlan-ccc;

vlan-id 763;

input-vlan-map {

push;

tag-protocol-id 0x8100;

vlan-id 763;

}

output-vlan-map pop;

}

 

 

Сам l2vpn работает. но не получается прмименить эти влан мапы, кто делал подскажите плиз где ошибка?)

Edited by motor503

Share this post


Link to post
Share on other sites

Так не будет работать. Логический интерфейс(unit), к которому будет приписан входящий пакет, определяется по vlan-id. Т.к. входящие пакеты не тегированные, то в unit 783 они не попадут.

 

Попробуйте сделать влан как native, без vlan-map'ов.

Share this post


Link to post
Share on other sites

Там засада в том что номер влана(юнита), должен совпадать, иначе сессия l2vpn падает. Это особенность натсройки в доках тоже так пишут.

А в режиме настройки юниат натив влан не прописывается(

Share this post


Link to post
Share on other sites

нужно сделать flexible-vlan-tagging вместо просто vlan-tagging и указать native-vlan на физическом интерфейсе, а не на юните, настройка юнита остается без изменений.

Edited by agr

Share this post


Link to post
Share on other sites

Вернулся. Понял что l2vpn не так удобно как vpls.

Поэтому сейчас, буду проверять для него.

 

собственно сам интерфейс:

 

set interfaces ge-1/0/3 flexible-vlan-tagging

когда проверял тут было про натив влан ид

set interfaces ge-1/0/3 encapsulation flexible-ethernet-services

set interfaces ge-1/0/3 unit 762 encapsulation vlan-vpls

set interfaces ge-1/0/3 unit 762 vlan-id 762

set interfaces ge-1/0/3 unit 762 family vpls

Edited by motor503

Share this post


Link to post
Share on other sites

не. так не работает.

 

не работает так же:

set interfaces ge-1/0/3 flexible-vlan-tagging

set interfaces ge-1/0/3 encapsulation flexible-ethernet-services

set interfaces ge-1/0/3 unit 762 encapsulation vlan-vpls

set interfaces ge-1/0/3 unit 762 vlan-id 762

set interfaces ge-1/0/3 unit 762 input-vlan-map pop

set interfaces ge-1/0/3 unit 762 output-vlan-map push

set interfaces ge-1/0/3 unit 762 family vpls

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this