Jump to content
Калькуляторы

CISCO 871 VPN (pptp pap) где косяк?

Есть железка CISCO 871 - IOS 12.4(9)T3

 

Одним интерфейсом смотрит в интернет вторым в домашнюю сетку, также делает PAT.

Появилась необходимость настроить VPN доступ в домашнюю сетку, решил использовать самый примитивный вариант с протоколом pptp (тот что используется в WINDOWS) авторизацию pap.

При попытке подключения с виндовой машины, майкрасофтовская звонилка выдает ошибку 734.

Выкладываю конфиг.

 

no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool clients
   network 192.168.0.0 255.255.255.0
   dns-server 66.66.66.66
   netbios-name-server 192.168.0.1
   netbios-node-type h-node
   default-router 192.168.0.1
!
ip dhcp pool VPN
   network 192.168.1.0 255.255.255.0
   dns-server 66.66.66.66
   netbios-name-server 192.168.1.1
   netbios-node-type h-node
   default-router 192.168.1.1
!
!
ip domain name test.org
ip name-server 66.66.66.66
ip ssh version 1
vpdn enable
!
vpdn-group DOSMEN
! Default PPTP VPDN group
description my VPN
accept-dialin
  protocol pptp
  virtual-template 1
!
!
!
!
!
username test privilege 0 password 7 131112011F
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
mac-address 0013.8f93.0000
ip address  195.68.203.245 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Virtual-Template1
ip address 192.168.1.1 255.255.255.0
peer default ip address dhcp-pool VPN
ppp encrypt mppe auto
ppp authentication pap
!
!
interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0  195.68.203.1
!
!
no ip http server
ip http authentication local
no ip http secure-server
ip http path flash:htdocs
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static udp 192.168.0.192 192 interface FastEthernet4 192
ip nat inside source static tcp 192.168.0.192 192 interface FastEthernet4 192
ip nat inside source static tcp 192.168.0.2 80 195.68.203.245 80 extendable

ip access-list extended inside
permit tcp any any established
permit icmp any any
ip access-list extended outside
permit tcp any host 195.68.203.245 eq 22
permit icmp any host 195.68.203.245
permit tcp any host 192.168.0.1 eq 22
permit tcp any any
!
access-list 1 permit 192.168.0.0 0.0.0.255

control-plane
!
!
line con 0
password 7 ***********
login
no modem enable
line aux 0
line vty 0 4
login local
transport input ssh
!
scheduler max-task-time 5000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice

 

Какие есть идеи?

И знаю, знаю что конфиг кривоват ... как обычно в попыхах сделал и забил ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this