Jump to content
Калькуляторы

Catalyst 3750G/3560G - хочу хитрый portbased VLAN

Всем доброе время суток.

 

Коллеги, пните плз в нужном направлении.

 

Есть пачка Catalyst 3750G/3560G.

Как на них реализовать такой сценарий?

interface giga0/1
swi trunk enca dot1q
swi trunk allowed vlan 10,20,30
swi mode trunk

interface giga0/2
swi trunk enca dot1q
swi trunk allowed vlan 10,20,30
swi mode trunk

interface giga0/3
swi trunk enca dot1q
swi trunk allowed vlan 10,20,30
swi mode trunk

interface giga0/4
swi trunk enca dot1q
swi trunk allowed vlan 10,20,30
swi mode trunk

interface giga0/5
swi trunk enca dot1q
swi trunk allowed vlan 10,20,30
swi mode trunk

interface giga0/6
swi trunk enca dot1q
swi trunk allowed vlan 10,20,30
swi mode trunk

 

При этом порты gi0/1-gi0/3 друг друга не видят, порты gi0/4 и gi0/5 тоже друг друга не видят. Порт gi0/6 видит

всех. Все это в пределах своих dot1q vlan'ов.

 

Hасколько я понимаю, switchport protected тут не работает. Смутно догадываюсь, что может помочь private vlan ,

но как именно - никак не соображу...

 

 

Share this post


Link to post
Share on other sites

Опишите конкретнее, что нужно? И где интерфейсы вланов?

Share this post


Link to post
Share on other sites
Опишите конкретнее, что нужно?
Так вроде же достаточно подробно описал...

Есть несколько dot1q транков. VLAN'ы в них частично пересекаются. Для простоты восприятия указано, что во всех транках вланы одни и те же.

Часть из этих транков можно условно назвать "клиентскими", часть - "аплинками". Мне нужно сделать больше одного транка "аплинками", но так, чтобы трафик между "аплинками" не ходил точно так же, как и между "клиентскими" транками. При этом есть, если можно его так назвать, "супер-аплинк", который видит всех.

Когда аплинк один, работает switchport protected. Больше одного аплинка (при условии изоляции аплинков друг от друга; это уже и аплинками-то называть не совсем корректно...) - оно не годится. Я уж про супер-аплинк не говорю...

 

В длинках с помощью traffic segmentation это делается достаточно просто. А тут?

 

И где интерфейсы вланов?
Нигде. Речь идет о L2.
Edited by Serhio Go

Share this post


Link to post
Share on other sites

!

interface GigabitEthernet1/0/13

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 12,13,15

switchport mode trunk

switchport protected

spanning-tree portfast

!

!

interface GigabitEthernet1/0/14

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 12,13,15

switchport mode trunk

switchport protected

spanning-tree portfast

!

Работает, мб чет не то крутили... тока что перепроверил, устройство А в vl 12 за g1/0/13 не общается с устройством Б в vl 12 за g1/0/14

Share this post


Link to post
Share on other sites
!

interface GigabitEthernet1/0/13

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 12,13,15

switchport mode trunk

switchport protected

spanning-tree portfast

!

!

interface GigabitEthernet1/0/14

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 12,13,15

switchport mode trunk

switchport protected

spanning-tree portfast

!

Работает, мб чет не то крутили... тока что перепроверил, устройство А в vl 12 за g1/0/13 не общается с устройством Б в vl 12 за g1/0/14

Что ж за день такой... то ли плохо объясняю, то ли никто не понимает =]

Оно работает, но не годится, когда между аплинками тоже нужно запретить трафик (т.е. когда аплинки по сути своей тоже вырождаются в клиентские порты). А у меня как раз такой случай.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this