Jump to content
Калькуляторы

cat6509 ограничение скорости как?

interface Vlan1518

ip address 192.168.56.2 255.255.255.0

rate-limit input 2000000 375000 750000 conform-action transmit exceed-action drop

rate-limit output 2000000 375000 750000 conform-action transmit exceed-action drop

!

interface Vlan3900

ip address 192.168.55.2 255.255.255.0

rate-limit input 2000000 375000 750000 conform-action transmit exceed-action drop

rate-limit output 2000000 375000 750000 conform-action transmit exceed-action drop

 

с двух сторон два фрибсд сервера с ип адресами соотв. 192.168.56.1/24 и 192.168.55.1/24 с дефолтовыми маршрутами соотв 192.168.56.2 и 192.168.55.2

при прокачке между серверами через комутатор скорость прокачки на всю ширину порта тоесть конструкция с рейт-лимитом не работает :(

что необходимо сделать/докупить/настроить чтобы конструкция работала?

 

дальше: стоит модуль 3 48 48 port 10/100 mb RJ45 WS-X6348-RJ-45

при заходе на int f3/1 и просмотре допустимых настроек нету на порту ни rate-limit ни traffic-shape... это получается что невозможно зашейпить скорость на порту? :( или необходима другая плата.

 

при этом на модуле 2 16 16 port 1000mb GBIC ethernet WS-X6416-GBIC есть и rate-limit и traffic-shape (пока не проверял или работают)

 

единственное как я добился шейпинга для юзера включеного в порт WS-X6348-RJ-45 это путем следующей схемы

 

 

class-map match-any test

match access-group 100

!

policy-map test

class test

police cir 2000000 bc 375000 be 750000 conform-action transmit exceed-action drop violate-action drop

!

 

access-list 100 permit ip any 192.168.55.0 0.0.0.255

 

 

и повесив service-policy input test на аплинк интерфейс. но помоему это не совсем правильно - а если таких клиентов 300-400 - это надо столько полиси повесить на аплинк интерфейс? не станет ли он при этом "лагать"?

 

буду очень благодарен за ответы с помощью...

Share this post


Link to post
Share on other sites

только вариант с QoS policy (последний) правильный.

если клиентов 300-400 придется создавать 300-400 ACL + столько же class-map и все class запихивать в одну policy-map и потом вешать на интерфейс.

 

кроме большого количества ACL + class (которые имеют ограничения по количеству) такой механизм не позволяет полсить исходящий траффик.

 

если надо более красиво + исходящий траффик - необходим microflow policing (UBRL). но он работает только на sup32/720-3b/3bxl

Share this post


Link to post
Share on other sites

(config-if)#speed 10

ну проще некуда =)

Share this post


Link to post
Share on other sites
только вариант с QoS policy (последний) правильный.

если клиентов 300-400 придется создавать 300-400 ACL + столько же class-map и все class запихивать в одну policy-map и потом вешать на интерфейс.

 

кроме большого количества ACL + class (которые имеют ограничения по количеству) такой механизм не позволяет полсить исходящий траффик.

 

если надо более красиво + исходящий траффик - необходим microflow policing (UBRL). но он работает только на sup32/720-3b/3bxl

для чего тогда эти команды rate-limit на влан интерфейсах? смысл? или просто типа для будущего использования?

Share this post


Link to post
Share on other sites

Получается что и на физическом интерфейсе rate-limit и traffic-shape не работает? странно почему на дешовом edge-core и длинке и на более старых моделях циско (2948G например) на физическом интерфейсе rate-limit и traffic-shape работают а на такой более дорогой железке нет... может надо включить какую-то опцию в конфиге?

Share this post


Link to post
Share on other sites

Работает и на физическом, если Вы трафик закрутите в программную маршрутизацию. Но работать будет не лучше 72xx.

 

А если Вы через PFC хотите маршрутизировать - ввиду своего дизайна PFC не умеет ограничивать скорости на порту и шейпить. Только классы.

Share this post


Link to post
Share on other sites
для чего тогда эти команды rate-limit на влан интерфейсах?
чтобы были.
Получается что и на физическом интерфейсе rate-limit и traffic-shape не работает?
подумайте сами, а равно ли L2=L3, если Вы переколотите: ноу свичпорт, так же будет работать?

з.ы. можно версию Вашего кат_оса узнать?

Share this post


Link to post
Share on other sites

если надо более красиво + исходящий траффик - необходим microflow policing (UBRL). но он работает только на sup32/720-3b/3bxl

А разве microflow policing работает на output?

Share this post


Link to post
Share on other sites
для чего тогда эти команды rate-limit на влан интерфейсах?
чтобы были.
Получается что и на физическом интерфейсе rate-limit и traffic-shape не работает?
подумайте сами, а равно ли L2=L3, если Вы переколотите: ноу свичпорт, так же будет работать?

з.ы. можно версию Вашего кат_оса узнать?

IOS s222_rp Software (s222_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(18)SXF17a, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2010 by cisco Systems, Inc.

Compiled Mon 01-Mar-10 17:21 by tinhuang

 

на счет "чтобы были" - как-то не совсем корректный ответ :)

попробую с но свитчпорт - отпишусь

 

п.с. - а как на этом свиче пошейпить вилан на инпут. например есть 2 транковых порта, мне надо определенный вилан проходящий через комутатор ограничить в скорости на 1 мегабит - как эт сделать?

Share this post


Link to post
Share on other sites
на счет "чтобы были" - как-то не совсем корректный ответ :)

попробую с но свитчпорт - отпишусь

не пробуйте, злая шутка была это.
п.с. - а как на этом свиче пошейпить вилан на инпут. например есть 2 транковых порта, мне надо определенный вилан проходящий через комутатор ограничить в скорости на 1 мегабит - как эт сделать?
никак. (для сквозного л2 трафика)

Share this post


Link to post
Share on other sites
А разве microflow policing работает на output?
нет не работает.

перепутал с указанием src/dest flow mask

Share this post


Link to post
Share on other sites

получается комутатор бесполезный в плане доступа а годится только как бордер и для роутинга?

Share this post


Link to post
Share on other sites

Ну в общем да :)

Это железка уровня агрегации или мелкого ядра.

Share this post


Link to post
Share on other sites
на счет "чтобы были" - как-то не совсем корректный ответ :)

попробую с но свитчпорт - отпишусь

не пробуйте, злая шутка была это.
п.с. - а как на этом свиче пошейпить вилан на инпут. например есть 2 транковых порта, мне надо определенный вилан проходящий через комутатор ограничить в скорости на 1 мегабит - как эт сделать?
никак. (для сквозного л2 трафика)

!

int gi XX/XX

desc TRUNK

mls qos vlan-based

!

int vlan

service-policty input XXX

service-policty output XXX

 

у меня работает

Share this post


Link to post
Share on other sites
!

int gi XX/XX

desc TRUNK

mls qos vlan-based

!

int vlan

service-policty input XXX

service-policty output XXX

 

у меня работает

это для какого СУПа?

Share this post


Link to post
Share on other sites
!

int gi XX/XX

desc TRUNK

mls qos vlan-based

!

int vlan

service-policty input XXX

service-policty output XXX

 

у меня работает

это для какого СУПа?

720-3bxl

Share this post


Link to post
Share on other sites
получается комутатор бесполезный в плане доступа а годится только как бордер и для роутинга?
Доступ/доступу рознь...

 

На классах в sup720 можно реализовать 1000 ограничений скорости. Это 500 портов можно заполисить.

 

А если применить SIP карты... Там, дай бог памяти, 8000 очередей кажется - 4000 потров.

 

 

 

 

Share this post


Link to post
Share on other sites

Вопрос такого плана. Реально ли реализовать на 6509 sup2 следующую фишку

Есть 2 вилана которые приходят от двух разных аплинков по бгп.

Есть клиент(ы) за каталистом.

Как мне ограничить на каталисте _СУММАРНУЮ_ скорость для определенного ИП для которого приходит трафик с обеих виланов.

Как ограничить для каждого из виланов отдельно проблем нет

access-list 100 permit ip any host 1.2.3.4

!

class-map match-any test

match access-group 100

!

policy-map if1

class test

police cir 2000000 bc 375000 be 750000 conform-action transmit exceed-action drop violate-action drop

!

interface GigabitEthernet2/1

service-policy input if1

!

interface GigabitEthernet2/2

service-policy input if1

 

при такой схеме клиент 1.2.3.4 качает на скорости в 2 мегабита и с одного и с другого интерфейса одновременно (тоесть реально может получить в 2 раза больше скорости чем должен)

 

как настроить такую схему чтобы скорость по обеим виланам суммировалась?

 

Share this post


Link to post
Share on other sites
как настроить такую схему чтобы скорость по обеим виланам суммировалась?

смотрите в сторону mls qos aggregate-policer,

на sup2 работает

Edited by C@T

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this