Jump to content
Калькуляторы

Mikrotik v.2.9.27 + wds = проблемы с ARP

Здравствуйте.

Подскажите, если кто-то сталкивался с такой проблемой.

Имеется 2 MT, подключенны через WDS. С обеих сторон все интерфейсы в бридже. Соединение устонавливается, трафик бегает. Но! на wds-клиенте в бридже в arp-таблице на радио-интерфейсе (который является wds-client) имеется всего 2 MAC-адреса: локальный и мак точки доступа. В результате весь трафик, который должен уходить через данный летит во все интерфейсы.

Помогло поднятие туннеля между AP и wds-client и добавление его вместо стандартных интерфейсов в бридж.

Скидываю настройки интерфейсов:

AP:

0 R name="wlan1" mtu=1500 mac-address=00:21:91:7E:7C:C8 arp=enabled disable-running-check=no interface-type=Atheros AR5213 radio-name="0021917E7CC8" mode=bridge ssid="inb"

area="" frequency-mode=superchannel country=no_country_set antenna-gain=0 frequency=2337 band=2.4ghz-g-turbo scan-list=default rate-set=default

supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=1Mbps basic-rates-a/g=6Mbps

max-station-count=2007 ack-timeout=dynamic tx-power-mode=default noise-floor-threshold=default periodic-calibration=default periodic-calibration-interval=60

burst-time=disabled dfs-mode=none antenna-mode=ant-a wds-mode=static wds-default-bridge=bridg1 wds-default-cost=100 wds-cost-range=50-150 wds-ignore-ssid=yes

update-stats-interval=disabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0 default-client-tx-limit=0 proprietary-extensions=post-2.9.25

hide-ssid=no security-profile=default disconnect-timeout=3s on-fail-retry-time=100ms preamble-mode=both compression=no allow-sharedkey=no

 

0 R name="wds1" mtu=1500 mac-address=00:21:91:7E:7C:C8 arp=enabled disable-running-check=no master-interface=wlan1 wds-address=00:21:91:7E:80:11

 

Client:

0 R name="wlan1" mtu=1500 mac-address=00:21:91:7E:80:11 arp=enabled disable-running-check=no interface-type=Atheros AR5213 radio-name="0021917E8011" mode=station-wds

ssid="inb" area="" frequency-mode=superchannel country=no_country_set antenna-gain=0 frequency=2437 band=2.4ghz-g-turbo

scan-list=2312,2317,2322,2327,2332,2337,2342,2347,2352,2357,2362,2367,2372,2377,2382,

2387,2392,2397,2402,2407,2412,2417,2422,2427,2432,2437,2442,2447,2452,2457,2462,

2

467,

2472,2477,2482,2487,2492,2497,2314,2319,2324,2329,2334,2339,2344,2349,2354,2359,

2364,2369,2374,2379,2384,2389,2394,2399,2404,2409,2414,2419,2424,2429,2434,2439,

2444,2449,2454,2459,2464,2469,2474,2479,2484,2489,2494,2499

rate-set=default supported-rates-b=1Mbps,2Mbps,5.5Mbps,11Mbps supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b=1Mbps

basic-rates-a/g=6Mbps max-station-count=2007 ack-timeout=dynamic tx-power-mode=default noise-floor-threshold=default periodic-calibration=default

periodic-calibration-interval=60 burst-time=disabled dfs-mode=none antenna-mode=ant-a wds-mode=static wds-default-bridge=bridge1 wds-default-cost=100

wds-cost-range=50-150 wds-ignore-ssid=yes update-stats-interval=disabled default-authentication=yes default-forwarding=yes default-ap-tx-limit=0

default-client-tx-limit=0 proprietary-extensions=post-2.9.25 hide-ssid=no security-profile=default disconnect-timeout=3s on-fail-retry-time=100ms preamble-mode=both

compression=yes allow-sharedkey=no

Edited by poul

Share this post


Link to post
Share on other sites

если интерфейсы в бридже, то трафик и должен идти на все интерфейсы...

проблема решается простым добавлением фильтра на drop трафика между

интерфейсами.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this