Jump to content
Калькуляторы

Роутинг в Cisco

Cat 6506

 

interface GigabitEthernet1/1

description Uplink1

ip address 10.0.0.1 255.255.255.252

 

interface GigabitEthernet1/2

description Uplink2

ip address 10.0.1.1 255.255.255.252

 

ip route 0.0.0.0 0.0.0.0 10.0.0.1

ip route 0.0.0.0 0.0.0.0 10.0.1.1

 

Интересует вот что:

Когда оба линка исправны и активны пакеты роутятся поровну. Поочереди.

Что будет если :

a. Пропадет физический линк на GigabitEthernet1/1 , как будут роутится пакеты ? По прежнему поровну ? и половина будет потеряна ?

b. Физический линк не пропадет но устройство на той стороне - например повиснет ? как тогда ?

 

Можно ли добится отказоустойчивости такой схемы без использования IP SLA ?

Share this post


Link to post
Share on other sites

а почему бы вам не использовать протоколы динамической маршрутизации...... (OSPF или EIGRP)

они как-то погибче будут в плане настроек отказоустойчивости

Share this post


Link to post
Share on other sites

а при текущей схеме маршрутизации если один линк упадет, то все будет роутиться через второй без потерь.

а если удаленный маршрутизатор повиснет, но линк не упадет, то потери пакетов неизбежны.

при использовании динамических протоколов все проще. если удаленный маршрутизатор не присылает эхо-реплай, то маршрут в его сторону не анонсируется в таблице маршрутизации и весь трафик идет по другому линку.

Share this post


Link to post
Share on other sites

a. все пойдет в оставшуюся дырку.

b. половина пакетов улетит в пустоту.

Share this post


Link to post
Share on other sites

Наверно самое простое получить от обеих по BGP "default route".

Тогда еще вопрос. Можно ли "default route" полученный по BGP от одного из аплинков пометить метрикой 1. А от другого метрикой 2. ?

как ?

 

Share this post


Link to post
Share on other sites
Наверно самое простое получить от обеих по BGP "default route".

Тогда еще вопрос. Можно ли "default route" полученный по BGP от одного из аплинков пометить метрикой 1. А от другого метрикой 2. ?

как ?

Да, можно:

 

router bgp xxx

neighbor x.x.x.x route-map set-metric in

!

ip prefix-list 1 permit 0.0.0.0/0

!

route-map set-metric permit 10

match ip address prefix-list 1

set metric 1

!

end

Edited by applx

Share this post


Link to post
Share on other sites

>ip prefix-list 1 permit 0.0.0.0/0

 

А не получится, что под этот фильтр попадут любые префиксы ? А не только default route...

Edited by Ivan Rostovikov

Share this post


Link to post
Share on other sites

Не получится. Проверено.

Share this post


Link to post
Share on other sites
>ip prefix-list 1 permit 0.0.0.0/0

 

А не получится, что под этот фильтр попадут любые префиксы ? А не только default route...

как раз таки он пропускает только дефoлт a вот ip prefix-list 1 permit 0.0.0.0/0 le 32 пропускает все

 

 

 

Share this post


Link to post
Share on other sites

Не получится. Проверено.

плохо проверяли

Share this post


Link to post
Share on other sites

плохо проверяли

Почему же? Всё правильно я сказал. Да и вы тоже.

Share this post


Link to post
Share on other sites
плохо проверяли
Почему же? Всё правильно я сказал. Да и вы тоже.

так а что именно у вас не работает? этот префикс пропускает только дефол это 100%, на счет этого можно даже не спорить. если вы на счет метрики то если сделать redistribute етого дефолта в другой протокол то все заработает как надо.

Share this post


Link to post
Share on other sites
так а что именно у вас не работает? этот префикс пропускает только дефол это 100%, на счет этого можно даже не спорить. если вы на счет метрики то
У меня всё работает :D И я именно это и говорил :) прочтите ещё раз :)

 

А не получится, что под этот фильтр попадут любые префиксы ?
Не получится. Проверено.

:)

Share this post


Link to post
Share on other sites
так а что именно у вас не работает? этот префикс пропускает только дефол это 100%, на счет этого можно даже не спорить. если вы на счет метрики то
У меня всё работает :D И я именно это и говорил :) прочтите ещё раз :)

 

А не получится, что под этот фильтр попадут любые префиксы ?
Не получится. Проверено.

:)

 

аа ну просто между строчек читал =)) простите уж ^_^

Share this post


Link to post
Share on other sites

Для чистого тракинга лучше использовать bfd, а не bgp.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this