Jump to content
Калькуляторы

трабл с EIGRP мультикастовые пакеты не пролезают

Добрый вечер!

 

Есть два роутера -- в Москве и в Питере

Между городами арендованный L2-канал, с обоих сторон приходит в виде шнурка, включенного в аксессный порт свитча

На обоих роутерах поднят EIGRP в одной AS.

Оба в одной сетке /30

 

Суть траблы: роутеры не видят HELLO-пакеты друг друга, хотя UPDATE пролезают нормально

Судя по статистике загрузки, такая фигня началась где-то в середине марта (до меня)

 

Понятно, что проблема с пролезанием в канал мультикаста, единственное, что непонятно -- с моей стороны или со стороны канального провайдера.

 

На всякий случай,

Москва:

WS-C3550-24-SMI, Cisco 7206VXR (NPE-G2)

interface FastEthernet0/18
description SPB_LINK 10 Mb/s
switchport access vlan 310
switchport mode access
switchport nonegotiate
duplex full
speed 10
no cdp enable
spanning-tree portfast
spanning-tree bpdufilter enable
end

 

Питер:

WS-C2950-24, cisco 3660 (R527x)

interface FastEthernet0/11
description L2 link to Moscow
switchport access vlan 50
switchport mode access
no ip address
load-interval 30
no cdp enable
spanning-tree portfast
end

 

 

Спасибо!

Edited by evghoul

Share this post


Link to post
Share on other sites

Если есть возможность, то сделайте mirror порта и посмотрите что приходит через wireshark и что не приходит

Share this post


Link to post
Share on other sites
Если есть возможность, то сделайте mirror порта и посмотрите что приходит через wireshark и что не приходит
Спасибо,

но чересчур муторно,

этот вариант отложил на крайний случай

 

 

Выяснилось еще вот что:

Из Питера:

spb-c3660-gw1#ping 224.0.0.10

Москва отвечает

 

Из Москвы:

M9-NPE-G2#ping 224.0.0.10

Отвечают все кроме Питера.

 

Еще больше захотелось выяснить, у меня или у оператора трабл.

 

Share this post


Link to post
Share on other sites
Если есть возможность, то сделайте mirror порта и посмотрите что приходит через wireshark и что не приходит
Спасибо,

но чересчур муторно,

этот вариант отложил на крайний случай

 

 

Выяснилось еще вот что:

Из Питера:

spb-c3660-gw1#ping 224.0.0.10

Москва отвечает

 

Из Москвы:

M9-NPE-G2#ping 224.0.0.10

Отвечают все кроме Питера.

 

Еще больше захотелось выяснить, у меня или у оператора трабл.

Попробуйте прописать команду neighbor, таким образом EIGRP будет использовать unicast вместо multicast в случае если ваш проваидер его фильтрует.

 

Share this post


Link to post
Share on other sites
Если есть возможность, то сделайте mirror порта и посмотрите что приходит через wireshark и что не приходит
Спасибо,

но чересчур муторно,

этот вариант отложил на крайний случай

 

 

Выяснилось еще вот что:

Из Питера:

spb-c3660-gw1#ping 224.0.0.10

Москва отвечает

 

Из Москвы:

M9-NPE-G2#ping 224.0.0.10

Отвечают все кроме Питера.

 

Еще больше захотелось выяснить, у меня или у оператора трабл.

Попробуйте прописать команду neighbor, таким образом EIGRP будет использовать unicast вместо multicast в случае если ваш проваидер его фильтрует.

Так уже сделал, как временное решение, но динамическое установление соседства все-таки поинтереснее.

Share this post


Link to post
Share on other sites
Если есть возможность, то сделайте mirror порта и посмотрите что приходит через wireshark и что не приходит
Спасибо,

но чересчур муторно,

этот вариант отложил на крайний случай

 

 

Выяснилось еще вот что:

Из Питера:

spb-c3660-gw1#ping 224.0.0.10

Москва отвечает

 

Из Москвы:

M9-NPE-G2#ping 224.0.0.10

Отвечают все кроме Питера.

 

Еще больше захотелось выяснить, у меня или у оператора трабл.

Дебагом на обоих цисках смотрите какие пакеты летят при пинге, только ограничивайте акцесс листом, чтоб не повесился маршрутизатор

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this