Jump to content
Калькуляторы

EoMPLS Настройка L2 MPLS

Вобщем есть схема. комп-----2851-----2851-----комп пытаюсь настроить между ними EoMPLS .

 

конфиг первой

 

interface Loopback0

description --Main IP ---

ip address 94.xx.xx.x 255.255.255.255

ip flow egress

 

 

interface Tunnel143

description ------

ip address 10.20.20.121 255.255.255.252

mpls ip

tunnel source 94.xx.xx.x адрес лупбека

tunnel destination 94.xx.xx.x адрес лупбека другой циски

tunnel mode ipip

 

 

interface GigabitEthernet0/0.396

description --

encapsulation dot1Q 396

ip flow egress

ip virtual-reassembly

xconnect 10.20.20.122 123 encapsulation mpls

 

 

конфиг второй

 

interface Loopback0

description --Main IP ---

ip address 94.xx.xx.x 255.255.255.255

 

 

interface Tunnel143

description --- Tunnel MCHS Krasnodar---

ip address 10.20.20.122 255.255.255.252

mpls ip

tunnel source 94.xx.xx.x адрес лупбека

tunnel destination 94.xx.xx.x адрес лупбека другой циски

tunnel mode ipip

 

interface GigabitEthernet0/0.396

description --- ---

encapsulation dot1Q 396

xconnect 10.20.20.121 123 encapsulation mpls

 

 

Далее тунели установились

 

второй

 

sh mpls ldp neighbor

Peer LDP Ident: 10.20.20.121:0; Local LDP Ident 10.20.20.122:0

TCP connection: 10.20.20.121.646 - 10.20.20.122.41979

State: Oper; Msgs sent/rcvd: 866/859; Downstream

Up time: 12:18:16

LDP discovery sources:

Tunnel143, Src IP addr: 10.20.20.121

Targeted Hello 10.20.20.122 -> 10.20.20.121, active, passive

Addresses bound to peer LDP Ident:

 

sh mpls l2transport vc 123 detail

Local interface: Gi0/0.396 up, line protocol up, Eth VLAN 396 up

Destination address: 10.20.20.121, VC ID: 123, VC status: up

Output interface: Tu143, imposed label stack {18}

Preferred path: not configured

Default path: active

Next hop: point2point

Create time: 12:25:33, last status change time: 12:19:34

Signaling protocol: LDP, peer 10.20.20.121:0 up

MPLS VC labels: local 19, remote 18

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface description: --

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 33359

byte totals: receive 0, send 3147495 смущает что receive 0

packet drops: receive 0, seq error 0, send 0

 

Первый

 

sh mpls ldp neighbor

Peer LDP Ident: 10.20.20.122:0; Local LDP Ident 10.20.20.121:0

TCP connection: 10.20.20.122.41979 - 10.20.20.121.646

State: Oper; Msgs sent/rcvd: 863/870; Downstream

Up time: 12:21:18

LDP discovery sources:

Tunnel143, Src IP addr: 10.20.20.122

Targeted Hello 10.20.20.121 -> 10.20.20.122, active, passive

Addresses bound to peer LDP Ident:

 

 

sh mpls l2transport vc 123 detail

Local interface: Gi0/0.396 up, line protocol up, Eth VLAN 396 up

Destination address: 10.20.20.122, VC ID: 123, VC status: up

Output interface: Tu143, imposed label stack {19}

Preferred path: not configured

Default path: active

Next hop: point2point

Create time: 12:22:40, last status change time: 12:21:54

Signaling protocol: LDP, peer 10.20.20.122:0 up

MPLS VC labels: local 18, remote 19

Group ID: local 0, remote 0

MTU: local 1500, remote 1500

Remote interface

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 14709

byte totals: receive 0, send 1605332

packet drops: receive 0, seq error 0, send 0

 

 

Вроде все установилось но receive 0 смущает и еще ничего не работает. может кто сталкивался ?

Share this post


Link to post
Share on other sites

Разве на ipip туннеле может работать больше одного протокола ? (ip+mpls)

Попробуйте GRE. Ну и не забывайте про mtu.

Share this post


Link to post
Share on other sites
Разве на ipip туннеле может работать больше одного протокола ? (ip+mpls)

Попробуйте GRE. Ну и не забывайте про mtu.

 

Вот этого к сожелению не знаю поэтому и спрашиваю, это первый мой опыт с mpls.

Share this post


Link to post
Share on other sites
Разве на ipip туннеле может работать больше одного протокола ? (ip+mpls)

Попробуйте GRE. Ну и не забывайте про mtu.

 

Вот этого к сожелению не знаю поэтому и спрашиваю, это первый мой опыт с mpls.

 

Все заработало спасибо, работает только если GRE тунель.

Share this post


Link to post
Share on other sites

Появилась очередная проблема. на маршрутизаторы был залит иос не поддерживающий mpls, соответвенно все что связано с настройкой мплс было удалено с конфига, откатился на предыдущий иос, настроил как описано выше и понеслось......

sh mpls l2transport vc 123 detail

Local interface: Gi0/0.396 up, line protocol up, Eth VLAN 396 up

Destination address: 10.20.20.122, VC ID: 123, VC status: down

Output interface: none, imposed label stack {}

Preferred path: not configured

Default path: no route

Next hop: Invalid MOI

Create time: 01:19:28, last status change time: 01:19:28

Signaling protocol: LDP, peer 10.20.20.122:0 down

MPLS VC labels: local 97, remote unassigned

Group ID: local 0, remote unknown

MTU: local 1500, remote unknown

Remote interface description:

Sequencing: receive disabled, send disabled

VC statistics:

packet totals: receive 0, send 0

byte totals: receive 0, send 0

packet drops: receive 0, seq error 0, send 0

 

В логах пишет следующее ATOM_TRANS-4-CONFIG: 10.20.20.122 mismatches the peer router id 94.хх.хх.х

 

 

show mpls ldp neighbor

Peer LDP Ident: 94.хх.ххх.х:0; Local LDP Ident 94.ххх.хх.х:0

TCP connection: 94.хх.ххх.х.34327 - 94.хх.хх.х.646

State: Oper; Msgs sent/rcvd: 33/34; Downstream

Up time: 00:16:53

LDP discovery sources:

Tunnel143, Src IP addr: 10.20.20.122

Addresses bound to peer LDP Ident:

10.20.20.122

в соседях почему то пишет внешние адреса лупбаков маршрутизаторов которые в свою очередь являются в тунелях source и destination когда раньше писал именно внутренние адреса туннелей..... подскажите куда копать....

 

 

Share this post


Link to post
Share on other sites

Я вижу два пути:

1. Неправильный. Сказать что-то вроде mpls ldp router-id <адрес на тоннеле> И перегрузить коробки.

2. Правильный. Сказать mpls ldp router-id <адрес Loopback> и переписать xconnect так, чтобы в качестве адреса в них был адрес Loopback.

Edited by nnm

Share this post


Link to post
Share on other sites

Зачем вам сабинтерфайс если у вас два компа и нет комутатора который посылает таги с виланом 396?

 

int gi0/0

no ip add

mpls ip

xconnect x.x.x.x 100 encap mpls

 

кроссконект должен терминироватса на лоопбаке другой киски.

 

и использовать:

 

mpls ldp router-id loop_X force

Edited by applx

Share this post


Link to post
Share on other sites

И еше вопрос, зачем изврашатса с двумя рутерами и мплс да еше с использованием тунелей. Кросконект с вашей схемой вообше не нужен, советую скачать ГНС3 и там попрактиковатса если нужен опыт именно с ЕоМПЛС.

Share this post


Link to post
Share on other sites

до маршрутизаторов естественно стоят коммутаторы, и клиентов порядком, для этого и подняты субинтерфейсы (в шапке просто образно описана проблема)....тунелями соединяю непосредственно через инет роутеры. проблема на данном этапе решилась по совету nnm прописыванием mpls ldp router-id <адрес на тоннеле> force на обоих роутерах. но мне самое интересное что до обновления иоса настраивал именно на лупбеках и все летало..... в чем подвох не пойму....

Share this post


Link to post
Share on other sites

Allexx, я думаю дело не в обновлении, а в перезагрузке.

До перезагрузки router-id был другим из-за порядка применения настроек.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this