Jump to content
Калькуляторы

7401asr vpdn постоянный ребут при попытке запустить пользователей Cisco уходит в ребут

Всем привет !

Настроил pptp сервер на 7401, связали авторизацию с radius, настроили ospf маршрутизацию (для обмена маршрутизацией с шлюзом). Конфиги в общем то без особых наворотов, в инете типичных встречали много.

НО проблема состоит в следующем ИОС более старой версии на нем были бока с аплоадом не доходил даже до 1 мегабита при оличном довнлоаде..

Аплоад исправили обновлением ИОС на 12,4,21 но вылезла другая проблема .. при попытке запустить пользователей число которых доходит до 40 Cisco уходит в ребут, после ребута число пользователей может дойти до 120 потом опять ребут...

Хотя до этого тестировали около двух недель но при этом было всего три pptp сессии она в ребут не уходила ...

В чем может быть проблема ... привожу конфиг ....

=================================

 

Cisco IOS Software, 7400 Software (C7400-IK9O3S-M), Version 12.4(12), RELEASE SOFTWARE (fc1)

 

=================================

 

version 12.4

no parser cache

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname vpnx

!

boot-start-marker

boot system disk0:c7400-ik9o3s-mz.124-12.bin

boot config disk0:vpn.startup-config.conf nvbypass

boot-end-marker

!

enable secret 5 хххххххх

enable password ххххххх

!

aaa new-model

aaa authentication login default local-case

aaa authentication ppp default group radius

aaa authorization exec default local

aaa authorization network default group radius

aaa accounting delay-start

aaa accounting update periodic 5

aaa accounting network default start-stop group radius

!

aaa pod server clients 10.0.х.х auth-type any server-key ххххххх

aaa session-id common

clock timezone EET 2

clock summer-time EEST recurring

!

!

ip cef

no ip domain lookup

ip name-server 195.149.х.х

!

!

vpdn enable

!

vpdn-group PPTP

! Default L2TP VPDN group

! Default PPTP VPDN group

description PPTP server for Win clients

accept-dialin

protocol any

virtual-template 1

pptp tunnel echo 10

 

 

 

interface GigabitEthernet0/0

ip address 10.0.х.х 255.255.255.0

duplex auto

speed auto

media-type gbic

negotiation auto

!

interface GigabitEthernet0/1

ip address 195.149.хх.хх 255.255.255.224

ip ospf authentication message-digest

ip ospf message-digest-key 1 md5 хххххххххххх

ip ospf network broadcast

ip ospf priority 0

duplex auto

speed auto

media-type gbic

negotiation auto

!

interface Virtual-Template1

ip unnumbered GigabitEthernet0/1

no ip proxy-arp

no logging event link-status

autodetect encapsulation ppp

no snmp trap link-status

peer ip address forced

no peer default ip address

no keepalive

ppp authentication ms-chap-v2 ms-chap

ppp ipcp dns 195.149.х.х

router ospf 1

router-id 195.149.х.х

log-adjacency-changes

area 195.149.х.х authentication message-digest

redistribute connected subnets

passive-interface default

no passive-interface GigabitEthernet0/1

network 195.149.х.хх 0.0.0.31 area 195.149.х.х

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 195.149.х.хх

ip route 10.0.0.0 255.0.0.0 10.0.х.х

ip route 192.168.0.0 255.255.0.0 10.0.х.х

!

no ip http server

no ip http secure-server

!

!

ip radius source-interface GigabitEthernet0/0

!

!

!

radius-server host 10.0.х.х auth-port 1812 acct-port 1813

radius-server key ххххххххх

radius-server authorization default Framed-Protocol ppp

radius-server vsa send accounting

radius-server vsa send authentication

!

control-plane

!

!

gatekeeper

shutdown

!

!

line con 0

transport output all

line aux 0

transport output all

line vty 0 4

password хххххх

transport preferred telnet

transport input all

transport output all

line vty 5 15

transport input all

transport output all

!

ntp clock-period 17180001

ntp server 10.0.х.хх

!

end

Edited by mik_kir

Share this post


Link to post
Share on other sites

Попробуйте поправить в темплейте

> ip unnumbered GigabitEthernet0/1

на не физический интерфейс, а на loopback

Share this post


Link to post
Share on other sites
Попробуйте поправить в темплейте

> ip unnumbered GigabitEthernet0/1

на не физический интерфейс, а на loopback

 

Не помогло :((( 20 человек и сразу ребут

У кого то будут еще какие то идеи ??

Share this post


Link to post
Share on other sites

12(4)-21 показал себя как исключительно глючный софт.

ставте 12(3)-26

Share this post


Link to post
Share on other sites
12(4)-21 показал себя как исключительно глючный софт.

ставте 12(3)-26

Ответный вопрос :) есть у кого нить в закромах ?? на 7400 12(3)-26 :) Буду благодарен

Share this post


Link to post
Share on other sites

у меня нормально скачивается все

Share this post


Link to post
Share on other sites

А можеш перезалить ну на рапиду например если не сложно

Share this post


Link to post
Share on other sites
12(4)-21 показал себя как исключительно глючный софт.

ставте 12(3)-26

НЕ помогло простояла минут 30 набрала на себя 90 человек и опять ушла в ребут :(

Share this post


Link to post
Share on other sites

была ситуация при которой помогало

ip route-cache flow

no ip route-cache cef

 

на физ. интерфейсах

а вообще как показала практика в качестве NAS - оно не очень. в качестве BGP бордера намного стабильнее работает.

Share this post


Link to post
Share on other sites
была ситуация при которой помогало

ip route-cache flow

no ip route-cache cef

 

на физ. интерфейсах

а вообще как показала практика в качестве NAS - оно не очень. в качестве BGP бордера намного стабильнее работает.

Ну статистику по нетфлоу мы не собираем ....

Сегодня пробывали еще раз простояла два часа 110 человек загрузка проца почти 90 % потом при попытке посмотреть конфиг на ней она ушла в креш ....

IP Input грузит проц капец просто

Edited by mik_kir

Share this post


Link to post
Share on other sites

ну так при 90%

sh proc cpu sort | ex 0.00

Share this post


Link to post
Share on other sites

CPU utilization for five seconds: 98%/55%; one minute: 98%; five minutes: 96%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

55 1028748 503771 2042 38.47% 40.18% 39.64% 0 IP Input

21 26340 68622 383 1.19% 1.54% 1.18% 0 ARP Input

90 54640 1737 31456 0.39% 1.58% 1.62% 0 VTEMPLATE Backgr

156 12400 64468 192 0.39% 0.44% 0.44% 0 PPTP Data

168 3296 4529 727 0.39% 0.16% 0.16% 0 OSPF Router

155 7160 24225 295 0.31% 0.26% 0.24% 0 PPTP Mgmt

160 7656 51539 148 0.31% 0.27% 0.26% 0 PPP Events

34 1760 1327 1326 0.31% 0.11% 0.08% 0 Per-Second Jobs

159 2732 41712 65 0.23% 0.11% 0.10% 0 PPP manager

3 1204 12658 95 0.15% 0.04% 0.04% 0 OSPF Hello

145 1304 267 4883 0.15% 0.06% 0.07% 0 Compute load avg

148 1136 12874 88 0.07% 0.05% 0.05% 0 CCPROXY_CT

163 2320 3058 758 0.07% 0.08% 0.07% 0 RADIUS

85 2040 2047 996 0.07% 0.07% 0.07% 0 CEF process

157 2160 7550 286 0.07% 0.07% 0.08% 0 TCP Driver

 

 

Включили cef загрузка упала до 60% но при 140 активных пптп всетаки многовато

 

vpnx#sh proc cpu sort | ex 0.00

CPU utilization for five seconds: 69%/50%; one minute: 62%; five minutes: 72%

PID Runtime(ms) Invoked uSecs 5Sec 1Min 5Min TTY Process

90 111608 3025 36895 12.15% 6.91% 5.43% 0 VTEMPLATE Backgr

156 25408 131679 192 1.66% 1.52% 1.06% 0 PPTP Data

55 1300216 564160 2304 1.11% 1.04% 13.44% 0 IP Input

21 43280 114095 379 1.11% 1.00% 1.11% 0 ARP Input

155 12308 38775 317 0.87% 0.47% 0.40% 0 PPTP Mgmt

160 12980 77674 167 0.79% 0.48% 0.40% 0 PPP Events

150 1400 13292 105 0.23% 0.07% 0.04% 0 VPDN SSS manager

58 700 2321 301 0.15% 0.03% 0.02% 0 SSS Manager

163 3844 4798 801 0.15% 0.14% 0.12% 0 RADIUS

159 3836 61324 62 0.15% 0.04% 0.05% 0 PPP manager

6 2184 253 8632 0.07% 0.02% 0.04% 0 Check heaps

168 5132 6841 750 0.07% 0.08% 0.12% 0 OSPF Router

85 3000 3003 999 0.07% 0.04% 0.05% 0 CEF process

145 2048 394 5197 0.07% 0.05% 0.06% 0 Compute load avg

158 944 1906 495 0.07% 0.04% 0.02% 0 TCP Listener

157 3904 12527 311 0.07% 0.17% 0.14% 0 TCP Driver

 

При включеном cef уходит в ребут :))))))))))

Edited by mik_kir

Share this post


Link to post
Share on other sites

А сколько у вас трафика и kpps идет через 7401?

Share this post


Link to post
Share on other sites
А сколько у вас трафика и kpps идет через 7401?

Практически ничего

Максимум доходит до 30 мегабит ....Дело не в трафике и kpps, потому что она ребутилась и при 20 активных пользователях.... Дело помоиму в самом cef, без него сегодня потестили постояла максимум два часа но IP Input грузит проц ужас просто ... большие задержки потери пакетов..... при включении cef загрузка на проц падает до минимум 47 и постоянно прыгает в пределах от 47 - 67 и потом ребут.... после ребута набегают пользователи , и что самое главное каждый раз по разному может ребутнуться при 20 онлайнах а может набрать на себя максимум было 200 и ребут...

кажется нужно ковыряться именно с cef но если бы кто то подсказал был бы очень благодарен ... :((((

Да еще что заметил при включенном cef IP Input грузит проц ну максимум до 15 процентов ... что грузит проц до 67 непонятно ибо при sh proc cpu ничего сумарно большого не видно ...

Edited by mik_kir

Share this post


Link to post
Share on other sites

у вас там PXF не выключен?

вообще, что про него циска говорит?

Share this post


Link to post
Share on other sites
у вас там PXF не выключен?

вообще, что про него циска говорит?

Чет я pxf вообще не нахожу.

Туплю :)

Походу не выключено ...

Edited by mik_kir

Share this post


Link to post
Share on other sites

vpnx#show pxf info

pxf: tmc type TMC ASIC Pass2 (T2-ECC) revision 2

ucode: filename 'system:pxf/ucode0' revision 1.1

state: is running, number of starts 1

uptime: 03:35:36

Memory Configuration:

Bank Name Total Reserved In-use Free

tmc internal memory column 0 16 Kb 2048 bytes 0 bytes 14 Kb

tmc column 0 memory bank 0 32 Mb 31 Mb 0 bytes 368 Kb

tmc internal memory column 1 16 Kb 512 bytes 0 bytes 15 Kb

tmc column 1 memory bank 0 32 Mb 590 Kb 2003 Kb 29 Mb

tmc internal memory column 2 16 Kb 4608 bytes 0 bytes 11 Kb

tmc column 2 memory bank 0 32 Mb 697 Kb 584 Kb 30 Mb

tmc internal memory column 3 16 Kb 15 Kb 0 bytes 512 bytes

tmc column 3 memory bank 0 32 Mb 2092 Kb 64 Kb 29 Mb

 

vpnx#show pxf accounting summary

Pkts Dropped RP Processed Ignored

Total 0 8960707 0

 

10 second averages: PXF complex busy: 1% PXF read pipeline full: 0%

 

PXF Statistic:

Packets RP -> PXF:

switch ip: 0

switch raw: 8964520

qos fastsend: 0

qos enqueue: 0

Total: 8964520

 

Packets PXF -> RP:

qos pkts: 0

fast pkts: 3813

drops: total 0

punts: total 8960707

" not IP : 253492

" L2 forwarding : 3810957

" IP options : 102

" CEF no adjacency : 240

" CEF receive : 4895879

" IP TTL : 37

Total: 8964520

 

Packets ignored: 43 | ring space:

shadow ring full: 0 | shadow ring: 16382

in ring full: 0 | inring: 1024

PXF inactive: 43

 

tx credits: 0 | delayed credits: 0

holdq enqueues: 0 | requeue drops: 0

interrupts: 5978699 | pipeline pkts/bytes: 1/68

L2TP tunnel read: 0 | session stats: 0

 

Interface Pkts In Chars In Pkts Out Chars Out Punted Dropped

Gi0/0 0 0 0 0 4883976 0

Gi0/1 3813 524982 3812 524908 4076731 0

Vi1 0 0 0 0 0 0

Vt1 0 0 0 0 0 0

Vi2 0 0 0 0 0 0

Vi3 0 0 0 0 0 29

Vi4 0 0 0 0 0 6214

Vi5 0 0 0 0 0 113

Vi6 0 0 0 0 0 0

Vi7 0 0 0 0 0 14453

Vi8 0 0 0 0 0 0

Vi9 0 0 0 0 0 26

Vi10 0 0 0 0 0 1110

Vi11 0 0 0 0 0 0

Vi12 0 0 0 0 0 66

Vi13 0 0 0 0 0 0

Vi14 0 0 0 0 0 0

Vi15 0 0 0 0 0 0

Lo0 0 0 0 0 0 0

vpnx#

 

 

vpnx#sh pxf interfaces

Intf I/f # Attributes

Gi0/0 4 Raw, Encap

Gi0/1 3 Raw, Encap

 

Edited by mik_kir

Share this post


Link to post
Share on other sites

Я после долгих переборов остановился на c7400-is-mz.123-5d.bin

Более свежие из имеющихся ребутились регулярно, у меня правда pppoe...

Share this post


Link to post
Share on other sites
Я после долгих переборов остановился на c7400-is-mz.123-5d.bin

Более свежие из имеющихся ребутились регулярно, у меня правда pppoe...

А есть в наличии c7400-is-mz.123-5d.bin сможеш выложить куда нибудь

Буду признателен

Edited by mik_kir

Share this post


Link to post
Share on other sites
Я после долгих переборов остановился на c7400-is-mz.123-5d.bin

Более свежие из имеющихся ребутились регулярно, у меня правда pppoe...

А есть в наличии c7400-is-mz.123-5d.bin сможеш выложить куда нибудь

Буду признателен

Поройтесь тут: ссылка

Выбираем чего надо, качаем и живем - не тужим.

 

Вопрос по теме в целом: pxf выключать пробовали?

Share this post


Link to post
Share on other sites
Я после долгих переборов остановился на c7400-is-mz.123-5d.bin

Более свежие из имеющихся ребутились регулярно, у меня правда pppoe...

А есть в наличии c7400-is-mz.123-5d.bin сможеш выложить куда нибудь

Буду признателен

Поройтесь тут: ссылка

Выбираем чего надо, качаем и живем - не тужим.

 

Вопрос по теме в целом: pxf выключать пробовали?

Спасибо попробуем что то подобрать хотя из 123 ветки перебрали 16 и 26 всеравно ребут

pxf отключать не пробывали ...после праздников уже займемся опять тестами ...

Спасибо ....

Кстати c7400-is-mz.123-5d.bin которую советовали месагой выше там нету

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this