Jump to content
Калькуляторы

Падение PPPoE

Люди добрые, помогите!!!!!

 

Есть 2 NASa + Catalyst 3560...между ними бегает OSPF (см. схемку)...на НАСах сетевухи Intel Dual Port E1G42ET (чипсет 82576)...2-ю неделю не можем победить....падают PPPoE-сессий у пользователей....

не с того не с сего пропадает связь с концом тоннеля... сесия умирает только по таймауту со стороны сервера....у соседей в этом же Vlane в это время все отлично...

смотрели в сторону loopback, в сторону вирусни, OSPF...нормально вроде...грешим на Catalyst и сетевухи....Може подскажете чего...

post-55913-1273057097_thumb.jpg

Share this post


Link to post
Share on other sites

Ээээ... Не спец по этому вопросу, но схемка один в один наша. И беда подобная вашей была года два назад. Пропадали (тупо исчерзали маки абонентов, из-за чего терялась PPPoE сессия). Связана была с ограничением количества PPPoE сессий внутри определенной VLAN. (По дефолту там максиму 300 сессий) Увеличили, по сей день все бегает (тьфу-тьфу-тьфу!) В эту сторону не копали?

Share this post


Link to post
Share on other sites
Ээээ... Не спец по этому вопросу, но схемка один в один наша. И беда подобная вашей была года два назад. Пропадали (тупо исчерзали маки абонентов, из-за чего терялась PPPoE сессия). Связана была с ограничением количества PPPoE сессий внутри определенной VLAN. (По дефолту там максиму 300 сессий) Увеличили, по сей день все бегает (тьфу-тьфу-тьфу!) В эту сторону не копали?

 

ОООО!!! Спасибо! подскажи где копать и покапаем)))....И отпишимся!!!

Edited by zep

Share this post


Link to post
Share on other sites

Не в курсе по деталям, ибо не цискарь =((

Сейчас спрошу у наших. но за оперативность ответа не ручаюсь.

От себя добавлю, лечился наш случай двумя способами:

1. Изменить это дефолтное значение ограничивающее количество маков в вилане. Причем на всех устройствах участвующих передаче данных.

2. Добавить еще несколько VLAN авторизации.

Edited by Basilicus

Share this post


Link to post
Share on other sites

После 3560 еще комутаторы "на доступе" есть ?

У меня такое было из-за слабой кеш-функции на свичах доступа. Сегметировал сеть - как рукой сняло.

Share this post


Link to post
Share on other sites
После 3560 еще комутаторы "на доступе" есть ?

У меня такое было из-за слабой кеш-функции на свичах доступа. Сегметировал сеть - как рукой сняло.

 

за Каталистом стоят Edge-Core 3526S за ними простенькие мыльницы.....

Edited by zep

Share this post


Link to post
Share on other sites
После 3560 еще комутаторы "на доступе" есть ?

У меня такое было из-за слабой кеш-функции на свичах доступа. Сегметировал сеть - как рукой сняло.

Разговор о 3028-х ДЛинках? - если да, то насколько крупными были сегменты, что слабая хэш-функция проявила себя?

Share this post


Link to post
Share on other sites

еще один ньюанс...pptpd работает без разрывов....

Share this post


Link to post
Share on other sites
После 3560 еще комутаторы "на доступе" есть ?

У меня такое было из-за слабой кеш-функции на свичах доступа. Сегметировал сеть - как рукой сняло.

Разговор о 3028-х ДЛинках? - если да, то насколько крупными были сегменты, что слабая хэш-функция проявила себя?

Да. 3028.

Мак-таблица содержала по 1000 и более строк. Причем "слабость" проявлялась на конкретных сочетаниях мак-влан.

 

Share this post


Link to post
Share on other sites
еще один ньюанс...pptpd работает без разрывов....

Значит дело не в свичах - если третий уровень работает нормально то второй тем более должен работать. разве что на свичах имееено проблема с пппое - но это маловероятно

 

Share this post


Link to post
Share on other sites

Если на PPPoE-сервере в свойствах PPP-соединений включить LQR, это помогает?

Share this post


Link to post
Share on other sites
Если на PPPoE-сервере в свойствах PPP-соединений включить LQR, это помогает?

Как я понял LQR есть только во FreeBSD.

 

Проверили все коммутаторы на переполнение таблиц МАС - все в порядке. Подмены МАС в сети тоже нет.

 

Даже пропадает иногда связь по PPPoE с офисных машин (на одной может замереть, а на остальных работает), которые включены в отдельном VLANе и в отдельный порт каталиста. В логах PPPoE сервера неоднократно было замечено LCP Echo Failure. Интервал LCP был увеличен в несколько раз, но положительного результата не дало.

 

В зоопарке есть еще один простенький сервачок под Ubuntu, на нем та же система, но без OSPF (quagga, zebra) и сетевая карта там обычный Intel Pro 1000 на драйвере e1000, около 100 сессий vpn & pppoe - и "небыло не единого разрыва" .... Есть все-таки подозрение на корявость драйвера IGB

Edited by zep

Share this post


Link to post
Share on other sites

В момент существования проблемы проверяйте наличие абонентского мак адреса на ВСЕХ свичах по цепочке. Гдето он теряется. Найдите где.

Share this post


Link to post
Share on other sites
В момент существования проблемы проверяйте наличие абонентского мак адреса на ВСЕХ свичах по цепочке. Гдето он теряется. Найдите где.

 

Даже пропадает иногда связь по PPPoE с офисных машин (на одной может замереть, а на остальных работает), которые включены в отдельном VLANе и в отдельный порт каталиста...

 

 

P.S. Предыдущий пост дополнил

 

post-55913-1273134224_thumb.png

Edited by zep

Share this post


Link to post
Share on other sites

monitor session абонентского порта на каталисте и если потребуется порта PPPoE сервера.

wireshark или tcpdump (в зависимости от вероисповедания)

 

На мой взгляд единственная причина такого поведения - невозможность доставки пакета коммутатором. По какой причине - незнаю.

Их масса.

Share this post


Link to post
Share on other sites

Почитал man pppoe-server и вот что там нашел:

 

-o offset

Instead of numbering PPPoE sessions starting at 1, they will be numbered starting at offset+1. This allows you to run multiple servers on a given machine; just make sure that their session numbers do not overlap.

 

Наводит на мысль, может при установлении сессии VPN (pptpd) другим клиентом возникает конфликт иной с сессией PPPoE, ведь они работают вместе на одном сервере через прослойку pppd ? Некоторые клиенты жаловались, что у них иногда падает VPN, но небыло замечено до внедрения PPPoE сервера парралельно.

 

Share this post


Link to post
Share on other sites

А может быть на разных NAS выдаются дублирующие IP?

Share this post


Link to post
Share on other sites

на каталисте есть mac address static мак-адрес-пппое-серверов-в-данном-влане ?

Share this post


Link to post
Share on other sites

Вроде бы разобрались. Установили на один из NAS Debian и собрали свежий драйвер igb для сетевой. Пока ничего не падало.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this